Apache Segfaults after Activating Domain Mapping Plugin

I set up this new site because my original site ended up having the same issue I'm about to describe.

After activating the WPMU Domain Mapping plugin I am unable to access my Network settings page. There are no entries in the site error logs but the Apache2 error log shows the following:

[Sun Feb 08 21:06:02.048103 2015] [mpm_prefork:notice] [pid 7526] AH00169: caught SIGTERM, shutting down
[Sun Feb 08 21:06:03.203895 2015] [mpm_prefork:notice] [pid 8611] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.5 OpenSSL/1.0.1f configured -- resuming normal operations
[Sun Feb 08 21:06:03.204009 2015] [core:notice] [pid 8611] AH00094: Command line: '/usr/sbin/apache2'
[Sun Feb 08 21:06:07.213427 2015] [core:notice] [pid 8611] AH00051: child pid 8616 exit signal Segmentation fault (11), possible coredump in /etc/apache2

I believe this has to do with domain mapping as everything was working fine up until I activated it. Deactivating all plugins and reinstalling Wordpress does not fix the issue. I end up having to delete the database and do a full reinstall each time.

This issue affects the Network Settings page as well as the General Settings page for individual sites on the network.

Like I mentioned, this is the second site this is happening to and this time its on a fresh server. Any advice on how to fix this would be appreciated.

  • Vinod Dalvi

    Hi Bill,

    Sorry to hear of the problem you are having.

    I am using latest version of Domain Mapping plugin on my test site but didn't face any issue with it on activating/deactivating it.

    A segementation fault is an internal error in php (or, less likely, apache). Oftentimes, the segmentation fault is caused by one of the newer and lesser-tested php modules such as imagemagick or subversion.

    Try disabling all non-essential modules (in php.ini), and then re-enabling them one-by-one until the error occurs. You may also want to update php and apache if it's old.

    Please let us know which PHP version you are using by using the information provided on the following pages.

    http://www.wikihow.com/Check-PHP-Version
    http://php.about.com/od/troubleshooting/qt/php_version.htm

    Also when you face this issue can you please try enabling WP_DEBUG mode? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);

    You might already have a line for WP_DEBUG, so just make sure it's set to true.

    For information on this, checkout this wpmu.org article.

    Let me know what errors if any you are getting when you face this issue.

    Kind Regards,
    Vinod Dalvi

  • Bill

    I'm running PHP 5.5.9 on Ubuntu 14.04 and Apache 2.4.

    With wp_debug enabled and no PHP modules loaded its still happening Apache throws a 500 error and there's no output to the browser from PHP at all. In my Apache system error log I got another:

    [Sun Feb 08 22:44:08.291232 2015] [mpm_prefork:notice] [pid 3378] AH00169: caught SIGTERM, shutting down
    [Sun Feb 08 22:44:09.343702 2015] [mpm_prefork:notice] [pid 3924] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.5 OpenSSL/1.0.1f configured -- resuming normal operations
    [Sun Feb 08 22:44:09.343811 2015] [core:notice] [pid 3924] AH00094: Command line: '/usr/sbin/apache2'
    [Sun Feb 08 22:45:11.414655 2015] [core:notice] [pid 3924] AH00051: child pid 3928 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Sun Feb 08 22:45:12.415925 2015] [core:notice] [pid 3924] AH00051: child pid 3929 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Sun Feb 08 22:45:13.417038 2015] [core:notice] [pid 3924] AH00051: child pid 3934 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Sun Feb 08 22:45:14.418222 2015] [core:notice] [pid 3924] AH00051: child pid 3932 exit signal Segmentation fault (11), possible coredump in /etc/apache2

    PHP's error log is clean. No errors reported at all. At this point I'm thinking it may have to do with the WPMUDev dashboard plugin instead. I removed the Domain Mapping plugin, deleted all traces of it, dropped my database and re-installed Wordpress again. This time I used a different, free domain mapping plugin and the error didn't occur. However, after activating the WPMU Dashboard plugin I now get the 500 errors again.

    Even if it can't be fixed, I'm hoping we can at least figure out what plugin is doing this and why so I can at least avoid it.

  • Bill

    After reinstalling Wordpress again this morning and enabling the Network it looks like the issue is being caused by the WPMUDev Dashboard plugin. So far I've been able to activate and configure a non-WPMU domain mapping plugin as well as some others and so far there are no errors when accessing the Network Settings or a site's General settings pages.

    I'm not going to use the WPMU Dashboard plugin anymore until we can figure out what's causing it to segfault Apache.

  • Bill

    Last update - hopefully this helps someone in the future. It actually wasn't any of the WPMU plugins causing this issue. The issue had something to do with the way Wordpress installs themes and plugins through its dashboard. I had an FTP user configured with public and private keys to do updates and install plugins via SSH. After using this method to install any plugin (it doesn't matter which one and I tried different ones) for the first time, the settings pages for both the network and each individual site broke.

    Now, I'm still not sure WHY this happened but what fixed it was adding the following line to my wp-config.php file above my FTP constant definitions:

    define('FS_METHOD', 'direct');

    It was previously undefined, then I changed it to 'ssh2' and then finally to 'direct' and everything started working again. Hopefully this is the final solution to this issue.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.