API and curl/fsockopen error message; Whoops, your server is having trouble connecting to the WPMU

The last series of discussions that I've been able to find in the forums on this issue was 2014. None of them had an answer I could use. I just installed the white label videos on a site that is also running the WMPUdev Dashboard, CoursePress and MarketPress. When I installed the videos I got the message, "Whoops, your server is having trouble connecting to the WPMU DEV API! If this problem continues, please contact your host and ask them to "make sure php and any firewall is configured to allow an HTTP GET call via curl or fsockopen to https://premium.wpmudev.org/video-api-register.php."

Both the curl and the fsockopen function are configured properly for port 80, which is standard. There isn't any firewall interference. PHP is version 5.6.21. This is the only plugin that isn't working. What, if anything, am I missing?

  • Nithin

    Hey go4victory,

    Just to be sure, I tried to replicate this in my system, but it works fine. Are you able to install the other plugins from the WPMU DEV Dashboard? Does it work if you try to install plugins from the WordPress repository? ie under Plugins > Add New

    Since this thread is more related to support, I'm moving this thread to support forum, so that we could have access to your site, and get this sorted asap. At the moment you have posted this thread under members forum, which is only used for discussions with other members.

    Could you please check with the host that whether they are blocking any of the listed IPs, as shown below, if yes, please ask them to white list it.

    66.135.60.59
     66.135.49.214
     66.135.60.64
     104.236.238.22
     104.236.50.140

    If you still have issues, please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.