Applying to sites, please wait - stalls

I clicked the apply to site in the settings area and now the plugin seems to stall on 101 of 142 sites updated.

This is the url http://okstateu.com/wp-admin/network/settings.php?privacy_update_all_blogs=step&offset=101

When we try to access the dashboard we get this page/error. "Applying to sites, please wait...
101 of 142 sites updated"

Thoughts?

  • digitsoft
    • The Crimson Coder

    It might be that your php.ini has a low setting for the max_execution_time in your php.ini

    You can check it with this simple script:

    <?php
    phpinfo();
    ?>

    Put that code inside a file named info.php in the root of your site and then open in a browser. Then search for the value max_execution_time - if it's set to 30-60, then increase it to 240.

  • Kimberly
    • Champion of Loops

    Hi!

    Just checking in :slight_smile:

    I'm guessing that because we haven't heard back from you that you've got your issue worked out or that we have reached the end of our convo here. If you are still having problems or need any other answers on this particular topic please feel free to come back to this thread at anytime. Just be sure to mark it Not Resolved so we don't miss it!

    This ticket is only being Resolved due to lack of activity. It is by no means an action to avoid, brush off or minimize your issue. We are ready and here if you want to re-open at any time and I apologize in advance for any lack of communication if this ticket is being closed in error.

    Thanks for using the WPMU Community!

    Best,
    Kimberly

  • aecnu
    • WP Unicorn

    Greetings billhandy,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • heather_chase
    • WPMU DEV Initiate

    I already put this solution in another thread, but I'm putting it here, too, since this was the first result that came up for me in a Google search.

    This plugin sets a cookie in your browser when it does the update process. Go into your browser's cookie storage, find the cookie "privacy_update_all_blogs" and remove it. You should then be able to login to your network dashboard.

    Here's how you do it in Chrome:

    Settings --> Show Advanced Settings --> Content Settings --> All cookies and site data --> type your domain name into the search box --> click your domain name --> select the cookie named "privacy_update_all_blogs" --> Click Remove

    See if you can get into your dashboard.

    This plugin is only one PHP file and one Javascript file with a bit of JQuery. There was no way in the world it could have been timing out my server's maximum execution time of 10 minutes to update the two blogs I had in my freshly installed multisite network. Maybe it stalls if you have hundreds of blogs and a very short max_execution_time set, but if that's the case, the process should just stop and you should get your dashboard back. It shouldn't just hang and keep you locked out.

    But I kept getting the same screen even after I uninstalled and reinstalled the plugin. That meant that either the plugin was setting a variable in the database that didn't get deleted and rewritten during uininstall/reinstall (which would be weird), or... well, I just looked at the plugin's PHP file and saw that it's using cookies (Dev, see line 84 in sitewide-privacy-options.php).

    I hope this is helpful.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.