Appointement pages are so slow

I'm getting a lot 502 server errors when trying to access the appointment page, especially when I click next month button.

  • James Morris

    Hello Federico

    I hope you are well today.

    I was looking into this issue further to try to determine why you are seeing this symptom, but I'm afraid the SFTP details you provided us are not working correctly.

    In order to help you better with your issue, would you please grant me access to your site and server so I can perform some advanced debugging?

    NOTE: Please make a full backup of your site before sending the following information.

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris

    Hello Federico

    After looking at this further, I've been unable to locate the specific cause for the error you're seeing. I've not been able to replicate this on my end. This issue has been flagged for our SLS Team (code experts) so that they can dig into this issue further for you. An update will be posted here as soon as more information is available. Thank you for your patience while we sort through this issue.

    Best regards,

    James Morris

  • Lindeni Mahlalela

    Hello Federico

    I hope you are doing great today. I am so sorry for the delayed response from our side I hope we get this resolved soon.

    I have checked your setup and performed a search about the error online. I found a thread that reports the same issue about a different plugin but on the same host, WP Engine. I then read about the error on WP Engine and they say its because of a time limit, it seems they have set a strict 60 seconds execution time and if a script exceeds that limit the server returns the 5o2 error, which relates to the timeout.

    Now, what I see on your current setup is that the WP Engine CDN is on and there are lots of files returning "404 Not Found" error and most of those files have URIs pointing to the CDN and it seems they don't exist there or the CDN is not properly configured. Also on the admin there are some files that are not found there as well.

    According to a related issue the error is mostly related to the files returning the 404 Not Found error, if the server cannot located the file it may timeout while trying to fetch it and as a result cause the issue at hand.

    What I advice now is that you double check the files exist on your server and or on your CDN, if the files are removed locally on your server they must exist on the CDN, if it some point you disable the CDN the files must exist locally. Also consider updating your plugins and themes to get back the original assets and try disabling minification/asset optimization if you have it as it seems the assets that cannot be found are kind of minified or combined and sent to the CDN.

    I have tried to access the FTP but I can't seem to login successfully, I get a timeout there as well.

    Please try reconfiguring the CDN so that all files are loaded properly and also try to manually increase the timeout by adding the following line of code in wp-config.php file:

    @ini_set("max_execution_time", 180);

    Add this anywhere before the line: /* That's all, stop editing! Happy blogging. */ once you have done that please do your tests again and see how it goes.

    I hope to hear back from you soon, please let us know how it goes and we will be happy to assist in any way possible.

    Have a nice day.
    Lindeni

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.