Appointment blocks locked to service length, not time base

In reference to my reply: https://premium.wpmudev.org/forums/topic/non-standard-appointment-blocks?replies=3#post-883664

The selectable blocks of time are locking to iterations of the length of the selected service, rather than the time base. For instance I have a service set to last 2 hours, and I have my Time Base set to 30 minutes. Despite that, the schedule on my booking page is only showing up in blocks of 2 hours (8.00–10.00, 10.00–12.00, 12.00–2.00, etc.) when I want users to be able to select the service starting at any half hour interval.

Any help would be appreciated.

  • Michael Bissett

    Hey @Nic, hope you're doing well today! :slight_smile:

    Do you happen to have the Durations add-on enabled in your site? If not, you'll want to go to:

    Appointments -> Settings -> Add-ons

    And enable the add-on from there. Once that's done, you'll want to go over to the General tab, and then set "Time slot calculus method" to "Minimum time based appointment duration calculus (legacy)". That'll get your timeslots to display in 1/2 hour intervals. :slight_smile:

    Hope this helps!

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.