appointment + custom color for Free Busy and Not Possible

The custom color for Free Busy and Not Possible don't display correctly. Hos do I fix this?
And why can't I edit the shortcodes in the make appointment page to match my theme? It just disconnects my site.

  • Dimitris
    • Support Star

    Hey there David Simon,

    hope you're doing good and thanks for reaching us!

    It seems to me to be correct at this point.

    If you mean the "today" color, it's because of an opacity set to it. You can revert that with
    td.today { opacity: 1; } in your custom CSS

    If you still can't see any changes there, please clear any caches (involving your web browser's http://www.refreshyourcache.com/en/home/) and try again.

    About the shortcodes, it is true that there aren't much options considering styling, we can help you out though if there're specific items that troubles you. :slight_smile:

    Warm regards,
    Dimitris

  • Adam Czajczyk
    • Support Gorilla

    Hello David!

    As you granted a support access, I visited the site and checked it. First thing I noticed is that if I visit the /book page as visitor (not-logged in user) I'm given a "404 not found" page with a completely different layout but then if I visit it being logged in to the sit I indeed see an empty page.

    However, you mentioned that the shortcode doesn't work. I can see that you are using some kind of a visual builder (I'm not familiar with this particular tool unfortunately) and while the regular "make an appointment" page is there and seems to be working just fine, you are not using a shortcode on "/book" page but instead you are using an "embed" module of your builder to include original "make an appointment" page.

    I'm not sure whether it was this way or your replaced the shortcode with that "embed" module but it seems that this is causing the issue. This "page embed" module seems to be using some custom internal method to fetch and render the page and this may be breaking the output of the shortcode used on "original" "make an appointment" page.

    Could you tell me please why are you doing it this way? Have you tried to use shortcodes directly on a "book" page instead of "embedding" another page there? Can you please shed some more light on what exactly would you wish to achieve?

    I'm sure we can find a way but I'd need to know a bit more about the goal here :slight_smile:

    Best regards,
    Adam

  • David Simon
    • Design Lord, Child of Thor

    The goal is to be able to use the shortcodes on a page that I can edit to look like the rest of the site.
    I removed the embed page snippet on the "book" page and replaced it with a simple text snippet that is used in the classic editor and pasted the same line of code that is on the make appointment page. But it still comes up blank. And I tried creating a "new" page that does look like the rest of the site with the header and footer but that makes the site lose its connection.

    And as for the 404 page when you're not logged in, I got that as well before I fixed the Google api. Now it seems to work for me if I'm not logged in, I get the appointment page.
    Maybe you're getting the old cached page. If not, I'm not sure why.

    Thanks for all your help.

  • Dimitris
    • Support Star

    Hey there David,

    I trust you're well today!

    I removed the embed page snippet on the "book" page and replaced it with a simple text snippet that is used in the classic editor and pasted the same line of code that is on the make appointment page. But it still comes up blank. And I tried creating a "new" page that does look like the rest of the site with the header and footer but that makes the site lose its connection.

    Could you please access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /*That’s it! Stop editing… */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and reach the /book page to replicate the empty page error. By doing so, a /wp-content/debug.log file should be created if any error occurs. Simply download it, rename it to debug.txt and attach it here in your next reply.

    And as for the 404 page when you're not logged in, I got that as well before I fixed the Google api. Now it seems to work for me if I'm not logged in, I get the appointment page.
    Maybe you're getting the old cached page. If not, I'm not sure why.

    I can still see a 404 error page with a whole new styling/theme.
    Can you please clear all caches involving (plugins, server side caches, 3rd party services like CloudFlare) this installation?

    I look forward for your results! :slight_smile:

    Warm regards,
    Dimitris

  • Predrag Dubajic
    • Support

    Hi David,

    I had a look at your debug file but there's nothing there that should be causing this issue.

    I also did a few tests on your site and after creating new page it worked just fine with A+ shortcodes but nothing I tried on the current book page worked, only way I got it to work was switching back to default page editor and saving changes there.

    Since newly created page is working can you try deleting booking page and re-creating it to see if it will work after that?

    Best regards,
    Predrag

  • Dimitris
    • Support Star

    Hey there David Simon,

    hope you're doing good today! :slight_smile:

    I just went ahead and added the following CSS rules in ProStyler Evo -> General settings -> Custom CSS code

    /* WPMU DEV support staff - start *
    article#post-541 table.appointments-legend-table td {
        display: inline-table;
    }
    article#post-541 table > tbody > tr:nth-child(n+5) {
        display: none;
    }
    /* WPMU DEV support staff - end */

    Hope that resolves the styling issues! :slight_smile:

    Take care,
    Dimitris

  • Adam Czajczyk
    • Support Gorilla

    Hello David!

    I added following code right below the one that my colleague Dimitris added to your site:

    article#post-541 table {
      border:0;
    }
    article#post-541 table td {
      border:0;
    }
    article#post-541 .appointments-list table {
      border:1px solid #ddd;
    }
    article#post-541 .appointments-list table th  {
      border:1px solid #ddd;
    }
    article#post-541 .appointments-list table td {
      border-top:1px solid #FFF;
      border-left:1px solid #fff
    }

    This seems to do the job, Let me know please if that's what you asked for (you may need to clear browser's cache in case the "outline" was still there for you).

    Best regards,
    Adam

  • Dimitris
    • Support Star

    Hello David Simon,

    hope you're having a beautiful day! :slight_smile:

    I just went ahead and reverted (commented-out) one of the previous CSS rules and I provided.

    /*article#post-541 table > tbody > tr:nth-child(n+5) {
        display: none;
    }*/

    Could you please re-check that everything is in place now?

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.