Appointment date Unknown

When creating a new appointment the date dropdown show unknown instead of the time to choose from.

  • viobru
    • Support

    Hi, Mark!

    Hope you are doing great :slight_smile:

    I'm sorry for the inconvenience that this might be causing you. I checked this on my testing site and unfortunately I'm not able to replicate this.

    Could you please share the creds to a staging site on which we can continue checking this? Please keep in mind to have the staging site placed on the same server and check that it is an exact copy of the live site (and that you can replicate the issue on it), thanks.

    Please use our secure contact form to share them and include the following details on it:

    Subject: "Attn: Violeta" (Please use this subject line to ensure that it gets assigned to me :slight_smile: )
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - cPanel credentials (username/password)
    - FTP credentials (host/username/password)
    - Linkback to this thread for reference
    - Any other relevant urls

    Many thanks in advance!

    Kind regards,
    Violeta

  • Patrick Freitas
    • Staff

    Hi Mark

    Thank you for the credentials.

    Had you modified anything?

    I tried to book a new appointment and was able to see all the options for booking hours.

    Are you not getting those hours on dropdown?

    When you make a new appointment from Admin, it will show the unknown as the first value, however, clicking on the unknown, it should show the hours to choose.

    Let us know if this is not happening on your live site.
    Best Regards,
    Patrick Freitas

  • Mark
    • Design Lord, Child of Thor

    Hi Patrick,

    I have a history log that shows the original service provider was DELETED by a WPMU representative.

    Now the times show in the drop down with NO PROVIDER selected instead of the original providers name that used to be there.

    This indicates a bug in the Service Providers menu drop down.

    Do you discuss this with a developer, if so what did they say, before you double checked the functionality?

    This is not proper troubleshooting, I am not sure what is going on here...

    Mark

  • Patrick Freitas
    • Staff

    Hi Mark

    My apologies for the delay here.

    When a reply is made the ticket goes to the bottom of the queue, and it can cause a delay.

    I had a closer look at your problem, but, not sure what happened, when I went to check your staging site I was able to see the hours, log out and tested on my end, didn't remove or went to the settings page, this why I asked if you had made any change in the settings :frowning2:

    It seems a glitch, and we were able to replicate, we found a temporary workaround for that.

    Wouldn't you mind, please, try to follow the steps?

    - Go and create a new Appointment. Time will still be showing as Unknown.
    - Under Provider, switch to "No Specific Provider" and back to Provider. The timetable will be fixed.

    However, I can see there is another report for the same issue and I'm going forward to the developer the ticket as a new report, in the meantime, I see at first chat it started in the plugin update.

    Wouldn't you mind, please, downgrade the plugin to the previous version you were using?

    - Create a full backup
    - Please, open the project page https://premium.wpmudev.org/project/appointments-plus/
    - Click on Changelogs
    - Download the older version

    -Unzip the file
    -Using the FTP, goes to WordPress Installation > wp-content > plugins
    - Move the current appointments folder to a temp folder like plugins-temp
    - Upload the downloaded appointments folder to plugins folder

    Note: Do not access the wp-admin > plugins while downgrading the plugin version to keep all settings.

    Let us know if you need any further help on this.
    Best Regards,
    Patrick Freitas

  • Mark
    • Design Lord, Child of Thor

    I have rolled back the plugin as described in your instructions via SFTP. But now there is a NEW issue.

    On the frontend of the site the calendar displays the correct schedule in standard time format which is what is expected.

    However in the admin when Adding a new appointment, the schedule does not match the set Working Hours (in the appointment drop down select menu), it shows additional hours not available and it displays in Military time.

    Please advise.

  • Patrick Freitas
    • Staff

    Hi Mark

    Hope you are doing well.

    It seems was a bug on this version of plugin :slight_frown:

    I've been pinged the developers asking for an update or a hotfix on the latest version of this plugin to get a fix as soon as possible.

    Can you try those steps on the staging site and check if this works for you too.

    -On the latest version of the plugin.
    - Go and create a new Appointment. Time will still be showing as Unknown.
    - Under Provider, switch to "No Specific Provider" and back to Provider. The timetable will be fixed.

    I will keep you updated once I get any response from devs.

    Best Regards,
    Patrick Freitas

  • Mark
    • Design Lord, Child of Thor

    Hi Patrick,
    You may not remember, but I rolled back the plugin to 2.3.2 in order to remedy the suggestion you are making:

    -On the latest version of the plugin.
    - Go and create a new Appointment. Time will still be showing as Unknown.
    - Under Provider, switch to "No Specific Provider" and back to Provider. The timetable will be fixed.

    So this is no longer an issue.

    Just to be clear I am waiting on the newly discovered issue :

    ... in the admin when Adding a new appointment, the schedule does not match the set Working Hours (in the appointment drop down select menu), it shows additional hours not available and it displays in Military time.

    Please let me know as soon as possible when a hot fix is expected.
    Best,
    Mark

  • Patrick Freitas
    • Staff

    Hi Mark

    How are you today?

    You may not remember, but I rolled back the plugin to 2.3.2 in order to remedy the suggestion you are making:

    I suggested on the staging site update the version and check if the temporary solution works for you too.

    -On the latest version of the plugin.
    - Go and create a new Appointment. Time will still be showing as Unknown.
    - Under Provider, switch to "No Specific Provider" and back to Provider. The timetable will be fixed.

    The developers still working on a fix here, some repairs can take more time depending on its complexities, however, I pinged them again to update me or the thread when a hotfix comes up.

    Thank you for understand.
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.