appointment+ does not send email confirmation to purchaser!

I have been at this for many hrs now. need help. went thru several threads already. 1) I'm looking to sell appointments and for now just trying to get the confirm email to go thru 2) does the appointments+ work as it is supposed to? 3) do I need to use marketpress in order for a confirm email to be sent?

I fooled around with the settings plenty and no confirmation email and I used WP-Mail-SMTP and still not working. It seems as tho there is code floating around but I don't know how to use it. i need instructions like which file and where in the file. Thanks for your help in advance.

  • Brian
    • Design Lord, Child of Thor

    I do have marketpress installed but have not tried to use appointment in conjunction with it yet.... I'm trying to fix the confirmation email first. services no money / with money lots of stuff.
    I did get it to send a confirmation email to the email that is on the same server/host. but nothing to my yahoo or gmail accounts.

  • Ash
    • WordPress Hacker

    Hello @Brian

    I hope you are well today and thanks for asking the question.

    I did get it to send a confirmation email to the email that is on the same server/host. but nothing to my yahoo or gmail accounts.

    This is an important point. Would you please make sure you have checked your spam or junk folder in gmail/yahoo?

    Please let me know.

    Cheers
    Ash

  • Brian
    • Design Lord, Child of Thor

    nothing in spam.
    I put together a little something to help me explain here.

    Case 1
    NOT using WP-Mail-SMTP
    NOT using marketpress or shopping cart
    auto confirm = Yes
    Payment required = No
    Send Confirm email = Yes
    Send Notification to admin = No
    Results:
    appointment is auto confirm in A+
    email on same server receives notification email for each email address I make an appoitment with (yahoo and gmail)
    email on same server receives confirmation email when used to make an appointment
    Yahoo: no confirm email
    Gmail: no confirm email

    Case 2
    NOT using WP-Mail-SMTP
    NOT using marketpress or shopping cart
    auto confirm = Yes
    Payment required = Yes
    Product cost = $0.0
    Send Confirm email = Yes
    Send Notification to admin = No
    Results:
    appointment is NOT auto confirm in A+... appointment is pending
    email on same server receives notification emails for all appointments
    email on same server receives confirmation email when used to make an appointment after resend from pending
    Yahoo: no confirm email
    Gmail: no confirm email

    Case 3
    USING WP-Mail-SMTP
    NOT using marketpress or shopping cart
    auto confirm = Yes
    Payment required = Yes
    Product cost = $0.0
    Send Confirm email = Yes
    Send Notification to admin = No
    Results:
    appointments are NOT auto confirm in A+... appointments are pending
    email on same server does not automatically receive notification emails. must resend from pending area
    email on same server receives confirmation email after resend from pending
    Yahoo: no confirm email
    Gmail: no confirm email

    Case 4
    USING WP-Mail-SMTP
    NOT using marketpress or shopping cart
    auto confirm = Yes
    Payment required = No
    Product cost = $0.0
    Send Confirm email = Yes
    Send Notification to admin = No
    Results:
    appointment is auto confirm in A+
    email on same server receives notification emails
    email on same server receives confirmation email when used to make an appointment
    Yahoo: no confirm email
    Gmail: no confirm email

    I would want case 3 where I can charge for the appointment. but confirmation emails are not being sent to external servers regardless.

  • PC
    • WPMU DEV Initiate

    Hey there Brian,

    Thanks for posting back. It seems that its your server blocking things here.

    Can you try using WP Smtp plugin with your Server email address and its smtp details to see if that works ?

    Cheers, PC

  • Brian
    • Design Lord, Child of Thor

    I have tried all that i could think of... including wp smtp plugin. I have contacted the host. they went inside and looked at things and said basically it's not the server. They said if mail gets to an email accnt on the server then it should get to one not on the server such as yahoo.
    i do not know if i mentioned b4 that the email seems to be sent but yahoo does not allow it because of conflicts in where it's actually coming from and where i tell it to come from (from field in form). i received an email saying Mail delivery failed: returning message to sender.
    I have tried many different addresses and the same thing happens.
    I have tried mandril and no luck with that either.

  • PC
    • WPMU DEV Initiate

    Hey there,

    Thanks for posting back.

    Can you kindly enable support access on your site so that I can do some experiment testing and see what is going on there and if we can fix that remotely ?

    You can enable support access via :

    WordPress Dashboard >> WPMU DEV Dashboard >> Support >> Staff Access >> Grant Access.

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Cheers, PC

  • Brian
    • Design Lord, Child of Thor

    The issue was the site being a subsite in a subfolder. So it was a server/host issue. I'm using Fatcow.com, I created a new site on it's own domain (in a sub folder though) and that cleared it up. I tried so many other configurations for days... and no luck. Even with fatcow technicians looking into the issue. After their test they said it was the plugin.

    Thanks for your help.

  • PC
    • WPMU DEV Initiate

    Hey there,

    Thanks for posting back and letting us know that it works after putting the site on its own domain.

    Sometimes the issue is caused due to something not at all related to the plugins settings :smiley: lol

    Glad to hear its all fixed !

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.