Appointment + Email Settings (TO / FROM)?

Hi, need to figure out why emails are not showing up in the back-end or being sent via our BOOK NOW page. Please advise, would like to customize the FROM email settings to show from info@caltan.ca and obtain a notification email, but currently isn't doing so.

  • Adam Czajczyk

    Hello Daniel,

    I hope you're well today and thank you for your question!

    The "From" e-mail is not customizable currently in Appointments+ plugin. Just to make sure: you are asking about an e-mail address that's used to send notifications enabled on "Appointments -> Settings -> General -> Notifications" page, is that correct?

    As for e-mails not being send. Are there only specific e-mails/notifications that are not sent or does that apply to all e-mails from your WP (such as e.g. lost password reminder)? If these are only selected e-mails, which ones are they?

    Please advise! It would also be great if you could grant me a support access to your site so I could test it myself. Here's a guide on enabling support access:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards
    Adam

  • Daniel

    Hi, it happens to ALL emails, I performed a test and it didn't send a notification to me when I booked an "appointment". ALSO, I need to know where the emails get sent to for the ADMIN, as we need to know when someone books an appointment online, where do they go to?

    I'd rather not provide logins as there's sensitive info and we can't have any accidental updates as WP 4.7 has already caused some issues for some of our sites. Thanks and look forward to your response.

    Cheers,

    Daniel

  • Adam Czajczyk

    Hello Daniel!

    By asking for granting support I was referring to the "support access" feature of our WPMU DEV Dashboard plugin. That doesn't require you to share any logins and sensitive data with us, instead providing a secure channel for us - support staff - to access your site on an admin level but without getting to know any login and password.

    Getting back to the issue though: by "all e-mails" you also mean e-mails that come from other parts of your site, like for example lost password reminder or user registration message, am I right?

    In such case there are two things to be checked first:

    1. If you are using an e-mail address that is not in the same domain that your site is using, try setting an e-mail from the same domain as site's domain for "Email Address" option on "Settigns -> General Settings" page and for your admin account profile.

    On some servers, an option to send e-mails from "3rd-party domains" via PHP mail() function is just blocked and this solves the issue.

    2. If this is not the case or you do not want to change e-mail address, try switching WordPress to deliver all the e-mails through SMTP. You may do this using one of these plugins:

    https://wordpress.org/plugins/easy-wp-smtp/

    https://wordpress.org/plugins/wp-mail-smtp/

    I need to know where the emails get sent to for the ADMIN,

    They are sent to the e-mail address of the site admin, the one that's set in profile settings of admin user(s).

    Best regards,
    Adam

  • Dimitris

    Hey there Daniel,

    hope you're doing good and don't mind chiming in! :slight_smile:

    Before proceeding with reviewing your website, could you please confirm that this isn't a generic issue like my colleague Adam mentioned before?

    Getting back to the issue though: by "all e-mails" you also mean e-mails that come from other parts of your site, like for example lost password reminder or user registration message, am I right?

    To check if emails are working indeed (in general) you can use a plugin like Check Email.
    If you don't receive any test emails, please proceed with the steps provided here
    https://premium.wpmudev.org/forums/topic/appointment-email-settings-to-from#post-1190756

    If your default emails are working, please enable WP_DEBUG so we could log any potential error messages during our tests. To do so, access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error by making a new booking.
    By doing so, a /wp-content/debug.log file should be created.
    Simply download it, rename it to debug.txt and attach it here in your next reply.

    I look forward for your results!
    Warm regards,
    Dimitris

  • Dimitris

    Hey there Daniel,

    hope you're having a beautiful day! :slight_smile:

    I just accessed your website and made some tests but nothing came up with an email in my test user inbox.

    I also used the Check Email plugin and confirmed that default emails are working indeed.

    Could you please share with us the debug file from your server? Simply download /wp-content/debug.log file, rename it to debug.txt and attach it here in your next reply. If filesize is larger than 5MB, upload it to a service like Dropbox and post the shareable link instead.

    Finally, could you please perform a plugin/theme conflict test just in case we're dealing with something outside the scope of A+? Simply try to deactivate all other plugins, revert to a default theme and try to book another appointment. If this resolves the issue, start activating them back one-by-one checking each time the confirmation emails.
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Warm regards,
    Dimitris

  • Dimitris

    Hey there Daniel,

    hope you're doing good!

    I just reviewed the debug log file and there're some error messages concerning the Google Calendar Authentication. :thinking:
    [Appointments+] [2017-01-28 14:24:28] ERROR: The OAuth 2.0 access token has expired, and a refresh token is not available. Refresh tokens are not returned for responses that were auto-approved.
    Have you made any changes in the Google Calendar integration during these last days?
    Could you please try to reset API credentials ,so the connection will be disabled shortly, and test again? You can then re-connect your calendars if that makes no difference and test again.

    Also, the theme/plugin conflict test will help you find out why this is happening in some websites while other sites of yours work without issues. I'd really appreciate if you could proceed with that and provide us your results!
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello Daniel!

    I'm really sorry that you are experiencing that issues with the plugin. Could you however please make sure that the support access to the site is granted so we could take a closer look again?

    I'm not sure if you granted it after my colleague Dimitris asked you for that in his last post on Feb 1st and I apologize for keeping you waiting if you did. Please note though that the support access is time valid and it expires in 5 days and also there's no automatic notification that you granted it so we may not even know about being able to access the site if you don't let us know about it.

    That said, please enable support access again so we could access the site and perform some more tests on it and also please let us know here one the access is enabled.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.