Appointment+ Integration with Google Calendar

Hi,

I've followed all the steps and integrated Google Calendar API with Appointments+. However, something isn't working right, which I need you to look into. It seems that I can make appointments on GC and they sometimes correspond correctly on my site.

In addition, a bigger problem is that I use iCal on my phone to schedule all appointments, which I've integrated with GC. All my appointments show up on both of these calendars just fine, but they do not associate with Appointments+. For instance, when I put a new appointment via my phone, it shows up on GC but never on the "make an appointment" site page. How do I fix this?

Lastly, I tried to access support from my WPMU Dev Dashboard, but it wouldn't let me. Can you also fix this?

Thanks much,

Jordan

  • Tyler Postle

    Hey Jordan,

    Hope you're doing well today!

    I've followed all the steps and integrated Google Calendar API with Appointments+. However, something isn't working right, which I need you to look into. It seems that I can make appointments on GC and they sometimes correspond correctly on my site.

    What happens when they don't correspond correctly? Keep in mind they don't sync over right away, it can take up to around 10 minutes sometimes longer. There is the "Import now" link on the gcal tab of Appointments+ settings though :slight_smile:

    All my appointments show up on both of these calendars just fine, but they do not associate with Appointments+. For instance, when I put a new appointment via my phone, it shows up on GC but never on the "make an appointment" site page. How do I fix this?

    This should be working, again I'm wondering if maybe it's just taking awhile to sync, can you try clicking "Import now" on that page :slight_smile:

    If it's still not working then can you send your FTP and WP login through our private contact form? https://premium.wpmudev.org/contact/

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    I can take a look at the support access issue while logged in too, this will just be quicker I think.

    The reason I'm also wanting FTP is so I can double check the .p12 key.

    Look forward to hearing back!

    All the best,
    Tyler

  • Tyler Postle

    Hey Jordan,

    Hope you're doing well today! Thanks for the additional information and thanks Vinod for connecting the two posts here :slight_smile:

    I actually haven't seen that error before Jordan. Would you be able to just grant access to your installation through our dashboard?

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Then I can check out your server info from the system info tab in the dashboard as well as your gcal settings.

    As for moving your installation into the root folder. When you did this did you change all the urls? Is anything else broken at all?

    Look forward to hearing back on this Jordan. Talk to you soon :slight_smile:

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.