appointment lower limit not working as expected

The appointment lower limit parameter set in the admin seems not working as expected. I set this value to 5 hours and at 12.52 my customer could book an appointment for 16.00. How is this possible ? At 12.52 my customer should have been able to book only after 17.52 (12.52 + 5) Or am I missing something ? Which is the formula applied to check if a slot is bookable or not ?
Thanks for your help.

  • Bojan Radonic
    • Head of Support

    Hey there @Antonio, hope you're well today!

    I just tested this on my installation and Appointments lower limit is working as intended.

    You could check if your time settings are setup correctly. Would you please make sure you have correct time zone set in Dashboard > Settings > General?

    Looking forward for your reply.

    Best regards,
    Bojan

  • Bojan Radonic
    • Head of Support

    Hey there @Antonio,

    Could you please grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access > Grant Access

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Cheers,
    Bojan

  • Bojan Radonic
    • Head of Support

    Hi again @Antonio,

    Sorry for the delay here, I am getting the invalid access token message when trying to access your website. That site you created for me is not displayed in the registered sites. Could you please re check that for me and make sure that you granted access.

    Cheers,
    Bojan

  • Vinod Dalvi
    • WP Unicorn

    Hi Antonio,

    We can't access your site staging1.adventurerooms.it using support staff access as it's not getting listed on your account.

    Could you please just send log in info through our secured contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Vinod Dalvi"
    - Include the URL of this post in your message so that I may track this issue better
    - Include login information (Wordpress admin info username + password )

    Regards,
    Vinod Dalvi

  • Jack Kitterhing
    • Code Norris

    Hi there @Antonio,

    Hope you're well today and thanks for your patience on this.

    Just tried to take a look at this for you, but I can't locate the email you sent within your system, I see two emails, one from last year and one from May 26th this year. Using your @gmail address

    Can you let me know which email address you used please? :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • Vinod Dalvi
    • WP Unicorn

    Hi Antonio,

    Thank you for sending the site details.

    I could confirm the issue after a lot of troubleshooting that the issue is causing by padding added to appointments.

    Could you please temporary deactivate the Appointments+ padding add-on and let me know how it works for you?

    Regards,
    Vinod Dalvi

  • Antonio
    • The Incredible Code Injector

    Thank you Vinod for your troubleshooting and for your answer. I'm happy to hear you discovered the issue.

    Unluckly I cannot deactive the padding in my live environment, as I need 1 hour between an appointment and the other.

    But I can live a few weeks with this issue if you suppose it's possible to redirect it the the developers and have it fixed in a next release.

    Please let me know.

    Thanks

    Antonio

  • Vinod Dalvi
    • WP Unicorn

    Hi Antonio,

    No issue.

    I could reproduce the issue on my test site that when i use padding add-on and set appointment lower limit to 5 then at the time 2015-01-04 13:47:14 the appointment time table displays as shown in the first attached screenshot and after disabling padding add-on it displays as shown in the second attached screenshot.

    I have notified this to the plugin developer and i hope it will be fixed ASAP.

    Thanks,
    Vinod Dalvi

  • Jose
    • Bruno Diaz

    Hello @Antonio and @Judah,

    I came across this thread a bit late I'm afraid.

    I believe there is a confusion in regard to how the lower limit feature should work.
    If you look in the option description in Appointments->Settings, it says

    ...appointments can be made if end time has not been passed.

    .

    This means that the lower limit will block all the timeslots where the end time is inferior to current_time + lower_limit.

    If current time is 13:59hs, lower limit 5 hours, and appointment duration is 2 hours, the next available slot would be 17:00hs. (the appointment ending at 19:00hs).

    If you want to set the lower limit to block appointments based on the start time, you need to add the appointment duration to the lower limit value.
    In the case above, it would be 5 + 2 = 7.

    Please let me know if it makes sense now.

    Thanks,
    Jose

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.