Appointment+ not blocking time

When I create an appointment, after confirming the appointment in the dashboard the time does not gets blocked in the appointment page

  • Tyler Postle

    Hey jkleber,

    Hope you're doing well this weekend!

    The reason that the appointment time is still available is because you have 3 service providers doing the same services. So, the capacity for each service defaults to 3 :slight_smile:

    You can change that by setting a capacity in the Appointments > Settings > Services tab.

    Or just reduce the service providers.

    You might notice that each service provider is still available during the time you have booked, this is because the service provider there is "No specific provider" which means a slot is taken up but it's not assigned to anyone yet, so if 2 providers get booked during that time it will block it off, cause it will leave the 3rd provider with the 'no service provider' one. This ensures there isn't an overbooking.

    If you would rather the dropdowns auto re-load the calendar when selected then you can add the autorefresh parameter to the shortcodes, so they look like this:

    [app_services autorefresh="1"] [app_service_providers autorefresh="1"]

    Hope this helps! Let us know if you still have any further questions.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.