Appointment + not sending confirmation eamils

My Appointment + log is showing that it is not sending the confirmation emails to the admin or client. I recently changed admin emails, but what do I do to get it to send emails again?

thanks,
matt

  • Patrick
    • Support Monkey

    Hi there @Mattbkelly

    I hope you're well today!

    ...but what do I do to get it to send emails again?

    By that, I can presume that emails were being sent before, correct? If so, simply changing the admin email address would not interrupt that process.

    Has anything else changed on your site recently? Any new plugins, new theme, updates, new custom scripts added?

    Have you double-checked your Appointments+ settings to ensure that nothing has somehow been altered there, specifically the Auto confirm & Send Confirmation email options?

  • Mattbkelly
    • WordPress Warrior

    I did a lot of changing (themes and plugins) but I just tried changing themes and deactivating all plugins except appointments and still not confirmation email. All appointment settings are good. strange I get the reminder emails. I have granted access.

  • Vinod Dalvi
    • WP Unicorn

    Hi @Mattbkelly,

    I have troubleshooted on your site and confirmed the issue.

    The Notification message is getting sent when i temporary set "Auto confirm" to "No" on your site but the confirmation email is not getting sent to the client on confirming the pending appointment.

    I have tested it on my test site using latest version of Appointments+ plugin and found the Notification and confirmation emails are getting sent fine regadless whether the "Auto confirm" is set to "No" or "Yes".

    Could you please try using and configuring the following plugin to make it work?

    https://wordpress.org/plugins/easy-wp-smtp/

    Regards,
    Vinod Dalvi

  • Mattbkelly
    • WordPress Warrior

    Thank you for your help tonight I really appreciate you getting back to me. I figured out the problem. The S MTP plug-in did work. It was also at that point that I realized I change the administrator's email address.I changed it back to the original administrators email address. And deactivated the SM TP plug-in. Now the appointments are being confirmed. My questin I changed it back to the original administrators email address. And deactivated the SM TP plug-in. Now the appointments are being confirmed. Now my question is why was the new administrators email address not working? Is this a problem with appointments plus? I seem to have remembered a problem with changing admin emails and having similar issues in the past. Is there anyway to test that one out? I would like to change the admin email if possible. Thank you very much, Matt

  • Vinod Dalvi
    • WP Unicorn

    Hi @Mattbkelly,

    I can see there is change in the domain of email address.

    I think this may be the domain focuscm.com specific email address issue.

    To check it could you please try another admin email address from the same domain massagetx.com or from any email service provider like gmail, yahoo etc.

    Regards,
    Vinod Dalvi

  • Mattbkelly
    • WordPress Warrior

    Now now the smtp plugin isn't sending confirmation emails either. Something might be wrong with my site or Appointments really doesn't like people changing the admin email. Have you tried changing the admin email on yours. Does it still send confirmation email?
    thanks,
    matt

  • Adam Czajczyk
    • Support Gorilla

    Hello Matt!

    I can't say that this would be for sure an issue here but from my own experience I can say that some servers are configured not to allow sending e-mails from addresses that are in a domain that's not matching site's domain. This is related to the php mail() function which WordPress by default uses to send e-mails.

    The idea behind such a configuration is to stop spammers. It's incredibly easy to forge the email sender's name and address using mail() function and this "glitch" is very often used by spammers. Because of this some hosting providers to filter mails and if an e-mail sent with mail() function doesn't much site's domain it's being blocked.

    This is not a case however with SMTP as with SMTP all e-mails a being sent through their "official" servers. From the description of these test you've run I assume that this may be a case here.

    I'd propose sticking to a WP SMTP plugin then and also you may want to ask your hosting provider (just to make sure) if their are indeed blocking e-mails sent from their servers from addresses that are not hosted on their servers.

    Chees,
    Adam

  • Ash
    • WordPress Hacker

    Hello @Mattbkelly

    Using a SMTP plugin should not be any issue, but it depends on the server configuration. As @Adam Czajczyk said, would you please consult with your host about this?

    Please let us know what you hear back from them.

    Cheers
    Ash

  • Mattbkelly
    • WordPress Warrior

    They say, that nothing is wrong with the emails or website. They said if it is sending emails from the plugin, then there is nothing wrong with the hosting just the plugin. It still is not sending ONLY the confirmation emails.

    PLEASE HELP. This is very important.
    thanks,
    matt

  • Adam Czajczyk
    • Support Gorilla

    Hey Matt,

    I took another look at your site's Appointments+ logs. I've noticed that the Google Calendar integration throws some errors there. I'm not quite sure about that but it's possible that this might be causing plugin to get stuck there.

    That said, could you switch off Google Calendar integration for a moment and see if it helps?

    Let me know please.

    Apart from this, I'd like to further investigate the issue but in order to do so I'd need to take a closer look at your setup. Could you please send in:

    Subject: "Attn: Adam Czajczyk"

    - your site's WordPress admin login URL
    - admin login and password (may be a temporary account)
    - FTP credentials (hostname, username, password, port number if needed)
    - any other relevant URLs and information
    - link back to this thread

    Please use our contact form here
    https://premium.wpmudev.org/contact/.
    Select "I have a different question" from the drop-down list.

    Please be sure to make a full backup of your entire site first!

    Cheers,
    Adam

  • Predrag Dubajic
    • Support

    Hi Matt,

    I don't think there were any changes made by us, as you would get answer on thread once we manage to find a cause.

    Since it's working now this was probably something server related, or did you made any changes on your site in the meantime?
    Disabled any plugins or something like that?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.