Appointment+ Reminder Not Sending

Hi, installed 103 and 104 and enabled the Reminder to Admin for Pending Appts and tested and am not getting the Pending Email Reminder. I do get confirmation emails though. I enabled the setting to Yes and saved – Appt+ responded with Settings Saved and Cache Cleared. But still no reminder emails.

Thanks for the great responsiveness and dedication!

  • Hakan
    • The Incredible Smush

    Hi,

    Notification emails for pending appointments are only sent when you require payments and whenever an appointment has been taken from front end. What is your “Payment required” setting? And what is your procedure while testing this?

    Cheers,

    Hakan

  • mikem5774
    • Design Lord, Child of Thor

    Please enable an option to allow pending appointments to notify administrator without a payment. I don’t want to force people to prepay or make a deposit to schedule an appointment in order to get a pending appointment notification.

  • Hakan
    • The Incredible Smush

    Hi,

    Please enable an option to allow pending appointments to notify administrator without a payment.

    There is a setting for that as of V1.0.2

    Just set “Send Notification to admin if confirmation is required” setting as Yes.

    It sends a notification email to admin if you do not require a payment and a client applied for an appointment.

    After you confirm the appointment. client and service provider will start receiving reminder emails.

    Cheers,

    Hakan

  • sborsch
    • WPMU DEV Initiate

    Hakan,

    Just to clarify your ‘fix’…does this mean that I only have to do this “confirm” one time? Or is this for every appointment made and then the client and service provider notifications will work?

    It really needs to be the former. My client is a non-profit and they’re scheduling phone interviews for volunteers (which are non-payment) and I’d hate to have the phone interviewer (i.e., the ‘service provider’:wink: have to login and view their profile and keep refreshing to see if any appointments are pending for them.

  • Hakan
    • The Incredible Smush

    Hi,

    Both of them are possible.

    There is a setting, “Auto Confirm”. If you set it to “Yes” any non-payment appointment is automatically confirmed. This fits to your case I think.

    Just for the other users and cases, if you want to be notified after a new appointment and confirm (or reject) it manually, then set “Auto Confirm” as No and set “Send Notification” as Yes.

    Cheers,

    Hakan

  • sborsch
    • WPMU DEV Initiate

    Thanks Hakan! (Nice job on this plugin, by the way)

    If I need to ask a ‘new’ question on the forum let me know, but I’ve set up a dummy service provider, I am one of three site admins on this client’s site, and *my* email is temporarily set as the WP General email address (for user notifications).

    The fake person creating the appointment (which I send to another email address of mine) receives their confirmation perfectly, but I’m wondering why I never receive the Service Provider’s notification email?

    In “Appointments+ > General” I have Auto Confirm set to “Yes” and “Allow Service Provider Confirm Own Appointments” set to “No”.

    I’ve Assigned Dummy service providers to me but no emails arrive.

  • Hakan
    • The Incredible Smush

    Hi,

    I works fine on my server and most others. But I see a few other complaints too, so it looks like that some php installations cannot interpret “bcc” on the header.

    In fact this is a server/hosting/php mail installation problem, but

    Instead of saying make your php mail installation fixed, I will change the email function and instead of using bcc I will send separate emails for admin and service providers.

    This will be applied in the next version.

    Cheers,

    Hakan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.