appointment+ renders the week as hidden

Hi,

I am trying to have only one day at a time render on the page.

What is happening is that when I add 3 or 4 days from the calendar using the exception list, it renders all the days after today as hidden, thus generating code that must be dynamically updated every 15 mins because of the next schedule. That would be ok, but it kills the load times when I exceed 10 or so users.

The HTML that is rendered, has today and every day after that as code. a HUGE amount of code.

so basically if I dont want to chase off the users by giving up or have them hit refresh 10 times in row, I can only show one day.

Is there any way to not render those days until they reach the correct time to display?

  • Michael Bissett

    Hey @latin625, hope you're doing well today! :slight_smile:

    In Appointments -> Settings -> General, do you have "Appointments upper limit (days)" set to "1" already? If you don't, could you try setting it to that please?

    If you do, can you please send in the following, so I can have a closer look at your settings?

    - In the subject field add "Attn: Michael Bissett”
    - Link back to this thread
    - Include WordPress admin access details
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks a bunch! :slight_smile:

    Cheers,
    Michael

  • latin625

    Thank you Michael! You are a godsend, I have been killing myself trying to get this down. I applied your very easy setting and it worked! Well kinda... =)

    It eliminated all the extra days on the calendar being generated, but still throws a ton of unnecessary code in the html. Here is one line as an example:

    <div class="app_timetable_cell notpossible app_break" title="September 24, 2014 3:30 pm">3:30 pm<input type="hidden" class="appointments_take_appointment" value="0:2:0:1411572600:1411573500:8"/></div>

    I have a ton of break times in my schedule to reduce the size of the time table that is displayed. It shrinks it to a very manageable size via CSS display:none;

    But yes, your suggestion has shrunk it down by 70%. Is there anything I can do in the code or otherwise that can eliminate these unneeded lines of code being generated and displayed?

    Thanks a bunch once again!!!

  • latin625

    Thanks. I have a freelancer handling the modifications and agree that this should be streamlined. This is a very nice and very powerful plugin. Honestly, I would pay 4x the cost for a plugin that had a much more robust admin panel and features, like Only day selections, custom options to display the appointments and even some more reporting and admin tools.

    I really appreciate that you agree with my assessment of the very heavy code that is generated with this plugin.

    In it's current state, this plugin would only be useful to very small start-ups or very light bookings. The power of this plugin should be released.

    Thank you and I will always purchase my plugin needs from WPMU for the sole reason of the solid support that is provided by your great staff.

    Thanks again.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.