Appointment + Working Hours issue

Hi,

I've been carrying out some further testing of A+ v1.3.1 and I would appreciate if you could confirm my results and if you agree could flag to the developer, @Vladislav for him to confirm our findings.

If I set the 'Working Hours' for a 'non specific Service Provider' or for a 'specific Service Provider'.
e.g. 09h00 - 17h00 for each day: M-F and set the relevant 'Work?' tab to 'Yes'
Then set multiple break times for each related day and set the 'Give break' tab to 'Yes'
e.g. 12h00 - 13h00, 15h00 - 16h00
Then save the settings it works fine
Then I go back and set any of the 'Give break' tabs back to 'No'
Then save
It appears that it ignores the 'No' and still invokes the relevant Break times.
The only way I could get it to work was to set the Break times outside the Working Hours.
e.g. changes Break times to say 02h00 - 03h00, 04h00 - 05h00
Then saved the settings and it seems to work.
I also found that if you set Multiple Break times and save
Then unset some or all of them the Multiple Break times are still visible.
Is it possible if they are set back to 'No' that they are removed?

Regards
SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Vaughan

    Just checking if @Vladislav has had a chance to check and confirm both of our findings?

    I've just been helping out a fellow wpmu member as they experienced the same problem having set Multiple Breaks to 'Yes' and then setting them back to 'No' the correct scheduled hours wasn't showing as the Multiple Breaks where still being used so I had to set the Break Times outside of the Working Hours for it to work.

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Vaughan and @Vladislav

    Good news - I've just received confirmation that A+ V1.4 has just been released, with plenty of fixes and I will be upgrading on my demo site to test.

    I just wanted to check if this bug has been resolved as I can't fined any reference in the history log?

    I also wanted to check if V1.4 has fixed the Working Hours issue, when you add multiple breaks then decide to set some or all of them to 'No' then you don't seem to get the option to actually remove/hide the break when the 'Work?' field is set to 'No'.

    I also need to check that if you set multiple Breaks do they have to be in sequential/time order for the rules to be applied correctly?

    Regards
    SteveB

  • Vladislav
    • Dead Eye Dev

    Hello,

    The break times issue should be fixed with the new release. However, setting the break time to "No" won't actually hide or remove this break time. We'll be working on this part, but this was mainly a bugfix release, so that was the main focus this time. Lastly, the break times don't need to be in the sequential order to be applied correctly - the plugin might be marginally more efficient if they are, but the order shouldn't be significant. I hope this helps.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.