appointments Access Not Configured for Google API

My problem is in the setup for Google API:

I have checked my settings 3 times, but I am still getting the following error message when I test the connection:

"[Appointments+] The following error has been reported by Google Calendar API:
exception 'Google_ServiceException' with message 'Error calling POST

(...I have removed the path to missing file for security reasons)

Recommendation: Please double check your settings."

I did everything in the documentation, including FTPing the file into the proper directory, however the instructions in Appointments tells me to put the file in a different site directory than the one in the error message.

Instructions address:
blah/blah. blah/sl.mymainsiteusername/public_html/mysite/wp-content/plugins/appointments/includes/gcal/key/

Error address starts the same but ends differently:
blah/blah. blah/sl.mymainsiteusername/public_html/mysite/wp-content/plugins/wpmu-dev-plusone/lib/external/google/io/Google_REST.php:67

My host allows me unlimited domains as folders inside the mainSite directory. ParallelMIndzz.com is one of my sites that is inside the main site directory. The host techs assure me that these other domains like ParallelMIndzz are not seen as a subdirectory or subdomain; that each domain has its own unique address.

Should I redo the "Create an OAuth 2.0 client ID..." again?

Should the paths be the issue, I'd be happy to privately email you the path I was told to set, and the one that is showing in the error message.

  • pxwm

    Hi @Tom Eagles - Hope you don't mind me chiming in

    Hi @aliyah_marr

    Could you please confirm if you are using v1.3?

    Could you please provide a screenshot of all your settings in the A+ 'Google Calendar' tab?

    Could you confirm if you are only using the single calendar using the settings in the A+ 'Google calendar' tab or have you created the same for each user in their Wordpress user profile?

    Did you receive the error message when you clicked on the 'Test Connection' towards the bottom of the A+ 'Google Calendar' tab?

    Regards
    SteveB

  • aliyah_marr

    Hi PXWM,

    I cannot provide screenshot for security reasons. However I have emailed Tom and the developer via the contact form.

    I don't know what you mean by:

    "Could you confirm if you are only using the single calendar using the settings in the A+ 'Google calendar' tab or have you created the same for each user in their Wordpress user profile?"

    However, now I seem to be closed out of the plug in settings for some reason (see below).

    ----------

    Google Calendar API Settings:

    Allow Service Providers.... YES

    Appointments will be sent to Google: ALL

    Integration Mode: A+ <-> GCal

    Key file name: xxxxxxx-privatekey

    Service account email address: xxxx@developer.gserviceaccount.com

    Calendar to be used: xxxx@group.calendar.google.com

    Event summary (name): SERVICE Appointment

    Event description: Client Name: CLIENT
    Service Name: SERVICE

    The error message came after I clicked the Test Connection button.

    I am using Version 1.3

    I have set myself up as the only service provider.

    --------

    NEW PROBLEM today
    This is weird: I just tried to check my settings, changed a few, and now I am getting a message whenever I try to access the Appointments settings page:

    "You do not have sufficient permissions to access this page."

    ????? I was just ON it and I am still logged in as Admin. I have NEVER seen this problem before in any plugin.

  • pxwm

    Hi @aliyah_marr

    You may have been 'locked' out of the settings page because you activated the 'permissions' add-on in the A+ Settings 'Add-Ons' tab

    If you did there is a bug in v1.3 and you may wish to read the following post: https://premium.wpmudev.org/forums/topic/modify-appointments-admin-options-more

    and the developer has provided a fix in v1.3.1-BETA-3 which is attached to this post.

    As for the problems you are experience with integrating your Google Calendar and the reference I made to:-

    Could you confirm if you are only using the single calendar using the settings in the A+ 'Google calendar' tab or have you created the same for each user in their Wordpress user profile?

    You have the option in the A+ 'Google calendar' tab to have a single main calendar for all Service Provider appointments or you can setup individual Google Calendars for each Service Provider.

    I've checked your settings and you have the 'Allow Service Providers for Google Calendar API Integration' field in the A+ 'Google Calendar' tab set to 'Yes'

    If you check the notes next to it it states:-

    Whether you let your service providers to integrate with their own Google Calendar account using their profile page. Note: Each of them will need to set up their accounts following the steps as listed in Instructions below (will also be shown in their profile pages) and you will need to upload their key files yourself using FTP.

    This means if you have this field set to 'Yes' then you have to complete the Google calendar setup for each Service Provider in their Wordpress user profile. To achieve this you have to login to each each Wordpress user using their login details and create API keys etc for each Service Provider.
    Effectively what you created in the main 'Google calendar' tab you have to do for each Service Provider.
    If you do want an individual Google Calendar for each Service Provider then you are best disabling the main page by setting the field 'Integration Mode' to 'Integration disabled'.

    However if you only wanted one main Google Calendar then could you try setting the field to 'No' and then click the 'test Connection' at the bottom of the page and confirm if it indicates a success message at the top of the page.

    Hope this helps
    Regards
    SteveB

  • aliyah_marr

    Also, since I am the only service provider, I originally set this to NO, but the test error message was the same.

    Then I realized that my email address for the blog and my google email address is different -- (I want this to be the case for security reasons) and I switched it to YES, thinking that Google would prefer this in any case, since the Calendar is connected to my Google email address.

    It's confusing me...

    Here is what I want to do:

    • schedule consulting/coaching appointments for myself (only) through the web
    * show my schedule online, so clients can sign themselves up
    • when they sign up, they pay in advance
    • email confirmations and reminders to me and client
    • former clients and members of the website get a 20% discount on private sessions

    • ideally, I'd like to offer packages of sessions, but I don't think I can do that with Appointments, so I will wait on this feature

  • pxwm

    Hi @aliyah_marr,

    This post relates to uploading the BETA version and then I'll respond to your further post.

    First I'd advise taking a backup of both your Wordpress database and home directory from within cPanel, as this will allow you to restore any files and settings.

    The beta zip file contains all the appointments+ files in a directory called 'appointments', therefore if you navigate to the wp-content/plugins/ directory within your wordpress installation, then upload the zip file and extract it, it should overwrite the previous plugin.

    You will probably want to do this using cPanel, so that you can extract the zip on the server.

    Hope that helps
    Regards
    SteveB

  • pxwm

    Hi @aliyah_marr

    I've tried to respond to your questions in order:-

    Also, since I am the only service provider, I originally set this to NO, but the test error message was the same.

    Then I realized that my email address for the blog and my google email address is different -- (I want this to be the case for security reasons) and I switched it to YES, thinking that Google would prefer this in any case, since the Calendar is connected to my Google email address.

    It's confusing me...

    Could you please confirm if you receive the error message when you click on the 'Test Connection' link at the bottom of the A+ 'Google Calendar' tab?

    Could you also confirm if you currently have the field 'Allow Service Providers for Google Calendar API Integration' field in the A+ 'Google Calendar' tab set to 'Yes'?

    If you do then can you follow my instructions in my earlier post as in the quotes below:-

    This means if you have this field set to 'Yes' then you have to complete the Google calendar setup for you as a Service Provider in your Wordpress user profile. To achieve this you have to login to your Wordpress user using your login details and use the settings in the A+ 'Google calendar' tab.
    Then disable the main Google calendar by setting the field 'Integration Mode' to 'Integration disabled' in the A+ 'Google Calendar' tab.

    Once setup you should then be able to see a 'Test Connection' at the bottom of your user profile page.
    Click on this to confirm if you receive a success message or the error.

    Your set of requirements:-

    • schedule consulting/coaching appointments for myself (only) through the web

    Could you please confirm if this means you want to schedule available slots through your Google Calendar or A+ for your clients to book through the A+ frontend?

    Also do you want them to have to log-in to make the appointment? There is a setting in the A+ 'General' tab so they have to log-in to make an appointment.

    • when they sign up, they pay in advance

    There are settings in the A+ 'General' tab that you can set so they have to pay upfront but the only payment platform is PayPal.

    • email confirmations and reminders to me and client

    Again there are settings in the A+ 'General' tab to achieve this

    • former clients and members of the website get a 20% discount on private sessions

    You can't achieve this directly in A+ but you may want to check the features in the wpmu Membership plugin as you can integrate this with A+ using settings in the A+ 'General' tab

    Hope this helps
    Regards
    SteveB

  • aliyah_marr

    OK, got the Beta installed and can now access the setting screen again.

    However, as I expressed earlier, the error message shows no matter whether I have Allow service providers on YES or NO.

    I reset it to NO but I get the same error message:

    [Appointments+] The following error has been reported by Google Calendar API:
    exception 'Google_ServiceException' with message 'Error calling POST https://www.googleapis.com/calendar/v3/calendars/blah@group.calendar.google.com/events: (403) Access Not Configured' in /blah/blah/public_html/parallelmindzz/wp-content/plugins/wpmu-dev-plusone/lib/external/google/io/Google_REST.php:67
    Recommendation: Please double check your settings.

    As for the settings, they are as I stated above, below I have listed the new settings:

    ----------

    Google Calendar API Settings:

    Allow Service Providers.... NO

    Appointments will be sent to Google: ALL

    Integration Mode: A+ <-> GCal

    Key file name: xxxxxxx-privatekey

    Service account email address: xxxx@developer.gserviceaccount.com

    Calendar to be used: xxxx@group.calendar.google.com

    Event summary (name): SERVICE Appointment

    Event description: Client Name: CLIENT
    Service Name: SERVICE

    The error message came after I clicked the Test Connection button.

    I am using Version 1.3 BETA

    I have set myself up as the only service provider.

    -------------

    Your other questions:

    Could you please confirm if this means you want to schedule available slots through your Google Calendar or A+ for your clients to book through the A+ frontend?

    I want clients to be able to schedule themselves through A+ AND to be able to schedule them myself through Google calendar in the rare case I have to make adjustments.

    I would want the calendar on my website (thru A+ and Google) to reflect these changes that I may make directly in the Google calendar.

    As for the rest of your answers, I think that I have found those settings and set them already. I just wanted to outline what I wanted to use A+ for...

    ---------

    My concern at this stage is getting A+ and Google to work before my month's free support ends.

  • pxwm

    Hi @aliyah_marr

    I would suggest the next step is to confirm that the private key, service email address and google calendar settings in your A+ 'Google Calendar' tab match with your google settings in your google account.

    The other settings you may wish to check in your google account NOT A+ is that the following field settings:-

    Login to your google account
    Select Products
    Select Calendar
    Select settings
    Select 'Share this Calendar'

    On this page check that the 'Service account email address' matches with that in your A+ 'Google calendar' tab
    Also check that the following Permission Settings have been selected from the dropdowns:-

    'See all event details'
    'Make changes to events
    'Make changes AND manage sharing'

    Hope this helps
    Regards
    SteveB

  • aliyah_marr

    Yippee!

    I finally got the calendar to work! I had to log out as ADMIN and log back in as Aliyah Marr (a service provider) I bought a session from myself, and the calendar on my website (A+) now has reserved that time slot.

    Now for finessing it:

    I cannot see the appointment I just made with myself through the website on Google calendar API. Nor does an event I scheduled on Google calendar show on the website (A+).

    --------

    I followed the following instructions for manually updating it, but it didn't update both calendars:

    Integration Mode
    Select method of integration. A+ -> GCal setting sends appointments to your selected Google calendar, but events in your Google Calendar account are not imported to Appointments+ and thus they do not reserve your available working times. A+ <-> GCal setting works in both directions. This synchronization is not immediate; it requires at least some traffic to your website and not handled less than 10 minutes intervals. To update it manually use "Import and Update Events Now" link which is only visible if the settings let it so.

    ---> I set it to A+ <->GCal

    Import and Update Events Now
    Clicking this link will manually import and update your Events from the selected calendar without waiting for 10 minutes. Note: Maximum 500 future events that will start until appointment limit setting are imported in the order of their starting time. Past events and all day events are not imported.

    ---> I tried manual import, but nothing changed on both calendars. (I even refreshed the Make An Appointment page on my website to see if it was there)

    I'd like to not accidentally allow someone to schedule an appointment over an event (conference call, webinar, etc) that I have.

    1. How do I get the events from the Google calendar to come into the A+ calendar on my website? I want the event to show and to block out the time as unavailable.

    2. If I want to schedule someone for something, say a free session, how do I do it? Where do I do it?

    3. How about scheduling events? Do I do this through GCal or my website?

    Thanks so much for your help Steve. You rock!

  • aliyah_marr

    Something else I noticed:

    When I tested the connection to GCal through the A+ settings, I got a confirmation email, but when I paid for a session, I did not get a confirmation email.

    I will need to get the PHONE number of the client so I can call them for their session. I have set this as a requirement in the General settings tab:

    Require these from the client: X Name X Email X Phone Address X City X Note

    And, while the system DID require that I (as the buyer) fill out these fields, I did not get the information through my email. Wouldn't the confirmation arrive immediately?

    I have tried to diddle with the settings since then; below are the screenshots.

    I am sure that there must be settings for this information. Please remember that I am both the ADMIN and Aliyah Marr (the only service provider). I set this up so all appointments are made under my name and my personal gmail address, and GCal is now working in Appointments. However, everything else is under a Yahoo email address (Admin). Regardless, all emails come to me, so I should be getting a confirmation email with the clients phone number and time of appointment.

    --------

    I just bought another session from the Make an Appointment page on my website to test the settings as listed in the screengrabs below. No email confirmation was sent to me as Admin or as the service provider. Then I checked the Appointments menu from within A+ and cannot find the 2 appointments that I made through Appointments, except as "Pending" which isn't true since they have been paid thru Paypal (full payment is a requirement for setting an appointment according to my settings).

  • pxwm

    Hi @aliyah_marr

    Good news, we seem to be moving forward with your issues.

    Could you please screenpost or list ALL your current settings in the A+ 'Google Calendar' tab.

    Could you also confirm if you have setup the Google calendar settings in your 'Aliyah Marr' Wordpress profile and if so could you also screenpost/list these.

    To confirm for A+ and your Google Calendar to be synchronised in both directions you need the 'Integration Mode' field set to A+<-> GCal (Synchronisation)

    As for the other issues: I've checked your settings.

    When an appointment is made do you want the Appointment to be automatically confirmed once the payment is made?

    If so can you set the 'Auto-confirm' field in the A+ 'General' tab to 'Yes'
    This should resolve some of your problems with this field set to 'Yes'.

    As for needing the phone number in the email confirmation then you could add the following or similar to the 'Confirmation email Message' field:-

    To confirm I will give you a call on PHONE to discuss your session

    The upper word PHONE will add the phone number they entered in the appointment form.

    Hope this helps
    Regards
    SteveB

  • aliyah_marr

    OK, I had not logged out as Admin, so I hadn't set Aliyah Marr's settings. So I did that.

    I am using exactly the same settings as Admin as Aliyah Marr, since I am the only service provider (same settings from screenshots above). This may be where the error lies?

    As explained above, I wanted to personalize my service without having to change my Admin settings for all my WP properties, so I set myself up with my gmail address initially with Google for Admin and am using the same settings for Aliyah Marr.

    --------------

    OK, I updated my Aliyah Marr profile page with all the settings from my Admin profile page and Google API.

    Then I logged out as Aliyah Marr, and logged back in as Admin. I set the Auto Confirm to YES in the General Settings tab.

    I then I bought another sample appointment from the website.

    -----------

    Results are the same:

    I get a confirmation on Payment from Paypal, but NO email confirmation nor does the appointment show on Google Calendar. However, the time of the appointment is blocked out on my website on the Make an Appointment page.

    In both profile pages (Admin and Aliyah Marr) when I "Test the Connection" it does put a dummy appointment on Google calendar, but it doesn't do this in a "real" situation.

    -----------

    Thanks again for your help.

    Attached please find the settings in the General tab.

    As explained above, I am using exactly the same settings for both profiles for the Google API. Perhaps I should cancel one or use different settings?

  • pxwm

    Hi @aliyah_marr

    I would suggest you remove the settings from one of your profiles and I would suggest your Admin profile.

    Can you please then provide a screenpost for all the settings in the following pages:-

    A+ 'Google Calendar' tab
    Aliyah Marr profile page

    if you don't want me to view the api key etc could you please strike these out but I would like to see all the other settings as they are on the page

    regards
    SteveB

  • aliyah_marr

    Ok, I removed the Admin profile as a service provider, and logged out and back in as Aliyah Marr. I tested the connection, and it did the same thing as before:

    TESTING THE CONNECTION

    • Posted the appointment on GCal, but did not send a confirmation email or post it as an appointment in A+.

    • The "Test the Connection" link "wiped" the A+ tab page contents in the interface. Strange effect, perhaps a glitch in the program? It does this every time I test the connection. To get the contents back I just click on a tab at the top.

    ------

    Next, I set the Tarot Reading service at 50 cents, and tried to buy it again through the Make an Appointment page.

    This time, Paypal did NOT charge my account (too small a charge?) and did not send a confirmation of payment. It has charged my account and sent me a payment confirmation every time before...

    As before, it did set the appointment in my website's calendar, but did NOT deliver a confirmation email or post it in GCal. I also manually clicked on "Import and Update Events Now" link.

    -------

    I have checked the Appointments section of A+ to see what is there. As you can see by the screen shots below, only the Pending Appointments tab shows any appointments. I have determined that these are ONLY the Test Connection Appointments, NOT the appointments that I have made (and paid for through Paypal) through the Make An Appointment page on my website.

    The screen grabs you requested are below.

  • aliyah_marr

    Perhaps the solution is to deactivate the plug in, remove it and reinstall it?

    If so, then please detail my ideal settings to achieve the functionality I need:

    1. Payment (OK)
    2. Updating of A+ calendar with appointment (OK)
    3. Email notification to my email (NOT DONE)
    4. Updating of GCal by reserving block of time (NOT DONE)
    5. Updating of internal confirmation system, achieving Active Appointment status (NOT DONE)

    Seems the only function I have been able to achieve has been the first two in my list: 1.) Payment and 2.) Updating the A+ calendar on website--reserving block of time.

  • aliyah_marr

    Thanks Tom,

    Do you think that I need to deactivate the plug in, remove it and reinstall it? Perhaps it is screwed up because I have two users (originally service providers) with the same Google account.

    Also, I am only a member until August 26th, so I'd like to either resolve this question soon or somehow get the support I need to make the plugin work.

    Thanks Steve and Tom for your help with this.

  • pxwm

    Hi @aliyah_marr

    I'll wait for the developer for his thoughts.

    However in the meantime is it possible you could carry out the following:-

    Login to the Wordpress dashboard as Admin
    Select A+ settings
    Select 'Google Calendar' tab
    set the 'Integration Mode' field to 'Integration disabled'
    Save the settings
    Then logout
    Then login using Aliyah Marr Wordpress profile
    Then select their profile
    Then scroll down and click the 'test Connection'
    If you receive a success message at the top of the page then logout
    Then try making an appointment through A+ and confirm if this is successful
    If so login to Wordpress dashboard as Admin
    Select A+ 'Appointments'
    Is the appointment in the 'Active' or 'Pending' appointments
    If in 'Pending' can you select the appointment and change the status to 'Confirmed' and update
    Can you then confirm this has moved the appointment to the 'Active' tab
    if so can you then check if the appointment is in your google calendar

    Regards
    SteveB

  • aliyah_marr

    I have been getting this message at the top of all my WP interface screens:

    You'll need Google Maps plugin installed and activated for Google Maps Locations integration add-on to work

    It has been installed and I put in the Google API key, but the message still shows. I don't know if this may be the cause of my problems with A+. Google does have my location in California, which is all I need, since I plan on only doing phone consultations with people.

    --------------

    Steve, I did all you requested and had the following experience:

    Testing the connection as Aliyah Marr, did not give me a "success" message, but does update my Google calendar. However, it didn't set anything in the A+ calendar on Appointments page, and only gives me a "pending" status in the A+ interface (profile page for Aliyah Marr). SAME RESULTS AS BEFORE.

    (Funny thing: clicking on Test the Connection seems to remove the bottom of the profile page when it refreshes--the part where you can set the settings for A+. To get it back, I have to go to another WP interface page; upon my return the rest of the profile page shows.)

    I made an appointment and paid for it, but it does not show up at all on my profile page as Aliyah Marr, nor is it showing at all on either Google Calendar or on the Make An Appointment page.

    ------------

    Sunday:

    I decided to do remove all service providers and redo the whole GCal page, including a new key and settings. The test connection came up positive for the first time!

    [Appointments+] Test is successful. Please REFRESH your Google Calendar and check that test appointment has been saved.

    However, nothing else has changed:

    1. Payment (OK)
    2. Updating of A+ calendar with appointment (OK)
    3. Email notification to my email (NOT DONE)
    4. Updating of GCal by reserving block of time (NOT DONE)
    5. Updating of internal confirmation system, achieving Active Appointment status (NOT DONE)

  • pxwm

    Hi @aliyah_marr

    Any chance you could provide me with a temporary Wordpress admin log-in so I can check your settings.

    Just to confirm I'm only a member of wpmu and not a staff member so I will totally understand if you don't want to provide me with temporary log-in details.

    However if you are happy to provide could you please:-

    take a backup of your site and database
    confirm if the site is live or at the design stage
    send your temporary login details to: steve.billington@pxwm.co.uk

    Regards
    SteveB

  • aliyah_marr

    I may have found the problem: Paypal.

    I just got this notice from them:

    ------------

    Hello ALIYAH MARR,

    Please check your server that handles PayPal Instant Payment Notifications (IPN). IPNs sent to the following URL(s) are failing:

    http://www.parallelmindzz.com/wp-admin/admin-ajax.php?action=app_paypal_ipn

    If you do not recognize this URL, you may be using a service provider that is using IPN on your behalf. Please contact your service provider with the above information. If this problem continues, IPNs may be disabled for your account.

    Thank you for your prompt attention to this issue.
    --------------

    If my server is unable to receive the IPN notice from Paypal, then A+ cannot know a payment has been made, and won't be able to send me an email confirmation, etc. All the points listed below:

    3. Email notification to my email (NOT DONE)
    4. Updating of GCal by reserving block of time (NOT DONE)
    5. Updating of internal confirmation system, achieving Active Appointment status (NOT DONE)

    It IS however, reserving the appointment in the A+ calendar on the Make an Appointment page. If I am right, this is because the A+ calendar is notified first, then it routes to Paypal and circles back to A+ app to confirm the appointment. Here is how I think it should flow:

    1. User requests appointment, button opens on bottom asking for Paypal payment---- this reserves a block on A+ Calendar webpage. OK

    2. Paypal accepts payment. OK

    3. Paypal sends confirmation to my email address. OK

    4. Paypal sends IPN to my server. NOT DONE

    5. A+ accepts IPN and combines it with info (date, service, time, client, phone) acquired in first step. NOT DONE

    6. A+ sends me email confirmation, pings Google to update GCal and updates my internal calendar with info. NOT DONE

    7. GCal gets updated and synced with A+ internal data and calendar. NOT DONE

    -------

    As you can see, the process is stopped at step #4 above because the server is not accepting the IPN.

    I currently have NO service providers listed. Just Admin.

    ------

    I just checked Paypal to see if IPN was turned on and it was disabled:

    Edit Instant Payment Notification (IPN) settings
    PayPal sends IPN messages to the URL that you specify below.

    To start receiving IPN messages, enter the notification URL and select Receive IPN messages below. To temporarily stop receiving IPN messages, select Do not receive IPN messages below. PayPal continues to generate and store IPN messages until you select Receive IPN messages again (or turn off IPN).

    Notification URL

    IPN messagesIPN messages
    Receive IPN messages (Enabled)
    X Do not receive IPN messages (Disabled)

    I just enabled IPN, but don't know how much of the URL in the email message from Paypal (see above) to include. The following is what I have for now. Please advise.

    http://www.parallelmindzz.com/wp-admin/

    I wonder as well if this is due to resetting the primary email account on Paypal to an alternate email address a month ago. So I made sure that both Membership and A+ is set to the primary email address listed with Paypal.

    -------

    BTW a search on your site returned the following link to someone who seems to be having the same issue.

    https://premium.wpmudev.org/forums/topic/appointment-paypal-payment-settings-notification-issues

  • pxwm

    Hi @aliyah_marr

    Many thanks for the feedback and good news you found a payment setting problem.

    I've checked the post you linked to and I've been providing feedback and advice on this.

    As for the IPN url you need then if you check the notes associated with the A+ 'General' tab 'PayPal Merchant E-mail' field it will provide you with the full url you need.

    Based on the part url your provided in your post I suggest it will say something like: Just for your information, your IPN link is:
    'http://www.parallelmindzz.com/wp-admin/admin-ajax.php?action=app_paypal_ipn
    You may need this information in some cases.

    Hope this helps
    Regards
    SteveB

  • aliyah_marr

    I just updated the IPN in Paypal to the full address:

    http://www.parallelmindzz.com/wp-admin/admin-ajax.php?action=app_paypal_ipn

    ---------

    I found this setting here:

    https://premium.wpmudev.org/forums/topic/paypal-ipn-question

    ---------

    So, after changing the Paypal email address and IPN settings in A+ I tried to buy an appointment again.

    Same results as before:

    1. Payment (OK)
    2. Updating of A+ calendar with appointment (OK)
    3. Email notification to my email (NOT DONE)
    4. Updating of GCal by reserving block of time (NOT DONE)
    5. Updating of internal confirmation system, achieving Active Appointment status (NOT DONE)

  • aliyah_marr

    I just tried the membership plug in and now it doesn't work either! What gives?

    I have been willing to accept that this is somehow my error, but I think this goes beyond even my patience.

    I have been working on A+ for weeks now, and Membership took me months to fix. Now it doesn't work.

    I have a public conference call tomorrow in which I wanted to announce both the Membeship and Appointments part of my site. Please, please help me resolve these problems now!!!!!

  • Tom Eagles

    @aliyah_marr

    Ok so what exactly are the errors with membership?

    From what i can see

    you say the pings from it dont work have you set them up correctly in the pings section of membership:

    http://yourdomain.com/wp-admin/admin.php?page=membershippings

    As for the membership users and wp users whats the error you are getting is when they sign up for a membership they aren't being created as a member?

    Cheers

  • aliyah_marr

    Thanks Steve and Tom for all your help. Here is the latest in my detective work:

    This is really weird: I got the Membership plugin to work again by reverting the email address in the plugin to the original one that I used.

    FYI I think the problem started when I added a new address to my Paypal account and made it primary, without losing the original Yahoo address, so apparently, Paypal still thinks this old address is the right one, even though I had synced the address in Membership.

    Now that I reverted back to my Yahoo address on Membership, even Mailchimp is working again.

    More and more, I think that these problems may be due to Paypal. The variables are not getting passed through Paypal to A+ and back to me as a confirm email.

    HISTORY

    I installed Membership and finally got it to work last month. Paypal settings were set with my yahoo email address as primary.

    I didn't like the payment screen on Paypal with this email address, so I set a new one as primary:

    services@parallelmindzz.com

    Then, without checking the Membership plugin to see if it worked, I installed A+. A+

    8-13 I fixed Membership by switching Paypal email (Membership settings) back to the yahoo email address, and now it works again--Yipee!!!

    8-14 Did the same with A+, but it doesn't work. Still getting stuck at the same place.

    --------

    Another message from Paypal that may be a clue:

    Claim your cash

    You received 1.00 USD from iconoclast@inbox.com on Aug 11, 2013. If you do not claim your money by Sep 10, 2013, this transaction will be canceled and the money will be returned to iconoclast@inbox.com's account.

    Log in to your PayPal account to view the details of this transaction.

    You need to manually claim this money because:

    Your payment receiving preferences are set to manually accept or deny this type of payment.

    If you have questions about this payment, log in to your PayPal account and click on the History subtab. Click the details of the payment in question for more information, or to accept or deny this payment.

    So, now I am off to trying to find where "manual" claims is set in Paypal.

  • Tom Eagles

    @aliyah_marr

    Aha! That explains it :slight_smile: I have the same issue i paypal, I had a domain that i was using for a site and the associated email address of that site was info@xxxxxxx.com and i used that for that paypal account and other sites also.

    Now when i let that domain expire i updated my email address with a new one (my personal email address used in my personal paypal account and set it as my primary on the paypal account i had the old address on, all well and good you would think NO NO NO, the interesting thing was all emails etc were going through to the old domains email address and when i logged into that account and viewed history i got redirected to the other ones site.

    Took me ages going back n forth with paypal to get this fixed, it seems though even if you add a new email address and set it to primary everything gets rooted over the original address.

    Regarding manual acceptance you should be able to simply click received in your history or received payments and you will see them there and simply accept it.

    Cheers

  • aliyah_marr

    Please note: resolving Membership Paypal problems haven't resolved A+ problems. I am still not getting notified by email with the ***important*** client info--their phone number!!!!

    Paypal jargon--what the heck do they mean? This is a page from within my Paypal account:

    My Preapproved Payments

    You haven't set up any Preapproved Payments yet. They're an easier and more secure way to send money or automate payments.To get started, go to our client's website that offers PayPal Preapproved Payments.

    So I am checking my Paypal API settings in Paypal:

    https://www.paypal.com/cgi-bin/customerprofileweb?cmd=%5fprofile%2dapi%2daccess

    API Access
    An API (Application Programming Interface) allows PayPal software to communicate with your online store or shopping cart.

    Setting up API permissions and credentials
    Choose one of the following options to integrate your PayPal payment solution with your online store or shopping cart.

    Option 1 - Grant API permissions to a third party to use certain PayPal APIs on your behalf.

    Choose this option if:

    You are using a pre-integrated shopping cart, hosted by a third party
    Your website is hosted and managed by a third-party service provider
    Grant API permission

    Option 2 - Request API credentials to create your own API username and password.

    This option applies to:

    Custom websites and online stores
    Pre-integrated shopping carts running on your own server
    Request API credentials

    Accept payments from your online stores before setting up APIs
    Enable Express Checkout to accept payments from your online stores right away. You can set up API permissions or credentials later.

    I clicked on the last choice and got to this page: https://www.paypal.com/us/cgi-bin/webscr?cmd=_profile-api-ec-noncredentialed-payments

    X Accept PayPal payments from all your online stores
    Use this feature to automatically accept payments from all your online stores and shopping carts before setting up API permissions.

    X Accept PayPal payments before API permissions or credentials are set up
    (You can complete API setup later)

    I chose the top one.

    I think I broke Paypal this time. I bought my services again (from a separate email and Paypal account) and it didn't even notify me of the payment. It was working before!

    ------

    I found this on your A+ page:

    **3. If the client goes through the first stage of the appointment (i.e. choosing service/date/time etc), but does NOT go through with the payment, does the system record their name and email etc so that we can contact them manually to ask them about making a payment to firm up their booking?**

    Yes, it will save that appointment as pending and you can manually pick the email address and contact the user.

    You can set Disable pending appointments after (mins) in the settings.

    Wouldn't this prove that A+ doesn't think a payment has been made? i.e. it is not getting my desired set of variables (user name, phone number, email, payment) BACK from Paypal?

  • aliyah_marr

    Thank you Tom! Ask him if I am right about the path the variables have to take to make it back to me as an email confirm. I think that Paypal may need a bit of extra configuring, but can't figure out how.

    If pre-approved payments are subscription payments, then why does Paypal allow Membership subscriptions (pre-approved in Paypal) while it doesn't allow pre-approved payments for A+ ?

    -----------

    Steve,

    Sorry, to be so slow in responding to your request for General tab screen shots; I spent the whole day yesterday trying to make sure I had Membership and as much of A+ as possible, functional--in time for my conference call. Here are the screenshots.

  • aliyah_marr

    Steve,

    Thank you for all your help. I hope that the developer can help me resolve these questions before my WPMU membership ends.

    Tom,

    May I have your email address?

    My membership to this WPMU ends on the 26th, and I won't be able to resolve these issues after that date unless I can contact you.

    This will have been a month trying to make this plugin work. Don't you feel that my questions should have been answered by now?

    I think that a month should have been enough time to give me the answers I needed; if it hadn't been for Steve, I would not feel that anyone from WPMU has cared enough to try to help me make this plugin work.

    Please resolve this for me soon.

  • aliyah_marr

    Dear Tom,

    Thanks for the suggestion, but I think I will see if the developer can find the problem for now. Could you please stay online as I continue to try to resolve this issue? I appreciate all your help.

    --------

    Thanks Steve,

    I am pretty sure the problem is with the IPN from Paypal. Perhaps it is a setting within Paypal that needs a different setting? Please see above.

    In looking at A+ settings, in the general tab I see the following (I have set it to YES):

    YES/no Whether you require a payment to accept appointments. If selected Yes, client is asked to pay through Paypal and the appointment will be in pending status until the payment is confirmed by Paypal IPN. If selected No, appointment will be in pending status until you manually approve it using the Appointments page unless Auto Confirm is not set as Yes.

    Because any appointments I have made using this system have only ended up in the "pending" section, AND because IPN seems to fail when Paypal tries to ping my site, AND because there is no email confirmation, I think that IPN is the breakdown in communication between Paypal and A+.

    Notice that I have set this setting to YES. It is acting as if it is set to NO.

    -----

    Also, NO email reminders have been sent-- perhaps because A+ thinks that they are pending appointments and not approved? However, I have set all notifications to YES.

  • pxwm

    Hi @aliyah_marr

    Just to confirm are you saying that even when you receive the IPN ping and the appointment is automatically confirmed then a Confirmation email is not sent to the end user?

    If this is the case it may be worth temporary setting your 'Payment required' field to 'No' and make an appointment to ensure an email is being sent to the end user.
    This will at least prove that the Confirmation email is being sent.

    I can confirm that if an appointment is in the 'pending' status then the Confirmation email will not be sent.

    Regards
    SteveB

  • aliyah_marr

    No, Steve,

    The IPN from Paypal does NOT reach A+--that's the problem.

    Paypal accepts the payment, and sends me an email that a payment has been made, but seems to want me to manually accept the payment. NO IPN is sent to A+ which means that no email confirmation of the appointment is sent to me.

    This is why the web calendar is updated, but the transaction in A+ is "pending" and Paypal hangs up.

    It is confusing, because this whole process works with Membership plugin, but not with A+. I don't want to mess up what is working between Paypal and Membership.

    IPN is on in Paypal with the following address:

    Notification URL http://www.parallelmindzz.com/wp-admin/admin-ajax.php?action=app_paypal_ipn

    Message delivery Enabled

    The tests that I did with MEMBERSHIP plugin last month (and this month) all succeeded in delivering an IPN but the tests that I did with A+ failed to deliver an IPN.

    Here are a couple of screen grabs from Paypal. The first shows you that IPN (has been) enabled. The second screen grab is a list of IPN tries, failures and successes in the last month. Be aware that I was successful with installing and testing Membershp last month, and have been testing A+ this month. Every now and then I would check on Membership by running a test payment as well.

    I checked each transaction on this list and found that the IPNs that succeeded were ALL from Paypal to Membership, while the failures are the ones from Paypal to A+.

    To me, this proves that the problem isn't Paypal, but A+---A+ isn't receiving the IPNs from Paypal. Paypal tries several times with each transaction, but it NEVER gets through. However, EVERY IPN for Membership gets through.

    (The only other difference between the two plug ins that I know of is that Membership uses SUBSCRIPTION buttons, while A+ accepts one-time payments, but I can't see why this might cause a problem.)

  • aliyah_marr

    And to be absolutely clear:

    The email confirm I am looking for is the one that should be sent to the SERVICE PROVIDER (me), not the one that would be sent to the buyer. Apparently that one isn't sent either, as I am both service provider, and buyer (using different email addresses for each).

    BTW

    Membership works: it emails me my user name and password each time I sign up as a test member.

  • pxwm

    Hi @aliyah_marr

    Just to confirm you will not receive an email as the Buyer or Service Provider until the appointment has been confirmed.

    I've just checked your settings and wonder if the problem is because you have the 'Membership levels for the above selections' field is set to 'Members Free Trial'.

    I posted a similar problem when some of the Services in A+ were setup with a price and others were setup with '0' so no charge and the Services with a price went through fine and the Services set as '0' didn't receive an IPN ping and the appointment was placed in the 'pending' appointment tab.

    Is it possible you could revise the membership setting so the person making the appointment has to make a payment and see if this works and then try making an appointment and paying to confirm if you receive the IPN ping.

    The post I am referring to is: https://premium.wpmudev.org/forums/topic/appointment-bookings-and-payments?replies=22#post-492442

    Regards
    SteveB

  • aliyah_marr

    As I understand that section of the A+ settings:

    I had selected both Members and Free Trial for the 20% discount.

    I have NOT clicked on the following button:

    Below selected level(s) will not be asked for an advance payment or deposit. This does not mean that service will be free of charge for them. Such member appointments are automatically confirmed.

    Since I have NOT enabled the option for these members to NOT pay, the settings should be correct, and each customer should have to pay in order to set an appointment.

    As I posted in the beginning, the process gets hung up at the IPN, not the buying process, although all payments are pending in my Paypal account.

    Apparently, theres is no "handshake" between Paypal and A+ that must be the IPN, since GCal is not updated either. Whenever I go through the process of buying a test appointment from this plugin, the following happens:

    1. Payment (accepts & Paypal emails me, but payment is only pending in Paypal)
    2. Updating of A+ calendar with appointment (OK)
    3. Email notification to my email (NOT DONE)
    4. Updating of GCal by reserving block of time (NOT DONE)
    5. Updating of internal confirmation system, achieving Active Appointment status (NOT DONE)

    I am repeating myself here. This is the same problem as I had in the beginning. No change despite all the work I have done and all the research I have made. Please tell me something new, or confirm that it IS the IPN as I suspect.

    As Membership IPN works, and A+ IPN does not (using the same settings at Paypal) I have to assume that the problem is with A+ or my settings, not with Paypal.

    -------

    I just removed the Free Trial membership from the setting (see old and new settings screen grabs), then I went in as a visitor from another browser, and bought a test session with another email address and Paypal account. The same problems ensue. No change. As you can see in the grabs, the button is not clicked that would allow no purchase in order to set an appointment.

  • aliyah_marr

    Reviewing that button again:

    Below selected level(s) will not be asked for an advance payment or deposit. This does not mean that service will be free of charge for them. Such member appointments are automatically confirmed.

    Does this mean that only those levels that do NOT ask for payment are auto-confirmed? This doesn't seem right. Shouldn't PAID appointments be auto-confirmed?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.