Appointments+ add custom input box for Surname and a Partner Name field

Hi Guys,
Firstly, great work on Appointments+. I am based in Melbourne as well and I am doing a job where I need to customise Appointments+ for a client. I need to add a Surname field and a Partner First Name field, and I need to change the Your Name field to be First Name. When it comes to adding in the Surname field and the Partner First Name field, I wonder; do you have an article on this? I have had a look through the WPMU site but haven't been able to find anything on this so far. Keep up the great stuff fellas!

  • Luís

    Hi @Jeremy,

    I hope had been good today!

    Additional fields

    To create additional fields in Appointments+, please do this:

    1) Go to Appointments -> Settings -> Add-ons and enable the "Additional fields" add-on;

    2) After that, go to Appointments -> Settings -> General and in Display Settings section, add your custom fields in "Additional fields";

    Change "Your Name" field

    To change "Your Name" field, you can use one of this options:

    1) Using our Ultimate Branding Plugin:

    https://premium.wpmudev.org/project/ultimate-branding/

    1.1) Install the plugin and in Branding -> Settings, enable the Network Wide Text Change module.

    1.2) After that, go to Branding ->Text Change and replace the string for other text you want.

    2) Using the plugin translation file.

    2.1) Go to wp-content/plugins/appointments/languages and download the appointments.pot file.

    2.2) Using an editor, like Poedit, open the file, change that text and save.

    2.3) After that, Poedit will generate two files (.mo and .po). Edit the name of .mo file to use the language code of the WordPress Setttings (Settings -> General).

    I.E. If you are using WordPress in English (Australia) your file should be: appointments-en_AU.mo

    2.4) Upload this file to wp-content/plugins/appointments/language

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

  • pxwm

    Hi @Luís - I hope you don't mind me chiming in but thought my suggestion may help @Jeremy

    Hi @Jeremy - You may wish to try the following to change the 'Your Name' field to 'First Name'

    Login to your Wordpress Dashboard as Admin
    Then select 'Pages' in the left hand side menu
    Then select your A+ Appointments page that contains your shortcodes.
    Locate the shortcode: [app_confirmation]

    and change to:

    [app_confirmation name="First Name:"]

    If the shortcode already contains additional parameters then do not remove but just add this additional parameter.

    Then 'Update' the page.

    Then logout and go to the Appointments page and refresh.

    Make an appointment by selecting a Service then Service Provider and when the form displays it should show 'First Name'

    I hope this helps
    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.