Appointments - Any hope of working correctly?

Ok, the Admin Add-on does not work. The unavailable times can't be set by the providers, as stated in the ad copy.
Are these things going to get fixed, the user interface needs to happen on the front end and allow the providers to set unavailable times and approve their own appointments.

  • Patrick

    Hi there @Jack

    I hope you are well today!

    I just gave the developer a nudge again on the issue with the Administrative Permissions addon issue as reported here:
    https://premium.wpmudev.org/forums/topic/appointments-plugin-stopped-access-to-settings-page

    As for enabling service providers to set their unavailable days, you simply need to set "Allow service provider set working hours" to "Yes" in the Accessibility Settings section under the General tab (screenshot).

    However, it is currently not possible to block off specific times on the exceptional days, unless the service provider does so in his/her Google calendar (and Gcal integration is configured) or simply books a manual appointment with him/herself.

    Finally, I believe a front-end interface is in the works to enable service providers to adjust their hours, etc, but I'd need the developer's input on that one.

  • Bert

    Hey Patrick,

    This thread looks relevant to an issue that I am having which I think I know the answer to.

    1. I am able to set the hours for the service providers including multiple break times using my admin account which gives me access to all of the serive providers. This is my standard WP admin account. (Admin Screen Shot)

    2. The service providers can login and edit their schedule but they cannot add another break time. That is the issue. (Service Provider Screen Shot)

    The problem looks like the javascript files are not included.

    1. This is the javascript included on the page that works /wp-admin/admin.php?page=app_settings&tab=working_hours NOTE: I removed my website from the url here by editing it out. It is listed when the page is rendered
    <script type='text/javascript' src='/wp-content/plugins/appointments/js/colorpicker.js?ver=1.4'></script>
    <script type='text/javascript' src='/wp-content/plugins/appointments/js/jquery.datepick.min.js?ver=1.4'></script>
    <script type='text/javascript' src='/wp-content/plugins/appointments/js/jquery.multiselect.min.js?ver=1.4'></script>
    <script type='text/javascript' src='/wp-content/plugins/appointments/js/js-check.js?ver=1.4'></script>
    <script type='text/javascript' src='/wp-content/plugins/appointments/js/admin.js?ver=1.4'></script>

    2. On the page that does not work /wp-admin/profile.php the javascript is not included.

  • Bert

    Hello Jack,

    I was just commenting on the point that my service providers can set their own hours. The only issue is when they try to set more than one break time. That still has to be performed in the administrative side.

    You might benefit from this tutorial here https://premium.wpmudev.org/blog/build-an-amazing-appointments-website/. I am just a member like you and can see your frustration. Read the link I sent you since it will probably help.

    Do not forget about the FAQ for the plugin when you are logged into your site. It has answers to questions like this one:
    How can I let my service providers freely edit appointments?
    Appointment records can only be edited on the admin side appointment page. Use an appropriate role/capability manager plugin and grant "manage_options" capability to your service providers. There are some plugins that let you select particular roles, even particular users/providers for this purpose.

    I hope this helps.

  • Patrick

    @Bert & @Jack

    Terribly sorry for the delay on this thread guys. Concerns for family health issues have kept me away from the forums quite a bit lately.

    @Bert

    I just tested the issue you reported above and can confirm that additional breaks times cannot be added via the user's profile screen. That does appear to be a bug and I have alerted the plugin developer to the issue. Thanks for spotting that!

    @Jack

    I just replied on your other thread about your issue with the Admin Permissions addon:
    https://premium.wpmudev.org/forums/topic/appointments-plugin-stopped-access-to-settings-page#post-643851

    Has updating to version 1.4.1 resolved your issue?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.