[Appointments+] Appointments +

I have Appointments + set up on a cloudways server. It works fine for a couple of days. Then Appointments + stops working. I'm seeing the error: "Attempt to set a forbidden header was denied: Connection" in my console. I've tried the steps outlined in the FAQ but can't resolve the problem. Thanks for looking in to this!

  • Predrag Dubajic

    Hi Tom,

    Hope you're doing well.

    So it shows fine at first but then after some time it will stop working?
    Can you tell me what exactly happens when it stops working, you don't see the calendar, nothing happens when you click on a slot, confirmation doesn't work, etc?

    Also, would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Best regards,
    Predrag

  • Tom

    Hi Predrag,
    Thank you for helping me.
    It works normally for a couple of days after installation and setup. Then it will stop working correctly.

    When this happens it will display part of the calendar but nothing else. And what I mean by that is that it is set up to allow the user to choose a service worker. Then it should display the given service worker's calendar. After clicking on a day it should display the service worker's available days etc. However, in its current broken state, it displays nothing beyond a partial calendar in its unresponsive state.

    I cannot ascertain what changed to possibly make this happen. In other words, it wasn't a case where I made a change to some other aspect of the wordpress installation and then it stopped working. The plugin had been set up and working for a couple of days before it stopped working, with no changes made during that time.

    I have granted support access. Thanks! - Tom

    I've installed it on 2 different servers and this has happened both times. So it could totally be the case that I'm mis-configuring it somehow. However, I can't seem to figure out what might be wrong. I've followed the troubleshooting steps, disabled all other plugins etc. All to no avail.

  • Predrag Dubajic

    Hi Tom,

    Thanks for the additional info and granting access, I can see that the page is not loading properly indeed, and in addition to A+ issue the admin bar is also not loading on that page.

    If the issue doesn't happen right away it's possible that there's some kind of server-side caching that breaks the page after some time, so the first thing you should try is clearing and disabling any server-side caching you might have active.

    If this doesn't help we might be able to get some more information about the issue from debug log.
    You can enable debug log in your wp-config.php file (located in root WP folder) by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'log_errors', 1 );
    @ini_set( 'display_errors', 0 );

    Visit appointment (test 2) page and this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Tom,

    It seems that memory limit is kinda low on your site and it gets exhausted which is causing the issue, can you try adding below lines to your wp-config.php file (located in root WP folder) just above /* That's all, stop editing! Happy blogging. */ line and see if it works after that?

    define('WP_MEMORY_LIMIT', '256M');
    ini_set('memory_limit', '256M');

    Let us know how it goes.

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Tom,

    Hmm, strange, A+ definitely shouldn't require so much memory to work properly...
    I see that you have Snapshot installed on your site, so would be ok if we download a backup of your site and restore it on local installation where we could dig deeper into this and see what might be causing this on your installation?

    If that sounds good can you grant support access again?

    Best regards,
    Predrag

  • Tom

    Hello,
    I set up a new site on an entirely different server and ran into the same problem. It worked fine to begin with and then stopped working after a few days.

    I received the following error message:

    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 32768 bytes) in /home/directory/myURL/wp-includes/functions.php on line 3743

    I thought I'd pass that along in case it helps.

    I'm definitely interested in using appointments+ in the future, but unfortunately I have to abandon the plugin for this particular project.

    I've been checking out other plugins to provide the same functionality. Do you happen to have one you'd recommend?

    Thanks for your help on this.

  • Predrag Dubajic

    Hi Tom,

    Unfortunately, I don't have any good news about this at the moment, our devs have been looking into it and are still looking for best way to go around this issue.

    The number of appointments is affecting the memory and it would probably need code to be rewritten to handle their load differently in order to reduce required memory.

    I didn't use any other appointment plugins myself so couldn't really give you any first-hand suggestions that I know it works properly.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.