[Appointments+] Appointments Plus Service Provider page is empty

I created a Service Provider in Appointments plus to test the plugin. Their unique page is not working. Support has been enabled on the website. There is a note on the Support page detailing the URL that was created for the Service Provider. I don't want to list it publicly.

  • Ash
    • WordPress Hacker

    Hello FZCU

    I can see a JS error on the console. Looks like this is a conflict. Would you please run a conflict test? Please deactivate all plugins except this one and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. You need to do the same with themes as well.

    You can find the flowchart here: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-1

    Please let me know how it goes.

    Note that, I had to create an appointment page. Do not delete the page now as we may need that to test later.

    Have a nice day!

    Cheers,
    Ash

  • FZCU
    • The Incredible Code Injector

    Ash,

    I tried and I do not know which plugin could be causing the conflict. All I can say is that the majority of plugins on my website are WPMUDEV plugins. So, if a conflict is occurring, it may be on the WPMUDEV side.

  • FZCU
    • The Incredible Code Injector

    Ash,

    You are welcome to activate and reactivate as much as you need. I have already de-activated most of the plugins and reduced the PHP version to 5.6 (the stable version) in an effort to determine the issue. I could not. Support has been enabled.

    • Ash
      • WordPress Hacker

      Hello FZCU

      I was testing on your site but one of your admin was frequently deactivating appointments+ plugin.

      Anyway, I found the issue. Actually, in the test page you created, there was no content. That's why nothing was showing. Once I added the content, you can see the bio page content. I have also checked by creating another provider which I have deleted after testing.

      Have a nice day!

      Cheers,
      Ash

  • FZCU
    • The Incredible Code Injector

    Ash,

    I am sorry, but that makes no sense. Do you mean to tell me that the content for the Service provider's page is not automatically generated? Other appointment plugins automatically generate the content for their service providers.

    • Ash
      • WordPress Hacker

      Hello FZCU

      Yes, in appointments+ you have to create a provider page with his details and then map that page to the provider according to the following screenshot:

      Once you select a page, then the content of that page will appear on the appointment page.

      Have a nice day!

      Cheers,
      Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.