[Appointments+] Appointments+ Settings ->Google Calendar Tab... Empty

I've just updated to version 2.4.0. Now in settings, Google Calendar Tab, the page is blank. Tested on Mac 10.12.6, Chrome Version 67.0.3396.99 & FireFox 60.0.2 & Safari 11.1.1. Any thoughts? I've opened the WPMUDEV support lock on my site.

  • Patrick Freitas

    Hi Paul

    Sorry to hear that you are having this problem, I had a closer look on this and there is a message on browser console.

    Wouldn't you mind please create a full backup of this site then deactivate the plugin and activate it again?

    and check if the problem is gone, if this persists, please enable the debug mode on WordPress.

    Using a FTP access the WordPress root folder search for wp-config.php click to edit it.
    Above /* That's all, stop editing! Happy blogging. */ paste the code:

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    Try to access the plugin, then back to WordPress root by FTP search for wp-content folder.

    On the wp-content folder search for any debug.log change it to debug.txt and upload on the ticket's reply.

    Let me know the results.
    Best Regards.
    Patrick Freitas

  • Paul

    Thanks, Patrick. I followed your instructions and could not find a debug.log file in the wp-content folder after I implemented your wp-config.php code and went into the Appointments+ plugin settings and Google tab. I then set the wp-config.php line to display_errors to = 1, and this is what displayed on the screen in the Google tab...

    Fatal error: Call to undefined method Google_Client::getClassConfig() in /home/kdunncom/public_html/_estateplanningmap/wp-content/plugins/appointments/includes/external/google/Logger/Abstract.php on line 126

    I turned off all plugins, except Appointments+, and the Google tab works! I found the plugin "WP Mail SMTP" Version 1.3.2 | By WPForms, to be the culprit.

    Any thoughts about this conflict? I used to need the SMTP plugin function with Appointments+, because emails were not being sent outside my domain name...however, now emails are being sent. So, now we know the issue...and because the emails are being sent, I don't have a problem now. Case closed on my end. Thank you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.