[Appointments+] Bad Gateway ngnix error with appointments+

I am getting a Bad Gateway Error message each time I attempt to access the "Service Providers" section of the Appointments+ Settings

  • Nithin
    • Support Wizard

    Hi FZCU,

    Hope you are doing good today. :slight_smile:

    I checked your dashboard, and could notice the issue. I tested this in my system, but wasn't able to replicate this. This happens in either 2 cases, ie if there isn't enough server resources, or a plugin conflict.

    I could notice the max_execution_time is 90 at the moment, which is a bit low. Could you please create a php.ini file in the root folder, and then try adding the following rules, and check whether the Service Provider page loads fine in Dashboard:

    max_execution_time = 300

    Root folder is where wp-config.php file resides. You can check whether max_execution_time got increased, or not once the above is added, under WPMU DEV > Support > System Info > PHP.

    If you still notice 90, instead of 300 after the above changes, then you'll have to bring this into your hosting provider, and ask them to increase the max_execution_time in your sites behalf.

    If you still have same issue even after increasing the max_execution_time, then would recommend you to run a plugin conflict test to rule out which exact plugin is causing this.

    Please check this flow chart, on how to run a conflict test:

    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    A conflict test would be give a better idea where the issue is. Please let us know how that goes, have a nice day ahead. :slight_smile:

    Regards,

    Nithin

  • FZCU
    • The Incredible Code Injector

    Ironically it’s your Google Maps plugin that its causing the conflict. I disabled all plugins on the website except for WPMUDEV’s Google Maps plugin. Everything went fine. As soon as I reactivated the Google Maps plugin, the latency and NGINX error occurred. There is a conflict between your two plugins.

  • Luís
    • Support

    Hi FZCU ,

    Hope you’re doing well today!

    Sad to hear Appointments+ and Google Maps plugins are conflicting in your setup, I tried to replicate it on my site, but was unable.

    We would like to give a closer look and fix the conflict, to do this we will need the FTP access to your website.

    Please send it privately through our contact form:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:

    Subject: "Attn: Luis Lopes"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/information

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.