Appointments+ Blank Page on Settings Update

Hello,

Would appreciate some help with this issue regarding Appointments+

Two issues (perhaps related).

1) In Appointments>>Settings .. Adjust a setting under Service Providers or Services and commit the change by clicking the Save button … and … the page doesn’t refresh – just goes to a Blank White Page.

If the browser back button is clicked, the page redisplays and its apparent that the setting was committed but the page did not refresh. (This is confusing for users).

2) We use MarketPress in addition to A+ to add appointment bookings to a cart. This has been working fine, but now when an Appointment date/time is selected, the Appt form filled in and user clicks the “Please Click Here to Confirm this Appointment” , the Appt is NOT added to the cart – just get a “spinner” icon that spins and spins.

Note that in Appointments>>Settings>>General, the “Auto-add appointments into cart” option is selected under the MarketPress payment settings.

Oddly – this all worked until recently. No setting adjustments made on this end. Not sure if the problem began after a plugin update or not.

NOTE: I have activated SUPPORT ACCESS on the site.

  • Tyler Postle
    • CGO

    Hey Jeff,

    Hope you’re having a great day so far.

    This sounds like a plugin or theme conflict. I tested out your booking form and can see in the console that you’re getting a 500 internal server error. While this usually does mean it is an issue with the server, it still could be a plugin conflict too.

    Try temporarily deactivating all your plugins accept Appointments+ then see if it still happens. If you know of any plugins you recently installed, then start with those ones as you mention it worked fine before. Same with any recent updates, it could be an update to another plugin that triggered the conflict.

    This should narrow down the issue so we can start looking into a solution to get around it :slight_smile:

    Look forward to hearing back!

    All the best,

    Tyler

  • Jeff
    • Site Builder, Child of Zeus

    Well Tyler …

    You were correct – it is a plugin conflict. A+ is not playing nicely with “Easy Social Share Buttons ” from CreoWorx.

    If “Easy Social Share Buttons” is disabled, the problems (both 1 and 2 in original post) are resolved. Of course I need to have that plugin active, so I’m not sure what steps would need to be made to get the conflict fixed and it’s unclear if this issue is caused by A+ or “Easy Social Share Buttons”. They did work together properly previously .. so I’m thinking an update from one of the two plugins has created the problem.

    What would you suggest as to next steps? I have contacted CreoWorx through their support forum as well.

    Thanks in advance.

    -Jeff

  • Tyler Postle
    • CGO

    Hey Jeff,

    Glad you were able to narrow that down :slight_smile: good stuff.

    Could you either send us your FTP or a copy of that plugin. Then we can test it out on our own installs and look for a fix.

    If you send in FTP then you can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me :slight_smile:

    Send in:

    Subject: “Attn: Tyler Postle

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    **If you want to send in just the plugin then send it to contact[at]wpmudev.org with the subject line “Attn: Tyler Postle“.

    Look forward to hearing back!

    Cheers,

    Tyler

  • Jeff
    • Site Builder, Child of Zeus

    Hi Tyler,

    Thanks for helping out with this. (I did send you a copy of the plugin that was conflicting – last Friday).

    Some more info..

    Since we needed to have Social Media Sharing buttons for the site up and running, we decided to source an alternate plugin and utilize it for sharing button functionality. We did a bit of research, sourced and purchased a new plugin called “Ultimate Social Deux”. When we installed and activated the new plugin, the same conflicts with A+ reappeared. (In order to keep A+ working, we have disabled the new plugin as well.)

    This would seem to suggest that the issue lies with A+. Thoughts?

  • Tyler Postle
    • CGO

    Hey Jeff,

    Sorry for the delay here. I got the plugin you sent, thanks for that :slight_smile:

    I’ve been testing this out on my install and so far it’s working fine for me. Looks to be setting related. Can you grant support access again so I can have a look at your settings?

    Then I should be able to replicate and let our developer know.

    I have a feeling it has to do with the Google+ API as Appointments+ uses an older version of it, but so far I haven’t been able to produce the conflict.

    Look forward to hearing back! Talk to you soon.

    Cheers,

    Tyler

  • Tyler Postle
    • CGO

    Hey Jeff,

    Thanks for the quick reply. I’ve been troubleshooting this for a little while and I’m still not able to replicate it even with your settings. That plugin has a lot of settings so it’s possible I could have missed a couple but I don’t think I did.

    Would you be able to deactivate all plugins except for just Easy social share buttons and Appointments+ then see if the issue is still happening? I’m wondering if another plugin might be playing a part in the conflict too. Not sure if they were the only ones active when you confirmed it before.

    If you would like us to run this test then no problem, just send in your FTP via our contact form as stated above.

    Talk to you soon!

    Cheers,

    Tyler

  • Jeff
    • Site Builder, Child of Zeus

    Hello Tyler,

    Once again you are correct!

    I undertook some additional testing on our development environment and discovered that there is another plugin involved – it’s “Membership 2”. (Note that we recently did all the plugin updates and this problem was in place back when Membership was “Protected Content”.) We are protecting some of the pages where users are able to book Appointments (protected by “Membership 2” – previously “Protected Content”:wink: – a user must be logged in to one of 2 membership levels to access the Appointment booking calendar.

    There are a number of WPMU Dev plugins working together in this clients solution .. A+, Membership2 and MarketPress (as we add Appt booking to a shopping cart before checkout). Again .. this was all functioning normally until a couple of weeks ago.

    Anyway .. here are the circumstances..

    A = Appointments + Plugin

    B = Easy Social Sharing Buttons for WordPress Plugin

    C = Membership 2 Plugin

    1) NO Issue if A and C (but not B) are activated

    2) NO issue if A and B (but not C) are activated

    3) YES issue if A and B and C are activated

    I have tested this on both our local Dev and the Live Production environments.

    IN our Dev environment, I get this warning popping up when we attempt to access the “Book an Appointment” page (which led me to try deactivating Membership2 as part of the test process):

    WARNING: MISSING ARGUMENT 3 FOR APP_MEMBERSHIP2::GET_PRICE() IN /USERS/AVIDTEST/DOCUMENTS/WEBSITES/ICONONEMULTISPORT.DEV/WP-CONTENT/PLUGINS/APPOINTMENTS/INCLUDES/CLASS_APP_MEMBERSHIP2.PHP ON LINE 89

    And the call stack looks like this:

    #	TIME	MEMORY	FUNCTION	LOCATION
    1 0.0008 305024 {main}( ) ../index.php:0
    2 0.0009 307904 require( '/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-blog-header.php' ) ../index.php:17
    3 1.5764 106980872 require_once( '/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-includes/template-loader.php' ) ../wp-blog-header.php:16
    4 1.6119 107623104 include( '/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-content/themes/avid-vellum/mp_product.php' ) ../template-loader.php:74
    5 2.0488 109160216 get_template_part( ) ../mp_product.php:13
    6 2.0488 109160960 locate_template( ) ../general-template.php:171
    7 2.0488 109161144 load_template( ) ../template.php:477
    8 2.0490 109180240 require( '/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-content/themes/parallelus-vellum/templates/page.php' ) ../template.php:503
    9 2.0505 109181368 the_content( ) ../page.php:14
    10 2.0506 109182312 apply_filters( ) ../post-template.php:230
    11 2.2898 109205440 call_user_func_array:{/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-includes/plugin.php:213} ( ) ../plugin.php:213
    12 2.2898 109205472 do_shortcode( ) ../plugin.php:213
    13 2.2901 109212224 preg_replace_callback ( ) ../shortcodes.php:200
    14 2.2901 109223704 do_shortcode_tag( ) ../shortcodes.php:200
    15 2.2901 109223832 call_user_func:{/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-includes/shortcodes.php:286} ( ) ../shortcodes.php:286
    16 2.2901 109223872 WPBakeryShortCodeFishBones->render( ) ../shortcodes.php:286
    17 2.2901 109223872 WPBakeryShortCode->output( ) ../shortcodes.php:987
    18 2.2902 109224256 WPBakeryShortCode_VC_Row->content( ) ../shortcodes.php:338
    19 2.2902 109224304 WPBakeryShortCode->loadTemplate( ) ../vc-row.php:16
    20 2.2906 109290560 include( '/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-content/themes/parallelus-vellum/templates/vc_templates/vc_row.php' ) ../shortcodes.php:231
    21 2.2909 109296656 wpb_js_remove_wpautop( ) ../vc_row.php:212
    22 2.2912 109297760 do_shortcode( ) ../helpers.php:203
    23 2.2916 109304512 preg_replace_callback ( ) ../shortcodes.php:200
    24 2.2982 109362096 do_shortcode_tag( ) ../shortcodes.php:200
    25 2.2983 109362536 call_user_func:{/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-includes/shortcodes.php:286} ( ) ../shortcodes.php:286
    26 2.2983 109362576 WPBakeryShortCodeFishBones->render( ) ../shortcodes.php:286
    27 2.2983 109362576 WPBakeryShortCode->output( ) ../shortcodes.php:987
    28 2.2983 109362984 WPBakeryShortCode->content( ) ../shortcodes.php:338
    29 2.2983 109362984 WPBakeryShortCode->loadTemplate( ) ../shortcodes.php:222
    30 2.2985 109389176 include( '/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-content/plugins/js_composer/include/templates/shortcodes/vc_column.php' ) ../shortcodes.php:231
    31 2.2986 109390472 wpb_js_remove_wpautop( ) ../vc_column.php:19
    32 2.2991 109390960 do_shortcode( ) ../helpers.php:203
    33 2.2994 109397712 preg_replace_callback ( ) ../shortcodes.php:200
    34 2.2995 109400248 do_shortcode_tag( ) ../shortcodes.php:200
    35 2.2995 109400376 call_user_func:{/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-includes/shortcodes.php:286} ( ) ../shortcodes.php:286
    36 2.2995 109400416 WPBakeryShortCodeFishBones->render( ) ../shortcodes.php:286
    37 2.2997 109429008 WPBakeryShortCode->output( ) ../shortcodes.php:987
    38 2.2997 109429680 WPBakeryShortCode->content( ) ../shortcodes.php:338
    39 2.2997 109429880 WPBakeryShortCode->loadTemplate( ) ../shortcodes.php:222
    40 2.2999 109455760 include( '/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-content/plugins/js_composer/include/templates/shortcodes/vc_column_text.php' ) ../shortcodes.php:231
    41 2.2999 109456632 wpb_js_remove_wpautop( ) ../vc_column_text.php:16
    42 2.3004 109457400 do_shortcode( ) ../helpers.php:203
    43 2.3008 109464152 preg_replace_callback ( ) ../shortcodes.php:200
    44 2.3008 109466312 do_shortcode_tag( ) ../shortcodes.php:200
    45 2.3008 109466752 call_user_func:{/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-includes/shortcodes.php:286} ( ) ../shortcodes.php:286
    46 2.3008 109467264 App_Shortcode_MonthlySchedule->process_shortcode( ) ../shortcodes.php:286
    47 2.3063 109501960 Appointments->get_monthly_calendar( ) ../class_app_shortcodes.php:541
    48 2.3063 109502408 Appointments->get_price( ) ../appointments.php:1999
    49 2.3064 109503544 apply_filters( ) ../appointments.php:837
    50 2.3065 109505360 call_user_func_array:{/Users/avidtest/Documents/Websites/icononemultisport.dev/wp-includes/plugin.php:213} ( ) ../plugin.php:213
    51 2.3065 109505528 App_Membership2->get_price( ) ../plugin.php:213

  • Tyler Postle
    • CGO

    Hey Jeff,

    Awesome troubleshooting! Thanks for the report. I tested this further now and oddly enough it’s still working fine for me. Which led me to think it got indirectly fixed in the most recent version of Membership 2. So I updated yours, but the issue still existed.

    Important: Very sorry about this Jeff, when I updated your M2 to the most recent version it deactivated all of your plugins. I re-activated most of them, was just going off memory and may have reactivated more than I should have or missed one or two :slight_frown: I checked your site and it all looks fine, but just wanted to let you know so you can double check it asap. Again, very sorry! My heart skipped a beat when it happened lol.

    I spoke to the developer and that deactivating plugin issue happened to some members, it’s already been fixed and the fix will be included in the next version of M2.

    Back to your issue here, I’m going to call in one of our SLS staff(coding experts) – hoping they will be able to notice something in the call stack or with the error that could cause this to happen. Your theme could be involved as well, not sure if you tried testing with the 2015 theme or not.

    If you have any further questions in the meantime, let me know! Either myself or SLS will respond back here once they have given it a look.

    Cheers,

    Tyler

  • Jeff
    • Site Builder, Child of Zeus

    Hi Tyler,

    No worries. I just checked out the site. There were a couple of extra plugins activated that were not supposed to be. I’ve reset them back to deactivated.

    FYI – When M2 disabled all the plugins .. it also removed all the content protection settings. I went through and reset the content that needed to be protected. Interestingly, it also added a new (previously non existent) membership level labelled “Protected Content” – there were no members assigned to this new membership level. I deleted it.

    I believe we did test the core issue on the default 2015 WP theme – but – I’m going to go back and check it again on our Dev environment. Shall advise.

    -Jeff

  • Jeff
    • Site Builder, Child of Zeus

    Hi Tyler,

    Well .. this issue has me flummoxed. The flurry of recent Plugin updates seem to be changing the way things are working (or not working).

    Our Dev environment has a differing mix of various plugin updates .. so I went ahead and did some testing on the live site. It appears that the “theme” we use IS, IN FACT playing a role in this issue. I changed the theme back to the default 2015 WP theme and activated all the problematic plugins – A+, Social Sharing Buttons and Membership 2 – no issue (symptoms are gone) with WP 2015 theme. Reactivated the theme we are using (Vellum by Parallelus) and the problem reappears.

    I must reiterate that the Vellum theme has not been updated in this installation (since day one) and that this issue did not exist before M2 (previously – Protected Content) was recently updated.

    This is certainly quite frustrating.

    -Jeff

  • Tyler Postle
    • CGO

    Hey Jeff,

    Sorry about the membership settings! I never noticed that bit :slight_frown:

    This is one of the most complex plugin/theme conflicts I’ve seen I think :p

    Would you be able to send me a copy of that theme too? Sounds like I should be able to replicate it then and we can get to the bottom of this.

    You can send it same way as the plugin: contact[at]wpmudev.org

    and “Attn: Tyler Postle“.

    Look forward to hearing back!

    Cheers,

    Tyler

  • Tyler Postle
    • CGO

    Hey Jeff,

    Thanks for sending that. I think this is server related, as I’m still not getting the same issue. I did notice that after adding that theme my site slowed right down. I thought at some points it was going to timeout. That would explain why it involves so many different plugins too, they aren’t conflicting but the load on the server might be too much.

    Who is your hosting with?

    I’m going to pass this info on to SLS as well. Hopefully they can pin point the issue on the server side if that is the case.

    Hope you had a good weekend!

    Cheers,

    Tyler

    PS. Would you be able to re-grant support access as well so the SLS staff can login?

  • Tyler Postle
    • CGO

    Thanks for the quick reply Jeff.

    Would you mind sending in FTP as well? This could help speed things along as if SLS can’t replicate on their own installs then they will likely need to debug yours further if that is okay. Just let us know.

    You can send that through our private contact form: https://premium.wpmudev.org/contact/

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me :slight_smile:

    Send in:

    Subject: “Attn: Tyler Postle

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    Cheers,

    Tyler

  • Hoang Ngo
    • Code Slayer

    Hi @jeff,

    I hope you are well today and I'm sorry for the delay.

    I tried to replicate the bug on my end, but everything seem fine. So I decide to check on your site, but everything seem fine for me, I try to create a new appointment, and add to cart, the cart is listing the appointments.

    I also tried to save/changes the setting in Service & Service Provider tabs, but they still works fine for me.

    Perhaps I'm missing something, can you please provide me how I can get the bug?

    Thanks!

    Best regards,

    Hoang

  • Jeff
    • Site Builder, Child of Zeus

    Hi Hoang,

    Yes, thanks for the follow-up on this – because this is a live site, we have disabled the series of plugin conflicts that make the bug happen. You can recreate and see the “bug” by activating the series of plugins that create it, as per this recipe..

    A = Appointments + Plugin

    B = Easy Social Sharing Buttons for WordPress Plugin

    C = Membership 2 Plugin

    1) NO Issue if A and C (but not B) are activated

    2) NO issue if A and B (but not C) are activated

    3) YES issue if A and B and C are activated

    Note – we tried to source an alternate Social Sharing button plug-in to test and see if the “issue” would be corrected with another vendors plugin – but the same problem arose (more detail on that up-thread).

    Thanks in advance.

    -Jeff

  • Hoang Ngo
    • Code Slayer

    Hi @jeff,

    Many thanks for your response. Since this is a live site, so honestly I don’t want to reproduce the bug there, if possible, I will clone your site (means I will clone your site to my end, not only just the same theme setting). I do think this way will help me to recover the bug, and fix it :slight_smile:

    If it is ok, I will need your cPanel information. Can you please send in:

    – Mark to my attention – ATTN: Hoang Ngo

    – Link back to this thread

    – Include cPanel (I will need to look at the DB so need PHPMyAdmin or similar)

    On the contact form, select “I have a different question”, this ensures it comes through and gets assigned to me.

    I’m sorry for this inconvenience, and many thanks for your patience.

    Best regards,

    Hoang

  • Jeff
    • Site Builder, Child of Zeus

    Hi Hoang,

    I have forwarded the cPanel access info, as requested. (Sent twice – you may get two copies – as the first time the captcha was not entered – yet the form seemed to process. Since I was unsure if it was properly submitted, I re-sent)

    -Jeff

  • Jeff
    • Site Builder, Child of Zeus

    Hi @hoang,

    Thanks so much! That was the fix – everything seems to work properly now. You ARE awesome!

    For my benefit – could you please let me know how/where you changed the memory limit. Was that done in php.ini ??

    Also – thanks to @tyler Postle for the perseverance to get this resolved!

    I will mark this as resolved.

    -Jeff

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.