Appointments+ Break Hours Not being respected

I recently had an issue regarding A+ hours not reflecting properly and discovered the problem as to why it was happening.

Something is wrong with the break hours in my A+ setup. Even when they are set to no, they are still blocking out hours - but only on Sunday.

When I set the working hours for a SP and turn the Break Hours to "No", the hours that are in the Break Hours section are still blocked out on the calendar. The strange thing is, is that it only occurs on Sundays.

Ex: Regular working hours ("Yes") 9 am -3 pm | Break hours ("No") 12pm -3pm - In the calendar that is reflected the hours 12pm - 3pm are greyed out. This only happens on Sundays and across multiple SP's.

I solved the problem by switching the break hour times to shorter selections during hours that the SP's don't have as working - that way there is no conflicting time. But this is not a solution to the problem, merely a workout. Other users may have different working times for their SP's and this could cause a potential issue.

Just wanted to let you know to see if you could take a deeper look into this.

Thanks again!
Judah

  • Tyler Postle

    Hey Judah,

    Hope you're doing well today! Just want to follow up here. Are you making sure to select the specific provider? and it's still blocking off break times even though it is set to "No"?

    Often an issue here is if "No specific provider" is selected when making changes and not the actual provider.

    I tested this on my install and I'm not able to reproduce the issue, its working as expected for me.

    If you still need further assistance could you grant support access?

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Then we can take a closer look :slight_smile:

    Hope you had a great weekend!

    Cheers,
    Tyler

  • Judah

    Hey @Tyler Postle,

    Here are the hours settings for the SP;

    Here is the display of that SP's calendar:

    Even though I have break hours set to "No" they are still being blocked out. I tried the suggestion by @Calvin but it did not work and I changed that setting back to "No".

    I will send you the FTP details via the contact form now so you can a look at my setup.

    Please let me know if you have any additional questions.

    Thanks,
    Judah

  • Judah

    Hey @Tyler Postle,

    Sorry for not getting back to you sooner but I was out of the country.

    In order to access the calendar page you need to login as a student (you should have the access info) and go here.

    I am using the below shortcodes to display the calendar
    [app_service_providers select="Please select a teacher" service="1" empty_option="Please select a teacher" autorefresh="1" order_by="name"]
    [app_monthly_schedule]
    [app_pagination month="1"]
    [app_confirmation title="Please check the appointment details below and confirm:" button_text="Confirm Lesson"]

    Whats strange is that this issue is only happening on certain days:
    Sunday, Monday and Thursday.

    Here are the settings used to test what days this was happening on but I have since changed them (as this is a test account & I don't want users booking anything with this SP)

    Here is the output for that SP with the settings - Note I was able to display two days' times simultaneously as there is bug in the system. The two days I selected are a Monday and a Tuesday - you can see that Tuesday is working properly but it's blocking hours on Monday.

    Please let me know if you need any additional information.

    Thanks,
    Judah

  • calvinrogercanas

    Hi Judah,

    Thanks for your reply.

    I tried to reproduced the issue with my own install but it seems working fine for me. It might be a conflict between a plugin or on the theme? Since this is a live site, I suggest you try to reproduce this by cloning your site and make the clone as your dev/staging site. This way you can experiment without worrying that something might break.

    When I temporarily enabled the debug it show some errors so the suspicion of plugin conflict increase and it maybe blocking the specific timeframe.

    Looking forward for what you will find out.

    Kind Regards,
    Calvin

  • Judah

    Hey @Jude, @Calvin @Tyler Postle..

    So I installed a brand new local WP with just the Appointments+ plugin installed.

    I copied the exact settings and was able to reproduce the issue - but its even stranger now.

    I don't even know how to describe what is going on but all I know is that after you modify something with the paddings, things get really strange.

    I switched the paddings back and re-set everything (regarding paddings/appt time length) to normal, created a new Service Provider and things went back to normal. I can't reproduce the issue anymore.

    For my local copy of my website, I removed all other plugins, set A+ to a clean version and changed the theme but the issue was still happening. I reset the paddings/services but it was still happening.

    I have been at this for a few hours now so I think I will give it another shot tomorrow. Hopefully I can pin down what is causing this to happen.

    Will keep you updated.

    Thanks,
    Judah

  • Judah

    Hey All,

    I did some further testing and cannot pinpoint the problem.

    I created a new service provider and when I applied the same service, working hours and beak hours (set to no), their hours were not being blocked out.

    I deleted a SP, then added them back in and re-setup their hours. and was still getting the same issue.

    That leads to me believe that there is something going on with how the SP's are stored in the DB? I honestly have no idea anymore.

    If you have any suggestions on how/what to test please let me know and I will give it a shot.

    Thanks,
    Judah

  • Judah

    Hey @Tyler Postle,

    This is still an issue for me and I have no idea what is causing it or how to replicate the issue.

    My workaround is setting the break times to a day/time that the SP is not working even though break times is set to off.

    Not sure if you will be able to solve/help. Just annoying for me to have to set up the working hours and make sure the break hours don't conflict.

    TBH this is a minor issue when it comes to the bugs I have with Appts+

    Still desperately waiting for a working timezone conversion feature as well as the padding working fluidly in the front and backend across all settings.

    I am going to mark this complete even though the real solution doesn't exist but there is a workaround.

    Thanks again for following up and all the help!

  • Tyler Postle

    Hey Judah,

    Thanks for your reply!

    My workaround is setting the break times to a day/time that the SP is not working even though break times is set to off.

    Glad you have a workaround; however, it is very odd that this issue is happening at all as I've not seen it before. It could be a conflict with some other custom code that has been added. If you ever do want to re-visit this issue then just let us know :slight_smile:

    Still desperately waiting for a working timezone conversion feature as well as the padding working fluidly in the front and backend across all settings.

    Yes, timezone feature and a padding re-write would be awesome in my opinion too. We will hopefully get both these added during our Appointments+ rewrite, if not before it.

    Enjoy the rest of your day Judah!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.