Appointments+ breaks site after updating to PHP5.3.28

The site is with Crazy Domains and appointments+ was working fine. I had been trying to get the Google Calendar integration which let me know I needed PHP5.3 to get working. I requested an upgrade from Crazy Domains and when the performed the upgrade the site doesn't load at all. Just a white screen with no HTML for front and backend on all pages. If I rename the plugin to appointments_BAK the site loads normally. I tried deactivating and deleting all plugins and as soon as I activated Appointments+ the site went back to the white screen again. Any help would be great. Should I just go back to PHP5.2 so I know it works and forget about Google Calendar sync?