[Appointments+] Calendar not showing booking

Hi

A have set up 3 providers, 2 services, and made a appointments page via the checkbox on the settings page.

One service is 30min massage, the other is 60min massage, but when choosing a provider and booking a 30min massage, it does not show up when looking at the calendar for booking 60min massages. Oddly the booked 60min massage showes up on the calendar when booking 30min massages.

What's causing this problem ?

All the best
Carsten

  • Elliott Bristow
    • The Bug Hunter

    Hi Carsten,

    How are the services and providers set up? If more than one service provider is providing the same service it will still show as available, unless you set capacity to 1.

    Perhaps if you could give us a brief rundown of your settings we can see if there's anything that might trigger this behaviour, or if indeed this is a bug.

  • Carsten
    • Design Lord, Child of Thor

    Hi Elliott

    Thanks for your reply :slight_smile:

    The 3 providers can provide both services.

    But when choosing one provider on the booking page, then the calendar shows the bookings for that specific provider ?

    The wierd thing as descibed, is that on the 30min booking calendar, the 60min booking shows, but the 30min does not show on the 60min, so a double booking is possible with the same provider.

    You can check and see here: http://www.gittehovmand.dk/make-an-appointment/ choose provider Jeanine and sep 10.

    Is there any special setting you're thinking of, or do i need to take screenshots of all the settings ?

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    I've checked your site and you appear to have 4 x Service Providers setup.
    Is that correct?

    I also can't click on any of the times.
    Do you have 'Login required' field in the 'General' tab set to 'Yes'?

    Could you please screenpost the following:-

    All the settings in your A+ 'General' tab
    All the settings in your A+ 'Services' tab
    All the settings in your A+ 'Service Providers' tab

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    Out of interest when you select a 'Service' from the dropdown are you clicking the 'Show Available Times' button under the 'Service' dropdown?

    If you are then can you confirm if you do the same when you have selected a 'Service Provider'.
    That is: Are you clicking the 'Show Available Times' button under the 'Service Provider' dropdown?

    The action of clicking the button refreshes the appointment page and ensures the correct scheduler is being viewed.

    To make the process easier you could revise two of your shortcodes in your Appointment page to:-

    [app_services autorefresh="1"]
    [app_service_providers autorefresh="1"]

    This will remove the two 'Show Available Times' buttons and automatically refresh the page when a 'Service' and 'Service Provider' have been selected ensuring the correct scheduler is being viewed.

    Could you please try this and confirm if this resolves your problem.

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi Steve and Elliott

    The suggestions by Steve, did not change a thing, it's still the same problem.

    When selceting 30min massage, i can see the 60min massage, but when selecting the 60min massage, i can't see the 30min massage.

    I have now both the 17th and 18th setup for appointments, but none of them show all appointments.

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Elliott Bristow - I'm not around for the rest of the week and would appreciate if you could follow with my latest feedback.

    Hi @Carsten

    Can you please confirm if you are clicking the 'Show Available Times' button under the 'Service' dropdown and the 'Service Provider' dropdown to refresh the page?

    Could you also confirm if you revised the two shortcodes in your Appointment page to:-

    [app_services autorefresh="1"]
    [app_service_providers autorefresh="1"]

    if you did could you please screenpost all the settings for the following:-

    'Services' tab
    'Service providers' tab
    'General' tab

    Regards
    SteveB

  • Elliott Bristow
    • The Bug Hunter

    Hey guys,

    I've had one or two threads where people have said they are attaching screenshots and they haven't appeared at our end. I'm not sure if there is a problem there so for now I would suggest posting screenshots via Dropbox, Imgur or some other image sharing service just to be sure.

    I'll ask the admin guys if there is a problem with posting attachments at the moment.

  • pxwm
    • WP Core Meltdown

    Hi @Carsten,

    Apologies I completely missed the links as I had been away and they were towards the beginning of the Topic.

    I've just checked the settings and they look fine.

    I've just viewed your appointments page and tried to make an appointment and getting a constant spinning wheel.

    Could you please post all the shortcodes in your appointments page with the page set to 'text' so I can see all the code and text in the page.

    Could you also screenpost all the settings in the 'Google Calendar' tab

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi Steve

    It's alright :slight_smile:

    I have sometimes gotten the spinning wheel too.

    I'm not sure what has happened, cause now it's greyed out, the timeslot, look at 11.30, Jeanine on the 25th.

    Here's the shortcodes:
    ------
    <table>
    <tbody>
    <tr>
    <td colspan="2">[app_my_appointments]</td>
    </tr>
    <tr>
    <td>[app_services autorefresh="1"]</td>
    <td>[app_service_providers autorefresh="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_monthly_schedule]</td>
    </tr>
    <tr>
    <td colspan="2">[app_pagination step="2" month="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_login]</td>
    </tr>
    <tr>
    <td colspan="2">[app_confirmation]</td>
    </tr>
    <tr>
    <td colspan="2">[app_paypal]</td>
    </tr>
    </tbody>
    </table>
    ---------

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    Many thanks for the additional info.

    The shortcodes look fine.

    I've checked your appointment page and I'm still getting the spinning wheel so suggest there is some conflict and I suspect it is another plugin or the theme.

    However before we work on this problem I checked the schedule and selecting:-

    Hospital-massage 60mins and Jeanine on the 25/9/13 the 11h00 time slot is greyed out.

    Is it possible you could screenpost the following:-

    The 'Working Hours' tab for Jeanine
    The 'Exceptions' tab
    The 'Google Calendar' tab

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    All the links appear to display the working hours for Jeanine.

    The settings look fine and would appreciate if you could provide a screenshot of:-

    The 'Exceptions' tab
    The 'Google Calendar' tab

    Also if you could provide a list of the plugins you are using.

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    I've checked the plugin and don't recognise any that I am aware cause problems.

    I'm still getting the dreaded spinning wheel.

    I can only suggest that you take a full backup of your site and database to give you a rollback option and then:-

    Initially revert your theme back to a default then check

    If this still causes the spinning wheel then unfortunately it may be a matter of deactivating the plugins and checking.

    There is one alternative option and that is to uninstall A+ completing and removing the data in the database and starting again.

    The easiest option is to try reverting to the default theme but if this doesn't work you will have to decide the next best option.

    Hope that helps
    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hello again :slight_smile:

    Sorry for this late reply, but have had a busy work-life.

    I have now tried to install a new WP 3.6.1, Genesis 2.0.1, child theme: Delicious 1.0.1, and then downloaded and installed Appointments +.

    I even created a new database for this test.

    There is no other plugin installed.

    And i still get this problem, when making an 30 min Default Service, it does not show-up on the 60 min Default Service 2, so i can double book, and that's not good ?

    One other thing, you're having problems testing the site, you get a spinning wheel, that's be course the plugin hangs in some way, the eplugin thinks that you need to login to make an appointment, but the options is not turned on ?

    I have had it turned on, but then turned it off again, but the plugin does not let go of the setting.

    EDIT: But the problem does not exist on the new install, even though i turned login required on, and then off again.

    EDIT 2: The test site is http://www.fredidalen.dk, and one other thing i found out during testing, when adding a new provider Gitte, then the 30min is greyed out on the 60min calendar, but when adding one more provider, Henny, it's not showin up - the first testers name who does not show 30min on 60min calendar, is Carsten. Both new providers is added as new users to WP from sccratch.

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    I've checked the appointment page on your site and it appears to allow me to book an appointment, so no spinning wheel.

    I've also checked back through the posts at the screenposts and I would appreciate if you could confirm the following:-

    It allows me to book an appointment for either service with the 'Service Provider' dropdown selected as 'no preference'.

    Is this what you require or do you want the customer to select a specific Service Provider?

    Also to confirm:-

    You have 2 x Services and 3 x Service Providers assigned to both Services.
    This means that a customer(s) can book Service1 3 x times for the same date/time
    Or they could book Service1 twice and Service2 once for the same date/time.

    Is this the issue you are having or is this acceptable?

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi Steve

    Nope, the problem is that the calendar does not mark the 30min appointment time booked when viewing the 60min calendar.

    If you book a 30min appointment at 10am, it will not show up when you go an want to book a 60min appointment at the same timeslot.

    Something is not telling the 60min calendar, that there is a 30min booking at 10am.

    That's the calendar problem.

    The other problem is that i need to know why my plugin on the real site hangs, where in the datebase do i reset that setting, and why does it hang at all ?

    I have had the login requered seetting turned on, then of, but it didn't turn it off, the checkbox is empty, but the plugin acts like it's turned on.

    And i have discovered a 3rd problem, when clicking the button to get to next month, it skips november and jumps to december ?

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    Hope you don't mind as I've made some test appointments on your test site.
    I can confirm I can replicate your problem.

    Could you please provide a screenshot of the following:-

    'Services' tab
    'Service Providers' tab

    Assuming your shortcodes are as per an earlier post then I think I know what the problem is with the scheduler jumping over months

    Could you revise the following line in your Appointments page

    From:
    <td colspan="2">[app_pagination step="2" month="1"]</td>

    To:
    <td colspan="2">[app_pagination month="1"]</td>

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi @Steve

    The solution woorks for the test site, but not for the real site, so something has went all wrong with that install, and i'm going to uninstall the plugin, and then reinstall it.

    But it does still not do anything about the dounble booking problem, and regarding the thread you posted a link to, it's a bug, so that doesn't get me any futher either.

    The screenshots as posted in the beginning of the thread: http://imageshack.us/g/21/glt0.png/

    Screenshots from test site:

  • Carsten
    • Design Lord, Child of Thor

    Hi again @Steve

    I think i located the bug a bit further.

    When choosing anything half past (e.g. 8.30, 9.30, 10.30 aso), then the 30min is greyed out on the 60min calendar.

    When choosing anything like 8.00, 9.00, 10.00 aso., the 30min does not show up on the 60min calendar.

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    I've checked the settings in the screenshots you provided and just wanted to check the following in your 'Service Providers' tab.

    Could you please confirm if the 'dummy' checkbox is ticked or not for all three 'Service Providers' because I can't tell from the image?

    If they are ticked then this may be the problem as you need one 'real' Service Provider.

    Could you try unchecking the 'dummy' checkbox for 'carsten'
    Then Save

    Then select the A+ 'general' tab and scroll down to the 'Accessibility settings' section and then select 'carsten' from the dropdown in the 'Assign dummy service providers to' field
    Then Save

    Then check to see if this helps

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi again @Steve

    The dummy is not ticked, only real providers.

    EDIT: Have just tried to delete the pugin and reinstall it on the live site, but it does not clear out the error of skipping af month, when jumping to the next.

    EDIT 2: And still hangs on the login check with the spinning wheel too, and the login needed is not ticked.

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    Could you please post all your current shortcodes in your appointment page with the page set to 'text' on the live site.

    Could you confirm when you installed the plugin did it give you an option whether to wanted or retain the database?

    If so did you opt to keep the database or delete?

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi @Steve

     
    <table>
    <tbody>
    <tr>
    <td colspan="2">[app_my_appointments]</td>
    </tr>
    <tr>
    <td>[app_services autorefresh="1"]</td>
    <td>[app_service_providers autorefresh="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_monthly_schedule]</td>
    </tr>
    <tr>
    <td colspan="2">[app_pagination month="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_login]</td>
    </tr>
    <tr>
    <td colspan="2">[app_confirmation]</td>
    </tr>
    <tr>
    <td colspan="2">[app_paypal]</td>
    </tr>
    </tbody>
    </table>

    I didn't get any question wether to keep or delete the database, should i have bin asked that ?

    I can see theat there's an update of the plugin, does this means that the bouble booking problem is fixed ?

    "Fix for the "only one service and only one provider per time slot" condition"

    EDIT: I now tried to install the new 1.4, and i didn't get any question regarding the database, and i still have the login problem.

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    I've checked your shortcodes and they look fine.

    As you have stated that it works fine on your demo site then I would suggest you either have a plugin or theme conflict on your live site or you have a problem with the A+ install/database.

    If you haven't already tried, you may wish to take a full backup of your live site and a backup of your database then try deactivating your other plugins and/or revert to the default theme and check.

    To confirm you will only be prompted to delete or retain your database settings when you uninstall the plugin not when you upgrade.

    Did the upgrade to v1.4 resolve your booking problem?

    I will be upgrading to v1.4 on my demo site in the next few days to test out.

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi @Steve

    Yes, it solved the problem with the double booking problem, upgrading to 1.4 :slight_smile:

    I completly uninstalled the plugin, before installing it again, and i never got a question regarding the database.

    I went through the database yesterday, cleared out anything which has nothing to do with what's installed, but nowhere there was anything regarding the A+ plugin.

    I have tried some login/redirect plugins, i think one of them is the bad guy, but i still doesn't understand it, cause i have bin through the database, so maybe there's something in a file somewhere.

    All the best
    Carsten

  • Carsten
    • Design Lord, Child of Thor

    Hi again @Steve

    Do you have anything on Genesis Framework 2.0 and problems with this plugin ?

    When switching to WP 2013, the login problem isen't there.

    EDIT: Hmm, seams to be something in my functions.php file, will get back when i catch the 'rat' :slight_smile:

    All the best
    Carsten

  • Carsten
    • Design Lord, Child of Thor

    Hi @Steve

    I found what was causing th eproblem with the required login not letting go.

    function restrict_admin()
    {
    	if ( ! current_user_can( 'manage_options' ) ) {
                    wp_redirect( site_url() );
    	}
    }
    add_action( 'admin_init', 'restrict_admin', 1 );

    I'm not sure which plugin added this, but when deleting this, there's no problem booking an appointment without being logged in :slight_smile:

    All the best
    Carsten

  • Carsten
    • Design Lord, Child of Thor

    Still a wierd thing with the calendar skipping december and jumping to january 2014 ?

    <table>
    <tbody>
    <tr>
    <td colspan="2">[app_my_appointments]</td>
    </tr>
    <tr>
    <td>[app_services autorefresh="1"]</td>
    <td>[app_service_providers autorefresh="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_monthly_schedule]</td>
    </tr>
    <tr>
    <td colspan="2">[app_pagination month="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_login]</td>
    </tr>
    <tr>
    <td colspan="2">[app_confirmation]</td>
    </tr>
    <tr>
    <td colspan="2">[app_paypal]</td>
    </tr>
    </tbody>
    </table>

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    Really good news you have resolved the log-in problem.

    This may be a silly question but please bear with me.

    Could you please confirm if you have setup more than one appointment page?
    If you have could you please check the shortcode in the other appointment pages.
    If you haven't could you please try the following:-

    Remove all the formatting from your shortcodes so you have:-

    [app_my_appointments]
    [app_services autorefresh="1"]
    [app_service_providers autorefresh="1"]
    [app_monthly_schedule]
    [app_pagination month="1"]
    [app_login]
    [app_confirmation]
    [app_paypal]

    Then Save

    If this doesn't work could you please confirm that when you click next it jumps two months each time

    e.g. Clicking 'Next' jumps to Jan 2014' but if you click again does it jump to 'Mar 2014.
    Also if you then click 'Previous' does it jump back two months?

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi @Steve

    I did actually delete the page, so that A+ 1.4 could make a new one, so nothing old was left.

    And yes, it's every time i click next month, it jumps two months e.g. jan, mar, may a.s.o.

    All the best
    Carsten

  • pxwm
    • WP Core Meltdown

    Hi @Carsten

    That is very odd.

    Could you please confirm if you have removed all the formating code in your appointment page so the shortcodes look like below just to ensure there isn't some eroneous code that has been added:-

    [app_my_appointments]
    [app_services autorefresh="1"]
    [app_service_providers autorefresh="1"]
    [app_monthly_schedule]
    [app_pagination month="1"]
    [app_login]
    [app_confirmation]
    [app_paypal]

    If this doesn't resolve the problem then I suggest you may have a theme/plugin conflict as with your login problem.

    Could you please take a full backup of your site and your database so you have a rollback option and then try:-

    Reverting to a default theme then check
    If this doesn't work could you try deactivating your plugins one at a time

    Regards
    SteveB

  • Carsten
    • Design Lord, Child of Thor

    Hi @Steve

    I found the problem, i had forgot to change the menu, so it was running on the old 'make an appointment' page, and not the new, that's why updating the shortcode didn't work - so all is well now with this :slight_smile:

    The other thing is the cancellation email, i have opened a new thread on that.

    All the best, and thanks for your help :slight_smile:
    Carsten

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.