Appointments + Confirmation Information Incorrect

Hi,

I have finally got the location to display on the confirmation using the code hack listed here https://premium.wpmudev.org/forums/topic/list-location-in-app_confirmation.

Now I have discovered that the confirmation Service name and Location written in the confirmation area is always the same regardless of the choice made above in Location and the service.

I have tried checking the clear cach option.

Please advise?

  • Adam Czajczyk
    • Support Gorilla

    Hey Natasha,

    I hope you're well today and thank you for your question!

    I assume that you've applied the code from this post:

    https://premium.wpmudev.org/forums/topic/list-location-in-app_confirmation#post-758438

    I took a look at it and it seems it should take location change into account, however please note that since October 2014 there's been a few updates to the plugin and this code may be no longer relevant.

    I think though that it would be great to test your site against plugins/themes conflicts first. As the code uses a tiny JS snippet it's possible that something's interfering with it.

    That being said, could you please follow the steps below, each time checking for an issue?

    1. Revert to a default Twenty Fifteen theme
    2. Disable all plugins (except Appointments+) and then enable them "one by one"

    If at some point the code starts to work, we'll be able to find the fix. Let me know please of the results of the test!

    Cheers,
    Adam

  • Natasha
    • WPMU DEV Initiate

    Adam,

    thanks for the reply. That seems a long debug to get the app working correctly.

    Is there a way to do this without having to mess with themes and plugins? The site is live and there is no test platform in place.

    I had to modify the code as per the post as the locations would not work without it.

    It seems that whatever changes I make to thh appointment the location and service stay static like a hard coded value or default? The time and date work fine???

    There is an update to 1.51 I believe, If I update to this will it overwrite changes I have made? Then finally how do I get the locations working without having to make these changes?

    Kind Regards

    N

  • Natasha
    • WPMU DEV Initiate

    I have rolled back the changes made to both:

    shortcodes.php
    appointments.php

    Please see attached screen shot.

    With the code back to where is was it is still the same.

    The process I have followed is:

    Arrive at page
    Choose Location
    Location chosen turn into choose service
    At this point I can either choose the date below or push the show available times. Which only seems to reload the page? What should this button do?
    If I choose a day insead of pushing the button. I can choose the time on the right.
    Which then displays the confirmation

    Your thoughts?

    N

  • Natasha
    • WPMU DEV Initiate

    Adam,

    with all plugins except appointments + active and the 2015 theme applied. The issues are the same. The choice of service is not reflected in the confirmation at the base of the page.

    Please advise asap. We have paid for the location addon and now the site is broken.

    N

  • Predrag Dubajic
    • Support

    Hi @Natasha,

    At this point I can either choose the date below or push the show available times. Which only seems to reload the page? What should this button do?

    Show available times button will refresh the page and change the calendar to show available times for selected service, if you don't click on the button you will be booking time for different service, and that's why you are seeing different service names.

    You can change your service selector shortcode so it hides the button and automatically refreshes the page after selecting the service, this is how the shortcode should look:
    [app_services autorefresh="1"]

    Also, Would you mind allowing support access so we can have a closer look at your booking behavior?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Predrag

  • Natasha
    • WPMU DEV Initiate

    Predrag,

    I have activated support access:
    Support access is ACTIVE until August 20, 2015 1:16 pm

    Also I changed the code as you suggested with the same results unfortunatley.

    <td colspan="2">[app_required_service_locations autorefresh="1"]</td>

    Let me know what else you need.

    N

  • Predrag Dubajic
    • Support

    Hi Natasha,

    Thanks for the additional info and for granting access, I was doing some further testing with A+ based on your setup and it looks like we have a bug in app_required_service_locations shortcode.

    I'm reporting this bug to our developers and in the meantime you could try using something like this instead of that shortcode:

    [app_service_locations autorefresh="1"]
    [app_services autorefresh="1"]

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Natasha,

    Thanks for getting back, I was sure it worked for me yesterday but after another test it doesn't work on my installation as well.

    I have forwarded all the details to the developer and fix for this will be included in next release of the plugin.

    Thank you for bringing this up to our attention.

    Best regards,
    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hey Natasha,

    I hope you're well today!

    I understand that this is a crucial for you so I'm sorry for the delay. The latest update of Appointments+ has been released on Sept 3rd. Unfortunately I'm not quite sure if this was the one as the developers use their own "code versioning" for fixes. I'm pretty sure though (judging by the dates) it should be this.

    That said, have you updated the plugin already and if so, did the update solved the issue?

    Let me know please!

    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.