Appointments+ confirmations not firing after clicking on an appointment time.

Yesterday, the Appointments page (Book) was working fine. I cloned the page and was going to show the owner the option of letting the clients select a service and provider without having to click a button. I added the autorefresh="1" to the services shortcode, and the providers shortcode - and this was just on the clone of the booking page.

I was also changing the Google Calendar API so that each provider would have appointments go to their respective calendars. All staff were previously sharing one google calendar, and it had become confusing as they grew.

The site uses Divi Builder, but I don't think it is the cause, because Appointments+ was working like a trooper on a Divi-built page up until yesterday.

I think the issue is related to the work I was doing to change them from a single Google Calendar, to one for each provider. There is one provider that I haven't been able to get a hold of this weekend to set up her shared calendar - and I'm thinking the problem is that she is on the list of providers, but I don't have a calendar to point her new appointments to.

We're slow on weekends, not expecting much appointments traffic if any. I've opened support access to theSLN.com (the Speech Language Network)

  • Rupok

    Hi Tim, hope you had a wonderful day.

    I could see a JavaScript error on your console. And yeah, when I tried to select a date from your calendar, the time box appears, but I can't click any of the times.

    Before we investigate if Appointments+ configuration is misconfigured, can you please do a plugin conflict test just to make sure no other plugin is causing this? To know more about plugin conflict test, you can check this article: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Moreover, can you change your theme to any default WordPress theme and check if the issue is still there?

    If none of them helps, can you remove "autorefresh" parameter from the shortcode and check? Please let us know the result.

    I think the issue is related to the work I was doing to change them from a single Google Calendar, to one for each provider

    Can you try setting up single Calendar again and check if the issue is gone? If not, then this is not the reason.

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

    • Tim

      Have a look at the things I've tried, and see if anything makes sense to you. I'll explain how I understand the Google Calendar API to Appointments+ procedure... ( and I may be wrong - and that's causing the issue)
      We have 4 Providers "A", "B", "C", and "D" who have already set up a Google Calendar to receive new appointments from Appointments+
      I log into Google Chrome using the Google Apps admin account for our domain.
      I log into our website and set up the Google Calendar API with Appointments+

      I log into Google Chrome as Provider "A" and log into our website using the admin account. I go to Provider "A" 's User Profile and click "Generate your access code". ...Appts would like to Manage your calendars - Allow. I copy the access code into Provider "A" 's user page, and click Update User.
      I logout from wordpress.

      I start another chrome session and log in as Provider "B". I log into the website as admin, and repeat the above to create an access code in Provider "B" 's user profile.

      Rinse and repeat for Provider "C" and "D"

  • Tim

    Thanks Rupok.

    Before I started working on the site yesterday, I removed unused themes (2013 and 2014), updated any plugins, and themes. We have the Divi theme, with an active Divi Child Theme. After I did this house cleaning, I exported all the appointments up to that time ~1400 as CSV.

    I then went to the 'Book' page (where they have the Appointments+ http://thesln.com/book/), and tried to pick various services and providers. I noticed that the Service would change after picking the Provider if I didn't click "Show available times" beside the Service prior to selecting a Provider. I did find the short codes to eliminate this, but I didn't use them on the live page; I just tried it on a clone of the Booking page (which I have since removed).

    In a similar support ticket, I followed the procedure of adding the following code to a new page - text tab without Divi Builder) and I still gpt no response for the confirmation after clicking an available time. from (https://premium.wpmudev.org/forums/topic/appointments-shows-timeslots-but-nothing-happens-when-a-customer-clicks-on-one)
    <table>
    <tbody>
    <tr>
    <td colspan="2">[app_my_appointments]</td>
    </tr>
    <tr>
    <td>[app_services]</td>
    <td>[app_service_providers]</td>
    </tr>
    <tr>
    <td colspan="2">[app_monthly_schedule]</td>
    </tr>
    <tr>
    <td colspan="2">[app_pagination month="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_login]</td>
    </tr>
    <tr>
    <td colspan="2">[app_confirmation]</td>
    </tr>
    <tr>
    <td colspan="2">[app_paypal]</td>
    </tr>
    </tbody>
    </table>

    What I have just tried... Went to Appointments+\Settings\Google Calendar
    - Changed "Allow Service Providers for Google Calendar API Integration" to No
    - 'Appointments will be sent to Google Calendar for" - I left this set to "All"

    Should I also reset the GCal API credentials? Making these changes so far hasn't fired the confirmation output.

  • Tim

    Next step; Logged into Google Chrome using the Google Apps account that hosted the single calendar shared by all staff last week.

    @ Appointments\Settings\Google Calendar I clicked the 'Reset API Credentials' button.
    Went to the Google API manager and copied the Client ID and Client secret to the Appointments+ fields. Generated the Access Code, and copied to the awaiting field. Saved changes. Returned to Booking page and the confirmations won't fire. Went to the test page with just the shortcode, and the confirmations won't fire.
    ** The autorefresh codes aren't in play on their booking page, nor the draft page I've just created to troubleshoot this. I've run aground at this stage.

  • Kasia Swiderska

    Hello Tim,

    Divi theme is throwing JS error that is probably breaking other scripts on the site - I found here that new version has this fixed https://wordpress.org/support/topic/read-this-first-wordpress-45-master-list?replies=7

    Divi
    Divi Version 2.7.3 ( updated 04-13-2016 ) fixes the jQuery issue outlined below. Update your theme.
    Exhibits the jQuery problem as described below. The file js/custom.js has the issue on line 706. Adding double quote marks around the hash symbols (#) will fix it.
    Change this:
    $( 'a[href*=#]:not([href=#])' ).click( function() {
    To this:
    $( 'a[href*="#"]:not([href="#"])' ).click( function() {

    your Divi is not updated. Please update it to remove that error.
    I was able to replicate it on older version of Divi also - I changed to theme that doesn't throw that error and appointments started to working.

    This is not issue with Google Calendar - it is issue with JS scripts that is why it's important to update theme so it wont throw that error.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.