Appointments+ Dummy Service Providers

This is the second install of Appointments+ I’ve done and I thought I had the Dummy Service Provider setup straight in my head. I guess I don’t.

We have a Coach who is available early in the AM for a 2 hour block of Swim training (Service called: One on One training ID-01) Monday, Wed and Friday from 5am to 7am most days, but somedays that schedule is cut to 1 hour.

To handle this we have setup two dummy service providers (both assigned to the Coach). DSP1 is available for the 5am to 6am shift and DSP2 is available for the 6am to 7am shift. I thought this strategy would allow us to assign an “exception non working day for either DSP1 or DSP2 when the coach only wants to be available for a single bookable hour, on the odd day.

If I assign DSP1 OR DSP2 to the service (One on One training ID-01) – the Appointments availability calendar displays as expected. BUT if I assign BOTH DSP1 and DSP2 to the service, the calendar displays BUSY for the entire week (Monday through Friday). This is despite the fact that DSP1 and DSP2 are the only providers assigned to this service and they only work one hour each Mondays, Wednesdays and Fridays.

Either I am totally misunderstanding the proper way to configure Dummy Service Providers, or something else is awry. I have read through all the FAQ’s, and searched the support forums extensively – now I’m at a loss.

(I have also disabled all other plugins to see if it is a plugin conflict. It is not).

  • Jeff
    • Site Builder, Child of Zeus

    Hello Vaughan,

    Thanks for the response. I’m doing well and hope your day is going well too.

    Shared services addon is disabled. The “Capacity” setting under the Service tab is set to zero (although I have tinkered with it – no change).

    I have turned on Support Access – thanks for looking – I hope you can spot something.

    Thanks again – Jeff

  • Jeff
    • Site Builder, Child of Zeus

    Hi Vaughan,

    Just checking back in to see if you were able to get logged in through the support access.

    I’ve made a few other trial adjustments to the dummy service provider settings in an attempt to resolve this problem – but – so far, no success.

    Thanks in advance.

    -Jeff

  • Jeff
    • Site Builder, Child of Zeus

    I’ve adjusted numerous settings and tried several differing iterations. Nothing I have done has allowed any of the appointment times to display in the calendar if BOTH Dummy providers are enabled for service (One on One Training – ID01).

    I have deleted and recreated new dummy providers – no joy – same issue.

    If either one of the dummy providers is enabled – the time slot displays for that provider. If the other provider is also enabled – Nothing is displayed for either provider.

    Thanks for any assistance.

  • Vaughan
    • Support/SLS MockingJay

    Hi Jeff,

    Sorry for the delay, we’ve had a hectic few weeks which has meant our queues are a lot bigger than they should be.

    I’ve taken a look, Apps+ is quite complicated.

    The reason I can see for this happening is because you are not assigning a specific provider on your book an appointment page, so when you try to book, because no provider is selected, it refers to the No specific provider time table, which you had set as no for all working hours.

    This only happens when you have more than 1 provider assigned to the service, if you only have 1 provider assigned to the service, then that provider is used. But having 2 providers means you are required to select a provider to use, if none is selected, the default (no specific provider) working hours are set.

    What I have done is set the no specific provider working hours for monday to be 5am till 8am with 1hr break between 6am & 7am so you now have 5am – 6am & 7am till 8am available.

    So Now, on your other services (products pages) for Shelly only, not the dummy providers, be sure to set the worker id to shelly in the shortcode.

    [app_monthly_schedule worker="12"]

    This will make sure that shelly is selected automatically as the provider, and prevent the no specific provider from being used (as that is set up for the dummy providers product (service 1)

    I can’t think of any other way of doing this with your specific scenario.

    If you could check it out and see if that’s ok for you? any other issues, just let us know :slight_smile:

    Hope this helps

  • Jeff
    • Site Builder, Child of Zeus

    Hi Vaughan,

    Thanks for logging in and taking a look at that. I was unaware of the fallback to the “No specific provider” when using the dummy providers.

    Now that we have that wrinkle running, I’ve run into another. One of the primary reasons to set things up this way (with dummy providers) was to allow for the odd exception day – whereby one of the time slots is not available for Service 01. Eg: the 5am to 6am slot is available – but the 7am to 8am is not (but just for the exception date).

    I thought that this could be achieved by adding an “exception – Non working day” to the Dummy Provider that is providing service in the 7am to 8am slot. To test – I set March 23 as the “Exception – non working day for Dummy provider DS-1-2. BUT – this does not seem to work. The 7am to 8am slot is still available for March 23rd. (Also tried to add the exception date to the “No Service Provider” but that didn’t work either.)

    Whew – A+ is very complex plugin to setup if the “use-case” is anything other than a straight-up schedule that stays the same on a weekly/daily basis.

    Thanks in advance.

  • Jeff
    • Site Builder, Child of Zeus

    Regarding the “Exception Day” for dummy provider..

    One work-around .. I suppose .. is to Manually block off an appointment time in the back-end. Just label it as “Manually Blocked” and then it will be synced to the providers calendar and disallow that time slot from being available on the front-end for booking.

  • Tyler Postle
    • CGO

    Hey Jeff,

    Hope you’re doing well today! Just going over some past unresolved tickets, so sorry we didn’t get back to you sooner on this.

    Your work around is the easiest solution when it’s just occasional time specific exceptions. What a lot of members do is use the gcal integration, to just schedule their exceptions in. You can block off a set of time then it will import than into Appointments+ and block it off on your schedule.

    Of course, you can just block it off by manually making apps inside the plugin like you are now, but many find gcal to be a more convenient option :slight_smile:

    Hope that helps. Let us know if you have any further questions!

    All the best,

    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.