Appointments+ - Edit hours beyond standard

We have two more issue:

1. Even though we set the workers hours properly... on the frontend it only shows till 5PM. We need it to allow working timespan from 11:30AM to 10:30PM. How can we accomplish this?

2. We are having issues with the display name. Some of the Workers use only a single entity name. But when we add them as a user to Wordpress it forces us to use a first and last name and then the nickname uses both. And when trying to set the screen name it always duplicates the first name twice. Any help on this subject?

  • Michelle Shull

    Hey there, Jaques!

    For issue number one, it sounds like either your WordPress time settings or your server time setting is off.

    To check your WordPress time settings, go to Settings > General and make sure the time zone reflected there is in the same timezone as your appointments.

    To check your server settings, log in to your server control panel, find the server info settings, and make sure the time zone for your server also matches your WordPress and Appointments+ times.

    If this is too advanced, you can ask your host to change your server time settings for you, but changing WordPress time settings is very simple.

    2. You shouldn't be forced to add a first and last name to new users, those fields should be optional. Can you please allow support access so we can see these issues first hand? If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Thanks for your question!

  • Jacques

    I have granted access to the system.

    The timeframe issue is that we are attempting to use times beyond the normal 8/9 to 5. Instead we need to use 11:30AM to 10:30PM (reguardless of timezone) which is a 11 hour work day/span. Please see if you can check and make sure your response is relevant and/or what solution might we find for this.

    As far as the first and last name... when we attempt to add a new user, or edit an existing one, it keeps giving us an error saying it needs to generate a sceen/nick name and that we must fill in the last name. Please see what you can figure out.

    Thanks!

  • Jude

    Hi there @Jacques

    The timeframe issue is that we are attempting to use times beyond the normal 8/9 to 5. Instead we need to use 11:30AM to 10:30PM (reguardless of timezone) which is a 11 hour work day/span.

    If you've done what @Michelle advised you to do you should be able to set this up easily.

    Just make sure you select a specific provider before setting the working hours and in the front end choose the same service provider.

    See my screenshot with this working

    As far as the first and last name... when we attempt to add a new user, or edit an existing one, it keeps giving us an error saying it needs to generate a sceen/nick name and that we must fill in the last name. Please see what you can figure out.

    If this is something you setup, here are some tips on how to remove it.
    http://davidwalsh.name/add-profile-fields

    Also you may want to check if any plugin is causing this behaviour, try plugin conflict test as detailed here to see if that helps

    Cheers
    Jude

  • Jacques

    Yes it works only if we are using the "non-exceptions" method... but since we are not using except for just a few days span we have each field in "Working Hours - Work?" set to NO and only using "exceptions" to set the day span. So there must be a base (default) timespan. Please take a look at the service provider "Sandrine" on both the working hours and exceptions tab and you will see what I mean.

  • Jude

    Hi again @Jacques

    You see, when using the appointment scheduler for an exceptional day , the start time for that workday is used, but the end of the workday it uses is not the one specified! Instead, it uses the latest end time for a work day set to "Yes" in your schedule (in your case, none). The only way to get more times to show up properly, is to make the latest work time for a "Yes" day be 11:30 PM.

    Alternatively just copy this code into your functions.php file, in your child theme or a site specific plugin if you use one.

    add_filter('app_schedule_ending_hour','app_extend_end_time');
    function app_extend_end_time($end){
    	return 22;
    }

    Hope that helps

    Cheers
    Jude

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.