Appointments + Gcal 2 way sync

I’m having an issue with the 2way Gcal sync. Appointments feed into Gcal just fine, but appointments created in Gcal aren’t feeding into appointments+ unless I manually click the Gcal import in the settings area

I’ve tried running wp-cron outside of WordPress with cPanel too, I get the same results.

  • Adam Czajczyk
    • Support Gorilla

    Hello Foot Solutions

    I hope you’re well today!

    I checked the site and it seems there are HTTP errors occurring whenever plugin tries to fetch events from Google: 500, 502 and 503 statuses.

    While they are not exactly the same they are all related usually to resource usage. This could indicate connection issue with Google Calendar endpoint but since the sync to it is working fine and manual sync from it is also working – that means that the API connection itself is fine. Such errors (500, 502, 503) often happen upon ajax calls internally within site and that suggests that when there’s import attempt, there’s not enough resources.

    I assume that the server is a VPS and e.g. memory limits seem really high and in fact WordPress shouldn’t even need such an amount of memory (assuming that the 8GB is a “real” limit, actually available to PHP) but there must be something more into it as I noticed even simply browsing the backend that the backend is not as fast as I would expect it on such server and there are temporary slow down. The SG OPtimizer configuration page doesn’t even load at all – just a blank screen.

    That all suggests that the site is in some way “overloaded” but I doubt any attempt to increase server resources even more would solve that. What I’d suggest starting with would be:

    1. I noticed that you’re using SG Optimizer and WP Rocket; In my opinion this is partially redundant and can cause issues; I’d recommend either quitting on WP Rocket or on SG Optimizer and also making clearing all caches after the change;

    2. There’s over 50 plugins installed of which some are clearly not a “daily use” plugins – some migration tools and similar – and it’s best to keep them disabled most of the time until they are really necessary (so in a way: “enable, use, disable”:wink:; that should lower the server load slightly

    3. Site’s running on PHP 5.6x and while that’s fine upgrading to 7.x should speed it up and lower resource usage even more; is that possible? If yes, give it a go please.

    4. Then try to re-set GCal integration in Appointments+ afterwards; also – I noticed that service providers are allowed to add their own calendars so is it that this option is enabled but not used or is it actually used? Could you check (after all the above) if it does import with this option temporarily disabled (please note: import is not immediate, it might take some time – I’d wait up to an hour)?

    If that doesn’t solve the issue we’ll dig deeper to find underlying causes.

    Kind regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.