Appointments+ GOOGLE API for different service providers

Hi There,

I have set up gcal synchronization with no issues on my account. Now, I am hoping to set up gcal synchronization for another service provider and I just want to check on the procedure for this before I proceed.

I believe that I simply login to the service provider's account on our WP site, select "Allow Service Providers for Google Calendar API Integration" to yes, and then complete the instructions again for her gmail account? I just wanted to check before I inadvertently replaced my API info for my account or some such mistake :slight_smile:

Cheers!

  • Shane

    HI Tom,

    Ruh Rho, I think I'm having some issues with the set-up.

    I went ahead and completed the gcal synchronization for our other service provider on her WP login. The link-up went fine-event created in her calendar as expected.The event is also created in my calendar because the test event doesn't specify a provider.

    But if I try to book an event for either myself or the other service provider the event does not appear in either calendar. The 'client' (myself in these test cases) does not receive a confirmation email either. The appointment does register with Appointments + on WP.

    Everything was working as expected before I tried adding the calendar information for another practitioner.

    It may be relevant that the set-up info (key file etc.) has stayed the same after logging out of the other service provider's WP account and back into mine.

    Can you think of any causes for these issues?

    Thank You!

  • pxwm

    Hi @Shane

    Could you please confirm if you have two service providers?
    If you do then do you want them to have their own google calendar?

    If you do then I would suggest you set the following:-

    In A+ 'Goolge Calendar' tab set:-
    'Allow Service Providers for Google Calendar API Integration' field to 'Yes'
    'Appointments will be sent to Google Calendar for' field to 'All'
    'Integration Mode' field to 'Integration disabled'
    Then if you want take a copy of all the field below this and save a local copy of the data and then delete the data from all the fields
    Then save the settings

    Then log-in to the 1st service provider Wordpress profile
    Then select 'Profile' in the left hand menu and scroll down to the GCAL fields and:-
    set 'Integration Mode' field to A+<-> GCal (Synchronisation) if you want A+ and google calendar to synch in both directions
    Then enter all the GCAL info 'Key file name', 'Service account email address', 'Calendar to be used'
    Then enter the information you want sending to the google calendar in the 'Event summary (name)' and 'Event description' fields

    Then save the settings and click the 'test connection' and confirm you receive a success message at the top of the page.

    Then logout of the Wordpress user profile and repeat for the 2nd service provider ensuring the api key is unique to each service provider

    Then once completed make some test appointments to confirm if this works.

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.