Appointments+ Google API issues

Hello,

The Google API instructions are very detailed and very good.
But they need a little help.

I'm enjoying issues setting up the Google API option for Appointments+.

The first issue is that the Google APIs interface has changed and the WPMUDEV instructions do not match the new UI.

Luckily, for now there is an option to return to the old style UI. How long that option will be there I do not know. But trying to use the new UI to find the things I needed to do in the instructions was 100% impossible. Please update the instructions to match the new UI.

Next when I got to steps 18 and 19 Google prevents this required setting:

18. Set "Permission Settings" of this person as "make changes to events".

19.Click "Add Person".

After clicking Add Person Google adds the email address but changes the Permission Setting to be:

"See only free/busy (hide details)."

And this cannot be edited or changed. I tried deleting the new user/email and adding it again but it still defaults to this permission.

With no option but to move forward with that setting (limitation?). I moved on with the instructions and created the calendar (step 20).

Step 24 could be more clear.

24. Select the desired Integration mode: A+->GCal or A+<->GCal.

This is followed by Step 23 which is done on the Google side, but step 24 also seems like it should be done on the Google side. It took some page searching to discover that "Integration" is not on the Google site but is instead on the Appointments+ Settings page. A more clear instruction for step 24 would be like this:

24. In Appointments+ Settings, select the desired Integration mode: A+->GCal or A+<->GCal.

I'm often guilty of instructions like this because I'm too close to the work and understand where I'm supposed to do something. It's always better to look at it from the user POV who knows nothing and has to be guided explicitly.

Steps 26 and 27:

26. After these stages, you have set up Google Calendar API. To test the connection, click the "Test Connection" link which should be visible after you clicked save settings button.

27. If you get a success message, you should see a test event inserted to the Google Calendar and you are ready to go. If you get an error message, double check your settings.

I saved the settings and then clicked the Test Connection link.

The page refreshed with no error or success messages. I'm left to guess if it's working or not. I assume from no error messages that it's working. But because no event appeared in the calendar (as the instructions stated it would)--I don't know.

And the instructions don't state WHERE/WHEN the appointment will be set. I'm guessing that the test appointment would be set right now. But who knows? It doesn't appear in the calendar.

I haven't gone further ahead in the Appointments+ tabs to set the Working Hours or Exceptions. So maybe because I'm doing this late in the day the appointment was blocked. Or maybe because the Permissions settings failed (above) it doesn't work. Again, who knows. There were no messages on the page when it refreshed after clicking the Test Connection link (multiple times).

Thank you for your time, help and consideration.

Warmest,

Chris

  • Ash

    Hello @Chris

    I hope you are well today and thanks for asking the question.

    Thank you so much for your feedback on the instructions, I will pass it to the dev team.

    About the gcal, is it your primary calendar? You must not use primary calendar as your appointment calendar.

    About the test connection, the test appointment will be booked in your gcal within 10 to 30 mins time from the time you clicked on it. But note that, you also need to match the time zone. The time zone from Settings > General of your wordpress admin should be same as the calendar time zone.

    If everything is okay so far, would you please make sure that curl is working perfectly fine in your site?

    Would you please let me know about these?

    Cheers
    Ash

  • anotheropus

    Hey Ash,

    Thanks for the help--I've been using TimeTrade in the mean time because it works out of the box.

    I created a unique Google Calendar for the plugin, per the instructions--it's not using my main calendar, and no other application is using this unique calendar.

    I've never been able to get an appointment to come across to the calendar.

    The site is hosted on WP Engine, which has CURL enabled and not restricted.

    Let me return to my original ticket and point to this issue (which seems essential to this plugin working with Google Calendars. The italics highlight what I believe may be the central problem to this plugin not working):

    Next when I got to [WPMUDEV instruction] steps 18 and 19 Google prevents this required setting:

    18. Set "Permission Settings" of this person as "make changes to events".

    19. Click "Add Person".

    After clicking Add Person Google adds the email address but changes the Permission Setting to be:

    "See only free/busy (hide details)."

    And this cannot be edited or changed. I tried deleting the new user/email and adding it again but it still defaults to this permission.

    With no option but to move forward with that setting (limitation?). I moved on with the instructions and created the calendar (step 20).

    Thank you for the help. I really dream to get this plugin working so I don't need to pay TimeTrade $ 49 a month.

    But clients setting their own appointments is essential to my business. So I'm nervous about the initial failure even after doing a long, careful setup explicitly attempting to follow the instructions. And I'm nervous moving forward because if this guaranteed to work plugin fails now, it will fail as soon as the Google Gods change anything in their APIs (I just had a very big problem on a YouTube heavy client site with Google's April 30/May 1 overnight change away from YouTube API 2.0 to API 3.0). Now that I've experienced that I don't need my business to falter because people cannot make appointments.

    Thank you for the help.

    Chris

  • Ash

    Hello @anotheropus

    I hope you are well today.

    Would you please send me admin login details and FTP details? Also, let me know which subsite I should test with. I will try with my google calendar in your site.

    To send me details, please use our contact form: https://premium.wpmudev.org/contact/

    Select: I have a different question
    Subject: Attn-Ash (this ensures that it will be assigned to me)
    Details:
    1. Send all requested details
    2. Send a link of this thread so that I can track
    3. Send any other relevant link

    I will be happy to take a look :slight_smile:

    Cheers
    Ash

  • anotheropus

    I'm a knucklehead--I can't find the Google API instructions!
    I looked at the plugin page on the Detail tab and the Usage tab--no links there.

    I'm logged in as an admin on the site, and I've looked at all the tabs (including the Settings tab), and I can't find any link to Google API instructions, which I referenced when I set up the plugin in the first place.

    Please help me find the link to the instructions for setting up the Google API.

    Also, I just tested setting an appointment and it opened Google Calendar for the user to set their appointment but it didn't add the appointment to the calendar that's set up on the API.

    Anyway, I'm at a dead stop here until I someone can tell me where to find the Google API instructions so I can redo this plugin setup.

    Thank you,

    Chris

  • anotheropus

    Thank you Ash.

    Your video helped me do the correct steps, step by step. All the steps in the video worked and saved but the new app and the new calendar don't work together.

    I've created two new appointments and they do not appear in the NEW calendar I created.

    And your Appointments+ Settings page has WAY more content, instructions and links than mine does. My page only has a few paragraphs and the fields to use to paste the code snippets in. I don't know how to get a settings page like yours with all the links.

    And when I click the Test Connection link on the bottom of the Appointments+ Settings page I get this message at the top after it refreshes:

    [Appointments+] Key file does not exist

    I think because I already set up a calendar the instructions no longer appear on the settings page. This makes it double difficult as there are no instructions and links available in the Usage and Details, and no none available on the Settings Page. It would be useful to publish the original Settings page instructions somewhere on WPMUDEV.com for reference.

    Is there a link I can follow to see the original instructions as you see them (without deleting the plugin entirely)? If I can see the full instruction set and links I might be able to resolve the [Appointments+] Key file does not exist problem.

    Thank you,

    Chris

  • Ash

    Hello @anotheropus

    I hope you are well today.

    I think you didn't upload the new key file, that I skipped in the video file (it would take much more time to render :slight_frown: )

    To see full instruction, you need to click on "i" icon in Instruction label, please check the screenshot. And make sure you upload the new key file in key folder as stated in the instruction.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • anotheropus

    Update: I don't see instructions but I remembered something about putting the .p12 file on the server. I went through the Appointments plugin folders and found the Key folder with my previous key and your test key. I added the new .p12 key file in there.

    But I don't know what to do with the other file, the .json file.

    And when I click the Test Connection key now there is no message on the Settings page when it refreshes, and no appointment is made in the new calendar (as it says it will be).

    Also I clicked the " Import and Update Events from GCal Now" button (Clicking this link will manually import and update your Events from the selected calendar without waiting for 10 minutes. )

    But when I refresh the calendar nothing is there, not the three appointments I made and not the test appointments said to be created by the Test Connection link.

    Again, I think not having the complete instruction set and all the links is causing me to not be able to set this up completely. If the Appointments+ Settings page would always have the instructions (even after creating a calendar), then users could set it up much more easily.

    Thank you for your help with the remaining steps to get this calendar working.
    My Time Trade free trial ended yesterday! I WANT to use the Appointments+ calendar.

    Chris

  • anotheropus

    Thank you Ash!

    Now I see the full instruction set.

    However I'm unable to get Appointments+ working.

    I followed your video (which was GREAT).

    I uploaded the key file to the key folder via SFTP.

    And it will not do test connection appointments nor will it do appointments from the front end.

    Can I ask if you can set it up for me? I'd gladly pay you to get this working.

    Thank you,

    Chris

  • Ash

    Hello @anotheropus

    I hope you are well today.

    I'd gladly pay you to get this working.

    I am afraid, we don't do any paid job :slight_smile: Also, you can post a job in our job board where you can hire a developer to assist further: https://premium.wpmudev.org/wpmu-jobs/ Please note that, no WPMU official staff is available in the job board.

    But I can help you. And for that, I will need you gmail access too. And I think gmail protects the login from different location if you have extra security enabled. In that case, you have to disable all the security like 2FA security. It might also ask me security question, so it's pretty difficult.

    I will suggest if you can find someone from your location to help you. But if you want me to try, I can give it a go :slight_smile:

    Cheers
    Ash

  • Ash

    Hello Chris

    Sure, please send me everything in detail :slight_smile:

    To send me details, please use our contact form: https://premium.wpmudev.org/contact/

    Select: I have a different question
    Subject: Attn-Ash (this ensures that it will be assigned to me)
    Details:
    1. Send all requested details
    2. Send a link of this thread so that I can track
    3. Send any other relevant link

    I will be happy to take a look :slight_smile:

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.