Appointments+ Google Calendar API

I am having trouble making the google calendar integration work for appointments+.
It looks like the explainer video is a little out of date, and most of what he talks about is not visible in my dashboard. I have set my client up with GSuite, and am wanting to make it so that when somebody books an appointment on his website it is automatically added to his GSuite calendar. Any help would be appreciated.'

  • Denitsa

    Hello Justin,
    I hope you are having an awesome day!

    Let's get through the setup steps from the beginning together then :slight_smile:
    First, go to Appointments -> Settings -> Google Calendar. There are some instructions you can find in a slider here under Google Calendar API: Create a new Google Application

    We'll pretty much repeat those, so feel free to ask if you stumble across some kind of difficulty.

    1) Go to and click Create project.

    2) In the popup, write your project's name and click Create.

    3) Then you'll be sent to the Dashboard API management screen for your newly created project. Find the Calendar API and click on it.

    4) In the next screen, choose Enable.

    5) Then go to Credentials from the left-hand menu and choose the tab that says OAuth consent Screen, write a product name there and hit Save.

    6) Now, you need to hit Create Credentials and choose OAuth Client ID from the dropdown.

    7) Select Other as an Application type and type any name.

    8) There will be a popup with your client ID and client secret

    9) Paste them in the respective fields under Appointments -> Settings -> Google Calendar

    10) You'll be sent to a screen with a link to Generate your access code. Click that, allow the application, then paste the access code you're given in the requested field under Appointments -> Settings -> Google Calendar

    You'd then be able to select a calendar, API mode and other settings.

    Does this help? If you have any other issues, please let me know and I'll be happy to help.

    Kind regards,

  • Justin

    So, I don't see any options to paste in the client ID and the client secret, only the option to generate the access code. When I click on that link, I get a 400 error:

    Error: redirect_uri_mismatch

    The redirect URI in the request, urn:ietf:wg:oauth:2.0:oob, can only be used by a Client ID for native application. It is not allowed for the WEB client type. You can create a Client ID for native application at

    Learn more

    Request Details
    That’s all we know.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.