Appointments+ :: how do i make 60 minute service with 60 minute time base?

i have "employee A" who can only work from 8:30am to 9:30am on Monday - she provides a one hour service.

a) i set TIME BASE to 30 minutes.
b) i set DURATION to 60 minutes.
c) i set her WORKING HOURS to 8:30am to 9:30am on Monday

when i do this the reservations are shaded and not available

when i set DURATION to 30 minutes everything shows up fine and you can book the appointment at 8:30 BUT you can also book a session at 9:00 - i don't want this.

here's what i want:

when a user clicks on a date i would like the TIMES AVAILABLE table to show half-hour increments (since the time slot starts on the half hour) ... but when a user books the 8:30 slot they reserve the entire hour

and i need the confirmation to display 60 minutes and not 30.

is this possible?


  • pxwm
    • WP Core Meltdown

    Hi @aristath - Hope you don't mind me chiming in

    Hi @Paul

    Assuming you are using v1.3 then the Time base rules have been changed and the Time Base is now controlled by the duration of the Service so I suspect this is why you can't view a 60min Service on the half hour.

    e.g. If you have a Service set at 60mins then the Start time will be set on the hour.

    Good News though - A 'switch' is going to be added to the next release which will allow you to set the Time Base rules as you require which was the case with v1.2.8 and also retain the Time Base rules as per v1.3.

    If you are okay using a BETA version then the developer, Vladislav has attached v1.3.1-BETA-3 which would allow you to switch back to the v1.2.8 Time Base rules. However please be aware you have to add some bespoke code to the wp-config.php to perform the 'switch' and both can be found in the following post:-

    However please be aware if you upload the beta version so you can set the Time Base to 30mins and the retain the Service Duration at 60mins then users will be able to book on the hour and half hour.

    To resolve this select A+ Settings 'Working Hours' tab and set the Service Providers working hours to 08h30 to 09h30 and this should only shown the option to book the 08h30 slot and when clicked in the schedule the form should show the Service with a 60min duration.

    As always i recommend before upgrading a plugin and making bespoke code changes you take a backup of your site and database so you have an option to rollback.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.