Appointments in the calendar is not removed after deletion

Hello!

1:

The application does not properly move deleted sessions after syncronization, if done from calendar. Cancellation in the app either by admin or user, works fine and syncs properly with the calendars aswell. However, removal of a session directly from the calendar, causes the session to be moved to the “COMPLETED” folder. It should be moved to the “REMOVED” folder. When the session stays in “completed”, it still causes the availability overview to stay RED and BUSY. It’s not a synchronization issue, as it syncs fine. The issue is that after removed session directly from calendar online, the apps moves the session mistakenly to COMPLETED folder rather than removed.

2:

There’s no option to demand minimum cancellation time. I’d like my clients to only cancel prior to 24 hour. I am sure many have this same policy. Can this be sorted out?

3:

There’s an issue with text sizing on phones and even small PC screens. Review the pictures attached. It seems like this is not responsive.

  • Jude

    Hi there Anders

    Hope all is well with you !

    1)

    The application does not properly move deleted sessions after syncronization, if done from calendar. Cancellation in the app either by admin or user, works fine and syncs properly with the calendars aswell. However, removal of a session directly from the calendar, causes the session to be moved to the “COMPLETED” folder. It should be moved to the “REMOVED” folder. When the session stays in “completed”, it still causes the availability overview to stay RED and BUSY. It’s not a synchronization issue, as it syncs fine. The issue is that after removed session directly from calendar online, the apps moves the session mistakenly to COMPLETED folder rather than removed.

    How exactly are you removing the appointment from the calendar ? The issue here could be if you simply delete then there is no way for Appointments + to know if you are cancelling the appointment or completing it. That said let me check with the developers to see if there is a way of doing this based on timestamps

    2)

    There’s no option to demand minimum cancellation time. I’d like my clients to only cancel prior to 24 hour. I am sure many have this same policy. Can this be sorted out?

    This is not currently possible out of the box because of the way the plugin is built. That said I am marking a feature request on this and we can consider it depending on how many other members request something similar.

    Alternately you can try our Jobs Board where you can have it custom developed by professional developers

    https://premium.wpmudev.org/wordpress-development/

    3

    There’s an issue with text sizing on phones and even small PC screens. Review the pictures attached. It seems like this is not responsive.

    The plugin uses the theme's table CSS for the responsiveness bit. That said I can help make it responsive if you share a link with me in case the theme does not do this well

    Cheers
    Jude

  • Anders

    «How exactly are you removing the appointment from the calendar ? The issue here could be if you simply delete then there is no way for Appointments + to know if you are cancelling the appointment or completing it. That said let me check with the developers to see if there is a way of doing this based on timestamps»

    Normal deletion of entry.
    Appointments+ should know easily in this way: A completed entry is not deleted; the date simply passes onto a new day. DELETED entries should this synchronize as non existent = Removal. I don’t remove completed entries, I just let them stay there in the past. I doubt also that others delete former entries. I use old entries to keep track on what I did. Point being, completion is not an issue.

    When synchronization occurs, and app notices that the former entry is not there any more, that should indicate that it’s removed for the purpose of cease exist.

    “This is not currently possible out of the box because of the way the plugin is built. That said I am marking a feature request on this and we can consider it depending on how many other members request something similar.
    Alternately you can try our Jobs Board where you can have it custom developed by professional developers
    https://premium.wpmudev.org/wordpress-development/”

    Thanks!

    “The plugin uses the theme's table CSS for the responsiveness bit. That said I can help make it responsive if you share a link with me in case the theme does not do this well”

    Thanks. We got around it by just changing from full day-names to half. The link is here though:

    http://treningogrehab.no/nettbutikk/#booking

  • Anders

    Another bug is that the syncronization doesn’t update a removed session from the calendar as it should.
    If a client cancels a session within the application, it will NOT synchronize the calendar (remove it from the calendar). It does however free up the space from the application schedule overview.

    In such case it’s possible to double book the calendar, causing unnecessary confusion of to which entry is the valid one.

    However if I manually enter the application settings, go to the “removed” folder, and permanently delete the cancelled appointment, THEN it syncs the calendar and removes the entry also from the calendar.

    So here’s the deal:
    1. If I delete a cancellation manually from the calendar, it won’t update the plugin (it moves it incorrectly to “completed” folder.
    2. If the client cancels the appointment within the application on the webpage, it does NOT synchronize the calendar until I manually delete the entry permanently from the “removed” folder.
    3. The only way to get rid of the unwanted entry properly, is to MANUALLY put the entry 1) into “removed” 2) permanently delete from “removed”

    Hopefully these issues will be resolved so that deletion from the calendar AND when clients cancel within the plugin will properly remove the entries without any further hassle (extra time demanding work)

  • Luís

    Hi Anders ,

    Hope you're doing well today!

    Firstly, sorry for the late reply and all the problems it may have caused.

    I was able to replicate the issues, so, I've confirmed these bugs and flagged the developer so they can get they fixed up asap.

    Either myself or the developer will reply back here once we have pushed a fix out. If you have any further questions in the meantime just let us know.

    Cheers, Luís

  • Panos

    Hi Anders ,

    Sincere apologies for the delay!

    Could you please place the following snippet on your functions.php or a mu-plugin:

    add_action( 'app_removed', 'wpmudev_app_remove_from_gcal', 20, 1 );
    
    function wpmudev_app_remove_from_gcal( $app_id ){
    
    	$app = appointments_get_appointment( $app_id );
    	if ( ! $app ) {
    		return false;
    	}
    
    	$Appointments_Google_Calendar = new Appointments_Google_Calendar;
    	$Appointments_Google_Calendar->api_manager->delete_event( $app->gcal_ID );
    
    }

    Now when setting appointment's status to removed it should be also removed from gcal!

    Please let us know how this works for you!

    Kind regards!
    Panos

  • Anders

    Thanks.

    I tried it and it did not work as planned. First of all, the entry I made (directly into google calendar) - which synchronized fine before - was now synced into the plugin as "unavailable" rather than "busy", leaving the field gray instead of red.

    Second, when I deleted the entry, it did not remove; the entry stayed gray. The block should resume a green / available color.

    Additionally it caused other entries to go gray/unavailable (priorly red/busy).

    When an entry is made into Google calendar, it needs to sync as "busy" and not "unavailable". Secondly, it should resume to a free / available state once it's removed directly from google calendar and sync as that.

  • Panos

    Hi Anders ,

    The snipped I provided above is to update GCal when setting an Appointment's status to "removed" within A+ (from the plugin).

    This should not have any other affect so can you please remove the snippet and try again to see if you can still replicate the issue :

    I tried it and it did not work as planned. First of all, the entry I made (directly into google calendar) - which synchronized fine before - was now synced into the plugin as "unavailable" rather than "busy", leaving the field gray instead of red.

    As for removing a GCal Event directly from GCal, it should be set to "Removed" instead of "Completed" in A+. I confirm that it is changed to "Completed" though. I have attached file:
    wp-content/plugins/appointments/includes/class-app-gcal.php

    which should be fixing this issue.

    The sync is made each 10 minutes. Here I would like to point out that by clicking on the "Import and Update Events from GCal" button (at Appointments > Google Calendar tab) it will remove only appointments the were created by GCal ("Reserved by GCal":wink:.

    I have modified another file:
    wp-content/plugins/appointments/includes/gcal/views/settings-gcal-step-3.php

    which adds a new button at the Google Calendar tab:

    Clicking this button will force a sync with GCal, and you can check what happens when removing an Event from GCal instantly without having to wait the cron job to sync.

    Please let me know how these work for you :slight_smile:

    Thanks!
    Panos

  • Anders

    There is a problem with showing availability between different services.

    I have three services.

    • Treatment
    • Web coaching
    • Teaching
    When I press the "show availability" button for these different services, they do not show the same schedule. Hours that are busy, show up as green, etc.

    The same goes for double sessions. I tried to include double session (120 instead of 60 minutes), but they did not show proper availability, and allowed clients to book into hours that were already taken.

    So; there's an issue with both scheduling different services that have the same length, and scheduling double sessions of the same service. It seems that they are not reading the calendar properly.

  • Luís

    Hi Anders ,

    Hope you're doing well today!

    If in the "Working Hours" section (Appointments -> Settings -> Working Hours) we set some days to "No", they are displaying as "Busy" in the front-end instead of "Not possible".

    So, I've confirmed this bug and flagged the developer so they can get it fixed up asap. Either myself or the developer will reply back here once we have pushed a fix out.

    As this issue is different from the original one, in the future I will suggest you to create a separate topic, it will avoid confusion and will help us to better track the issue.

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.