Appointments+ is not sending me confirmation emails.

I just lost 2 bookings because the plugin is not sending me notifications half the time.

They were going to my spam folder originally, and I created a filter to prevent them from going to spam, but now I'm not getting them at all. I just had someone test to see, and I got a confirmation email the first time, and the 2nd time I got nothing. The appointment is there in appointments but I can't check that every 5 minutes to see if we have a booking. I need to get these notifications. I am about to get slammed with bookings, and this needs to work.

Any help is greatly appreciated.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi JOSEPH!

    I think you may be experiencing a bit of a glitch with the native PHP mail WordPress uses by default. It's not super-reliable, especially in critical cases like yours.

    I normally recommend an SMTP solution for users who are depending on emails getting through. The benefits are two-fold; 1) it takes the load of sending email off your WP server and 2) It works even if your site is down.

    There are two primary plugins I recommend to enable SMTP, you can choose whichever one appeals to you the most.

    https://wordpress.org/plugins/wp-mail-smtp/
    https://wordpress.org/plugins/easy-wp-smtp/

    Both are free, and either one will ensure that all your confirmation emails get to you in a timely fashion.

    Thanks, JOSEPH!

  • JOSEPH
    • New Recruit

    I tried using the first solution, I input the settings they have listed for GMAIL under their FAQ...

    smtp.gmail.com
    port 465
    SSL on
    and input my gmail account info..

    I tried to send a test email, and got this error back.

    The SMTP debugging output is shown below:
    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)

  • Ivan
    • HummingBird

    Hey Joseph,

    Thanks for your patience.

    This is a bit shot in the dark, but if you are using CPanel for your hosting, can you please try the fallowing.

    1. First of all, login to your CPanel of your account. Click the MX Entry icon under the Mail groupbox.
    2. You will be redirected to DNS Zone Editor, find the MX (Mail Exchanger) section.
    3. Click the more >> link.
    4. Select Remote Mail Exchanger, by default this is set to Automatic Detect Configuration.

    Now it might look a little bit different at your end, but you should look for the MX records.

    I would suggest talking to your hosting company, as this is more likely their server blocking ports, or the php configuration has some limitations to help them stop abusive spam.

    Let me know if this helps you.

    Thanks,
    Ivan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.