[Appointments+] Issues with Litespeed Cache

Hi,

My host is using litespeed cache and I'm having issues with Appointments+. Specifically when I try to book an appointment but then if I want to remove the item from the cart before completing it does work in the back end but it stays in my cart. I've tried to add the url "..store/cart" to not cache but it's still not working

Any help much appreciated

  • Patrick Freitas
    • Staff

    Hi Kieran

    I'm sorry to hear that you are having this problem.

    I can see that you are using an old plugin version, wouldn't you mind please, update all WPMU DEV plugins?

    If the problem persists, please, grant the support access, and I can take a closer look for you.

    1- Log in to the WordPress Admin Panel for your site (go to the Network Admin dashboard if on Multisite), and then navigate to the “Support” page from the WPMU DEV menu item (WPMU DEV > Support).

    2- Click the “Grant Support Access” button in the Support Access panel.

    You can follow the steps on https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Let me know when you grant the support access.
    Best Regards,
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi Kieran

    Wouldn't you mind please send me some credentials information and I can take a closer look at the problem.

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Patrick Freitas"

    - Site login URL:

    - WordPress admin username:
    - WordPress admin password:

    - FTP/SFTP credentials

    Host:
    Username:
    Password:
    Port:

    - cPanel credentials

    Host:
    Username:
    Password:
    Port:

    - Folder path to the site in question:

    - Link back to this thread for reference

    - Any other relevant URLs/info:

    Please, reply to the ticket once you have sent the information.
    Best Regards
    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi Kieran

    Thank you for the information.

    I tested on my end and wasn't able to reproduce, I activated the Litespeed on your site and tested too, I could remove the Appointment from the cart, could you try a clean the browser cache and check again? Or try to use the incognito mode.

    Is there any specific browser that you are testing?

    Does wpmudev support litespeed cache plugin?

    I checked there is no report about any conflict with Litespeed, and our plugins are ultra compatible.

    However, if the problem persists after cleaning the cache, I suggest you run a plugin - theme test.

    So, would you mind please run a conflict test?

    Remember, is essential that you run this test in a staging site, if you can’t do it you must create a full backup.

    Please deactivate all plug-ins keep the reported plugins (MarketPress, Litespeed, Appointment+), and check if the problem is gone. If so, then enable all plugins one by one and find which one is creating the issue.

    If you still having this issue, could you do a theme test, much the same as the plugin test, but now you’re testing themes!
    Activate one of the default WordPress themes, like Twenty Sixteen or Twenty Seventeen.

    Here you will find more information on https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Let me know the result.
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.