Appointments + keeps breaking after a day or so of use. I've reinstalled it a few times but eac

Fatal error: Maximum execution time of 30 seconds exceeded in /home/content/16/5607816/html/ls/wp-content/plugins/appointments/appointments.php on line 3900

  • Jack Kitterhing
    • Code Norris

    Hi there @Little Sprouts Academy

    I hope you are well today and sorry to see of the problems your having.

    Could you add this set_time_limit(60); in your wp-config.php above the line reading "that's all stop editing happy blogging" could I also have a link to your appointments page please?

    Thank you!

    Kind Regards
    Jack.

  • pxwm
    • WP Core Meltdown

    Hi @Jack Kitterhing

    Just to let you know that I'm helping out a fellow member based on an earlier post and stepping through a few setup problems.

    I've fixed all of them and I am left with the same issue.

    I've proved the google calendar settings are correct and clicking the 'test connection' in the 'Google Calendar' reports a success message so I know all of this is working.

    When I make an appointment in the front end of A+ it is recorded correctly within A+ and the google calendar.

    However if I click Import or wait 15 mins until A+ and google calendar syncs it doesn't match up the appointment and creates an appointment in the 'Reserved by GCAL' appointment tab. It then duplicates this every 15 mins so the 'Reserved by GCAL' keeps filling up with these 'false' appointments.

    I can confirm A+ is the latest version and the site is already on the default theme so my next step is to take a full backup including a database backup and then start deactivating the plugins.

    If I find the problem I'll post here as well as the original post.

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi,

    Out of interest do you have a plug-in called 'BackWPup' installed and active?

    If you do you may wish to deactivate and see if this resolves your problem of duplicate appointments being imported from your google calendar to the 'Reserved by GCAL' appointment tab.

    PLEASE NOTE: It is always advisable to take a 'home' and 'database' backup before deactivating any plug-ins

    If it doesn't do you need the GCAL to be synced both ways?
    If not you could try changing the settings so it only exports the appointment to your google calendar.

    Could you please let me know the results

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Jack Kitterhing

    I've not had any input since my last post.

    However I'm still helping out another fellow member who seems to have the same problem and I will update their post with the following update.

    I've resolved all their problems except the issue with GCAL not synchronising in both directions.

    I've proved it isn't their google calendar settings and I've deactivated all their plug-ins and reverted to the default theme.

    At the moment the GCAL settings are set so it only synchs from A+ to their google calendar and this works fine.

    I suspect their problem relates to either their server or the build of their website.
    I would suggest there are only two options left and that is: Host on a known good server that works with A+ and the GCAL settings so this will prove their server and if this still fails then the only option would be to rebuild their website on a clean Wordpress installation (last resort)

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.