Appointments+ / LOCATION tab not doing anything version 1.9.4

Hi,

On the Locations Tab, if I click on 'Edit Location' or 'Settings', nothing happens. Is this perhaps a bug in the latest release?

  • Nastia
    • Support Rock Star

    Hello Asif , I trust you are doing well today!

    My apologies for the inconvenience

    Please replace in file /wp-content/plugins/appointments/includes/pro/includes/addons/app-locations-location_support.php on line 191 this

    include_once( appointments_plugin_dir() . 'includes/addons/lib/class-app-locations-list-table.php' );
    with this line

    include_once( appointments_plugin_dir() . 'includes/pro/includes/addons/lib/class-app-locations-list-table.php' );

    Please create a backup fo your site before making any changes.

    Deactivate add-on Locations and then activate it again. This should fix the issue.

    Let me know how it went!

    Cheers,
    Nastia

  • Asif
    • WPMU DEV Initiate

    Hi,

    Replaced the line as instructed above. Deactivated the locations plugin and activated it again. No change. Then I deactivated the Appointments+ plugin and reactivated it. Still no change.

    Any other ideas please?

  • Asif
    • WPMU DEV Initiate

    Hi,

    I changed the file and then the whole website has stopped working. I then replaced the file with the old one and now there are two identical options for Activating locations under options. Should I delete the plugin and install it again? (seems something may have gotten corrupted with all the changes)

  • Nastia
    • Support Rock Star

    Hello Asif ,

    My apologies for the delay in this thread. I'm sorry that you have this issue occurred. There might have been a conflict with a plugin if the file were replaced correctly. You can manually replace the whole Appointments plugin, via FTP, from wp-content/plugins folder.

    If you wish can do this for you and I'll fix the issue with the location add-on, for this I will need your credentials.

    You can send credentials by using our secure contact form http://premium.wpmudev.org/contact/

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Select “I have a different question” for your topic - this and the subject line to ensure that it gets assigned to me.

    I am waiting for your email!

    Cheers,
    Nastia

  • Asif
    • WPMU DEV Initiate

    Hi Nastia,

    For security reasons, the site does not have FTP access. I am happy to manually delete the plugin and replace it...if you would give me a link to the one I should use to replace it with. If at that stage it still doesn't work, I can give you a login to the WP site and you can may be have a look at it.

  • Sajid
    • DEV MAN’s Sidekick

    Hello Asif,
    Hope you are doing good today :slight_smile:

    I have applied the patch and tested it on my own test site and its working just fine for me (see screenshot).

    I am attaching the complete zip file of Appointments + plugin. Please delete the existing plugin, download the plugin, install and activate it on your website. Now check if this solves your problem.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.