Appointments+ mail to subject of appointment

When someone books a service in the calendar, the mails go only to the admin of the site, not to the one who actually is responsible for that service (service provider).

  • Kasia Swiderska
    • Support nomad

    Hello Michael,

    I’m extremely sorry for this delay on our side. Seems that during the chat session issue was replicated, but it was most probably a different reason why this is happening on your site.

    Our staff used to test our WPMU DEV Hosting where to send those emails SMTP needs to be configured from another server (our Hosting doesn’t provide email service).

    From what I see the site where you are having this issue is not hosted on our Hosting.

    In case of the site on our Hosting the issue was fixed by using an SMTP plugin. I don’t see that this was tried on your site. Can you check if configuring SMTP plugin will fix this? You can use our Ultimate Branding plugin it has an SMTP module.

    Let me know how it goes

    kind regards,


  • Michael
    • The Incredible Code Injector

    Hey Kasia Swiderska,

    thanks for the answer. I’ve looked into it but I’m not quite sure this would help me. The Appointments+ is from a subsite, one of my clients. If I put in my SMTP-credentials, things will work. But they don’t want to recieve mails from me.

    Anyway, in case I overlooked something, I will set it up as you said. But still, that means they are sending mails using my account, not theirs.

    Let’s see how it goes.

    I’ll keep you posted.

    kind regards

  • Michael
    • The Incredible Code Injector

    Ok, I have to wait now. I added my IP to my G-Suite GMail App SMTP relay service but I still get “Authentication failed” from the SMPT in Branda (Branda, really?) :wink:

    But in my experience, it may take a while before the new G-Suite settings are activated. I will check back tomorrow evening.

    As always: thanks and I’ll keep you… posted.

  • Michael
    • The Incredible Code Injector

    Hi everyone,

    Hope you are all doing fine.

    I’m still stuck with this issue. I have been configuring and trying for days, but I can’t get it to work. The error I receive, no matter what I do, is always the same: authentication failed.

    The current configuration:


    Sending mails from websites by IP

    Allowed senders: Only addresses in my domains

    Only accept mail from the specified IP addresses: Yes

    Allowed IP addresses: 24 Degrees HQ

    Require SMTP Authentication: No

    Require TLS encryption: Yes


    From Headers:

    Sender email address:

    From name replacement: Enable and set to my company name



    Encryption: TLS

    Port: 587

    Insecure SSL certificates: disable

    SMTP-Authentication: disable

    So, although SMTP-Authentication is turned off, it is weird that I Branda gives me the error: SMTP-Authentication failed.

    That doesn’t make sense to me :slight_frown:

    What else can I try? I ran out of ideas and that doesn’t happen a lot.


    Kind regards

  • Kasia Swiderska
    • Support nomad

    Hello Michael,

    Hm. Settings are looking fine in Branda.

    Can you enable debug mode in your WordPress and try connecting again? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    If you open wp-config.php and that define statement is not there, you can add it right before this line:

    /* That's all, stop editing! Happy blogging. */

    After that, you should have a debug.log file – upload it to Dropbox type of service and paste like here.

    kind regards,


  • Michael
    • The Incredible Code Injector

    Hi all, hope you are doing fine.

    I succeeded in logging everything and tried the steps above. It created a logfile but the only thing in it are the following lines:

    [19-Mar-2019 18:38:20 UTC] PHP Notice:  Undefined variable: ph in /home/twentyfour/domains/ on line 48
    [19-Mar-2019 18:38:20 UTC] PHP Notice: Undefined variable: ph in /home/twentyfour/domains/ on line 48
    [19-Mar-2019 18:38:20 UTC] PHP Notice: Undefined variable: ph in /home/twentyfour/domains/ on line 48
    [19-Mar-2019 18:38:20 UTC] PHP Notice: Undefined variable: ph in /home/twentyfour/domains/ on line 49

    Can those errors be the cause of the plugin not able to send mails?

  • Patrick Freitas
    • Staff

    HI Michael

    Hope you are doing well,

    The logs are only a notice, not an error, wouldn’t you mind please, try to configure the OAuth 2.0 protocol to authorise access to the Gmail API instead simple SMTP settings.

    You can try using this plugin

    The plugin will connect the WordPress, and Gmail SMTP to the API, which brings you more benefits

    You can follow all the steps at and

    Let us know the result you get.

    Best Regards,

    Patrick Freitas

  • Michael
    • The Incredible Code Injector

    Hi Patrick Freitas

    Thanks for your response. After (a lot of) investigation, it turns out that Google restricted SMTP-relay a bit more. So it is from uttermost importance that every DNS setting of your domain is actually set correct. In my case, I’m missing a DMARC setting. Although not really required, it can cause issues.

    In the scope of this issue, I will meet with Google tomorrow (online) to figure out with them what actually is going on. I will post our findings here.

    Furthermore: if the issue is not solved and the cause wouldn’t be a Google thing, I will follow your advice about (gmail-smtp) and report here also.

    Thanks and talk to you tomorrow.

    kind regards.

  • Michael
    • The Incredible Code Injector

    Hi all,

    thanks for all the support. After some adjustments, I didn’t get the Branda mail part regarding SMTP to work. I did however followed Patrick Freitas’ advice and that worked like a charm.

    Thanks Patrick, keep up the excellent work !

    kind regards and hope to see you in Berlin.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.