Appointments "No Preference" doesn't show Service Provider schedules

I've been playing with this for a while but I can't seem to get this to work. I have just 1 service and 2 service providers because there is this one day were I have 2 simultaneous slots for appointments available. I have the individual providers schedules working just fine but when the "No Preference" is selected for service provider it is either a different schedule that seems somewhat aligned with the other service providers or if I turn the "No Specific Provider" schedule off on all the days, it just shows no availability unless you click on a specific Service Provider. I've played with dummies and the php function code given in the FAQs to no avail.
Eventually, I want to just use "No Specific Provider" and hide the option to choose a certain provider so people sign up (since the provider is very relevant in this situation).
Help is much appreciated! I have turned on support access as well.

  • Kasia Swiderska

    Hello Beau,

    In working hours for No Specific Provider you have to set all the days your providers work. So if one provider works 2 days in week and second one works other 5 days - then you have to set 7 days as working.
    This was when calendar will be loaded it will show by default all available days and hours - and when you change to specific provider you will see what time does that one works.

    But days and hours in No Specific Provider have to cover all working days of your providers.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.