Appointments not configuring correctly

Hello - Please help!

I have a service that takes 180 minutes to perform. So I set my service to 180 minutes. That way, if someone books an appointment, 180 minutes of padding will be added so another person cannot make an appointment within those 180 minutes.

For some reason, this is blocking off 180 minutes on my available hours to select from on the calendar, regardless of whether an appointment has been scheduled?

I want all business hours to be available for selection (in 1 hour intervals) UNLESS someone sets an appointment. When someone sets an appointment, only then do I want 180 minutes blocked off on the calendar so another person cannot book within that 180 minute timeframe.

For example:: If someone sets an appointment at 8am, I want 8, 9, and 10am to be unavailable.

If someone HAS NOT booked an appointment yet, I want the hours 8, 9, and 10 to be available for selection on the calendar.

Currently, as mentioned above, it's blocked off the available times to select from as if appointments have been set, so nearly all of my hours are "unavailable" because my service time estimate is 180 minutes.

Can you tell me what I'm doing wrong or how to get this expected functionality to work?

I just purchased the Appointments + ... but I'm having such a difficult time getting it to function the way I need it to.

Thank you!

Barb

  • Patrick

    Hi there @Barb

    Welcome to WPMU DEV, glad to have you aboard!

    For some reason, this is blocking off 180 minutes on my available hours to select from on the calendar, regardless of whether an appointment has been scheduled?

    That's because, by default, the calendar will display time slots in increments based on the duration of the appointment the user selects in the dropdown.

    However, you can override that behavior by enabling the Durations addon under the Addons tab.

    You'll then see new options at the bottom of the Time Settings section under the General tab: Time slot calculus method.

    Be sure your Time Base is set to 60 minutes. Then select Minimum time based appointment duration calculus (legacy) in the 1st of those new options to get the calendar to display increments of 60 minutes.

    Now when a user books an appointment, the calendar will block off only the 3 hours for that appointment, and leave everything else available. if, however, another appointment is booked in the same day with less than 3 hours between the two, then that time will appear on the calendar as Not possible.

    See an example on my test site here:
    http://appointments.pcwriter.net/make-an-appointment/

    Go ahead and book a couple of appointments to see it in action, & don't worry about booking too many as it's a test bed after all. :slight_smile:

    I hope this helps! And thanks for being a member :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.