Appointments+ Not Sending Confirmation Emails

Hello Gents,

After much research and trouble shooting...i have to ask this question for some much needed help....

My Appointments+ plugin is not sending any confirmation emails. I have the correct settings in my plugins Admin panel, but still nothing happens. I do the following, but no emails are sent:
(1) Make an appointment
(2) Check the back-end and change the appointment from "pending" to "confirmed"
(3) wait...wait...wait...oh and wait some more, but no email arrives in my users email account, and the Admin doesn't get any notification either, neither does my Service Provider.

Any help you guys can assist with would be great....

Oh and as a small side-note, can you please check that my HTML script is correct. I have simple HTML code in my "CONFIRMATION EMAIL NOTIFICATION BOX" under "Settings>Notifications" but I just need to make sure that the box will accept basic HTML.

Open Access is Granted...so help-away!
Thanks guys.

-A. A.

  • Tyler Postle

    Hey Arturo,

    Hope you're doing well today. I did a test appointment and looks like the email sent, but it did go into my spam box.

    Can you check yours to see if it's there?

    As for why it went into spam, it could be because your using the default webhost mail - you see it's sent from hostgator's servers there which will be a lot less trusted by email clients since there is a ton of spam that comes from hostgator servers because they have so many users.

    The best option is to instead use an SMTP plugin to change the server that your mail comes from: https://en-ca.wordpress.org/plugins/easy-wp-smtp/

    As for the html, looks fine to me and I can see that it all came through in the email as well. If you want additional space then you can add multiple br tags.

    Hope this helps, if you still have any further questions just let us know.

    All the best,
    Tyler

  • Arturo

    Hey Tyler,

    Thanks for the fast response....and yes....WOW...it WASSS there...you know I never bothered to check because originally...about a few weeks ago, every test email I sent came to my inbox AND there were no issues with where it was being sent from.

    It's weird, but something must have changed, and I'm really not sure why it suddenly started showing [sent via "...hostgator.com"]. My test emails from the beginning (over a period of 3 months) just said [sent by "...@centrixlearning.com". So I'm not sure why it changed. :slight_frown:

    In any case, thanks! You fix worked. I'm using the Easy WP SMTP plugin and it all works smoothly now. Gracias!

    Best Regards,
    AA

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.