Appointments + Not Sending Email Confirmation to Admin

Hello,

Email notifications are not being sent to the admin to let them know an appointment has been made. Appointments are set to auto approve & setting for Email Notifications is set to Yes. Even manually generated email approvals will not work.

I have granted support access so you can view the settings and test this yourself.

Thanks!

  • Rupok
    • Support Ninja

    Hi LaunchGo

    Hope you had a wonderful day.

    I tried to regenerate the issue on my test site, but I’m getting emails whenever an appointment is confirmed on my site. But in your site, I could confirm the issue. Can you please confirm if this is happening only with Admin emails, or no emails are going form Appointments+ ? Or even no emails are going out at all? I’ve compared your site settings with mine side-by-side. All settings seem to be identical. So I don’t think any Appointments+ configuration did this.

    Can you provide your server log so we can check if we find any clue regarding this? Can you also ask your host if they can check about something blocking the mailing process? I’m looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!

    Rupok

  • LaunchGo
    • Site Builder, Child of Zeus

    Issue with SSL is fixed, but emails are not being sent for when appointment is made. When an appointment is canceled an automatic email is sent immediately just fine. Still having an issue with auto email notifications not going out for new appointments made.

  • Kasia Swiderska
    • Support nomad

    Hello LaunchGo,

    Looks like this is bug we recently discovered – it doesn’t happen on all sites that is why Rupok was not able to replicate this, but I did on my testing site.

    I will add your thread to bug report and will notify when there will be a patch or release with fix for this issue.

    kind regards,

    Kasia

  • LaunchGo
    • Site Builder, Child of Zeus

    Okay, so how do we fix this in the meantime? Any alternative solutions so provider is notified with a new appointment? Any other way to set up the Appointments + plugin so they get a notification?

    This is a pretty significant issue; provider needs to be aware of any newly added appointments.

  • Rupok
    • Support Ninja

    Hi LaunchGo

    Hope you had a wonderful day.

    I checked the issue. Kasia Swiderska has flagged our developer, a task is created and assigned to him and he is already working on this. I’ve also pinged our developer there for any possible patch or workaround. Though I can’t give you any ETA on this, but I believe, he will come up with a solution soon.

    Have a nice day. Cheers!

    Rupok

  • Nithin
    • Support Wizard

    Hi Matt,

    Hope yo are doing good today. :slight_smile:

    This should have been fixed with the latest version of Appointments + plugin, if you are still having issues, would recommend you to perform a plugin conflict test, and rule out whether any plugin is causing this issue.

    If that didn’t help, please check whether, switching to a SMTP plugin makes the plugin work.

    If you still have issues even after following all these, then it seems like the issue needs specific attention, would recommend you to create a new thread so that one of the support staffs can help get this resolved asap.

    I hope this helps. Have a nice weekend. :slight_smile:

    Kind Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.