Appointments+ not sending notification email to dummy user

Hello,

I am not receiving Appointment booking notifications when a client books an appointment in the front end.

I have a service provider Kyla set up who is set to be a dummy user. In the backend i've set the dummy service provider to be Diane in the Settings tab. Once an appointment is booked for Kyla in the front end a notification email is suppose to be sent to Diane correct?

I've set the "Send Notification to admin if confirmation is required" to "yes" but that does not seem to be sufficient enough to send the dummy user a notification that an appointment has been booked in the front end.

What am I doing wrong?

Thank you,

Tin

  • Sajid

    Hi Tin! Hope you are doing good today and thanks for your question :slight_smile:

    By default dummy users will not receive confirmation emails. A dummy service provider is a user whose emails are redirected to another user that is set on the General tab.

    If you set "Send Notification to admin if confirmation is required" to "yes" and still not getting emails then its due to email delivery problem (pretty common) and can be solved by installing WP Mail SMTP plugin.
    https://wordpress.org/plugins/wp-mail-smtp/

    Install and configure this plugin and let me know if its still not working :slight_smile:

    Cheers, Sajid

  • Hoang Ngo

    Hi @Tin,

    I hope you are well today.

    For doing this, we can enable the setting Allow service provider confirm own appointments to true, but if you don't want that, so we will need to modify the plugin code.
    In the line 4496 line /appointments/appointments.php, you will see a code like this
    if ( $r->worker && $admin_email != $this->get_worker_email( $r->worker ) && isset( $this->options['allow_worker_confirm'] ) && 'yes' == $this->options['allow_worker_confirm'] ) {
    Please update to
    if ( $r->worker && $admin_email != $this->get_worker_email( $r->worker ) ) {
    Lets see if it works for you :slight_smile:

    Best regards,
    Hoang

  • hoangker

    Hello @Hoang Ngo,

    thank you for your response. However, my business requirements changed. The client want the emails to goto their service providers as opposed to one dummy admin user. I turned off dummy users in the service providers tab and set "allow service provider confirm own appointments " to "yes". No emails to the service provider or the admin were sent even though "Send Notification to admin if confirmation is required" to "yes".

    I went and installed WP SMTP wordpress plugin and activated network wide. Then added mail info (ex. smtp out server etc), booked an appointment and it finally worked. What's going on with Appointments+ plugin how come we are having such a default time sending mail. I've seen some threads regarding this problem.

    FYI:
    Before I installed the WP SMTP plugin I enabled the logs in Appointments+ and the emails were being sent out - but no emails did arrive to the destination inboxes of the service provider or the admin.

    Thanks,

    Tin

    • Jose

      Hi there @hoangker,
      Hope you are doing great.

      Before I installed the WP SMTP plugin I enabled the logs in Appointments+ and the emails were being sent out - but no emails did arrive to the destination inboxes of the service provider or the admin.

      This means that Appointments+ is working just fine.
      Our plugin doesn't provide a custom email outgoing method but just relies on wp_mail() functionality.
      As per the symptoms that you describe, the default outgoing email method wasn't working in your site.
      WP SMTP plugin just overrides wp_mail() to use an smtp server to send the messages.

      In short, the issue wasn't related to our plugin but to outgoing emails in general.

      Hope this shed some light :slight_smile:

      Cheers,
      Jose

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.