Appointments+ not showing correct service name in confirmation box

Hi WPMU team,

When I choose a service and a time in Appointments+, the confirmation drop down box shows the incorrect service name. It always shows the service that is listed as ID = 1, not the one I choose. How can I fix this?
The page in question is: http://supercurls.com.au/make-an-appointment/

Thanks!

  • cliqueco
    • New Recruit

    Hi Timothy,

    Thanks for the quick response. It seems to work fine for you... Whenever I select a different service, it keeps displaying the same default name for Service ID1 (see screenshot).

    I have tested this on different browsers, different computers, even different countries, but the problem still remains. Any reason why it works only for you?

  • cliqueco
    • New Recruit

    I have W3 Total Cache plugin installed on the site.

    I have emptied the caches of the browsers but that didn't work. I also tried disabling the W3 Total Cache plugin but still nothing. I don't see why it can't work for me. I'm at a loss here. I'll try reinstalling the Appointments plugin.

  • Timothy Bowers
    • Chief Pigeon

    Hey just checking in to see how things are going.

    I tested again and it worked fine on various appointments, I never completed booking out this time though, didn't want to fill up your calendar. :slight_smile:

    If they're not, then it might be worth removing W3 cache and all files just temporary whilst we keep testing. I suggest this as the other month that seemed to resolve a similar issue with a non WPMU DEV plugin and ensured no cache from that plugin could be active.

    Then go disable and clear Appointments+ cache:

    Admin --> Appointments + --> Settings

    See Screenshot.

    Let me know how that goes.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.