Appointments+ not syncing correctly with Gcal?

hello, we are having problems with the appointments+ plugin. We are using V1.2.8. We marked an appointment on Gcal and it still shows it as a free time on appoinments+

On the "people, setting appointments" though, it works fine the other way around is not working

1. I am sure my settings are all correct
2. Test connection works
3. mode is set to “syncronization”

  • pxwm

    Hi @amitb,

    I appreciate you have indicated everything is setup correctly but could you please confirm the following:-

    1. Do you just have the main google calendar set up in the A+ 'Google Calendar' tab or do you have individual google calendars setup for each each service provider?
    2. If you just have the main google calendar what results do you get if you click the 'test connection' at the bottom of the A+ 'Google Calendar' tab?
    Does it indicate a success message at the top of the page?
    3. If you have individual A+ google calendars setup for each service provider can you:-
    Log-in to Wordpress using the specific service provider log-in.
    Then select Profile in the left hand menu and scroll down and click the 'test Connection'.
    Does it indicate a success message at the top.
    Repeat for each service provider
    4. In the A+ 'Google Calendar' tab do you have the 'Integration Mode' field set to 'A+<-> GCal (Synchronisation)'?
    5. If all the above is correct could you please create an appointment in your Google Calendar and then either wait 15 mins or Log-in to Wordpress
    Then select A+ settings
    Then select the 'Google Calendar' tab
    Then click the link 'Import and Update Events Now' which is just below the 'Integration Mode' field
    This should indicate at the top of the page that it has updated an event
    If it does then select A+ Appointments and select the 'Reserved for GCAL' tab and the appointment should be located.
    You then have to 'Confirm' the appointment and it will move to the 'Active Appointments' tab.

    If all is fine except item 5 above could you please confirm how many Google calendars you have setup in your Google Account and which calendar you are using to create the appointment?

    Could you also screenpost all the settings in your A+ 'Google Calendar' tab?

    Hope this helps
    Regards
    SteveB
    Then select the

  • amitb

    1. I just have the main google calendar set up in the A+ Google calendar tab also there is no other service provider on the site but me

    2. when I hit test connections, it gives me this message :
    "[Appointments+] Test is successful. Please REFRESH your Google Calendar and check that test appointment has been saved."

    3.

    4. yes it is set to synchronization

    5. did what you asked. updated event, it gave me the message that says something like "400+ of your appointments were..."

    Also the appointment setting on the site is working correctly. when someone sets an appointment, it gets saved/sycronized on my Gcal

    The problem is whenever I add something to my gcal, it still shows me as available on the appointments+ end - which it shouldn't

    Screen shot of my Appointments+ settings:
    http://s22.postimg.org/4jl3ybqvk/appointments.jpg

    Another note I would like to add is that the gcal sync was working perfectly fine before until I discovered that one of my clients were able to book an appointment. even if I set it to unavailable/busy on my gcal.

    Also our host just recently switched/moved us to a different server and I am also wondering if that's also one of the issue that is causing this.

    thank you very much and I appreciate the help

  • pxwm

    Hi,

    Checked your settings and read your feedback and would appreciate if you could try the following:-

    Log-in to Wordpress as Admin
    Select A+ settings
    Select 'Google Calendar' tab
    Save the data using notepad or similar for the following fields:-
    'Key file name' field
    'Service account email address' field
    'Calendar to be used' field
    Then remove the data from the three fields
    Then set 'Integration Mode' field to 'Integration disabled'
    Then take a copy of the following two field:-
    'Event summary (name)' field
    'Event description' field
    Then save the settings
    Then Log-Out

    Then log-in using your Wordpress service provider user profile (not admin)
    Then select 'Profile'
    Then scroll down and populate the same five fields using the data you saved
    Then set 'Integration Mode' field to 'A+<-> GCal (Synchronisation'
    Then save the settings
    Then scroll to the bottom and click the 'test connection' and confirm you receive the success message at the top of the page.
    If all okay log-out

    Then create an appointment directly in your google calendar and test as per my previous post.

    Let me know how you get on

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.