Appointments+ Not Syncing w/ Google Calendar

Hi, we are experiencing a problem with Appointments+ syncing to our clients Google Calendar. I have been going round and round with this problem, but never getting much for a solution.

We installed the Appointments+ plugin on IndyPaint.com and configured the settings as recommended (per the instructions online and the instructions provided by the support rep on your chat). The support rep said the issue may be with our host blocking simple phpmail function, but our host (Hostwinds) says the issue is with the plugin? I then chatted with another support rep, but he ended the chat before the issue was resolved (he recommended setting the time zone to that of the Google Calendar, which needed done, but that did not fix the problem).

This seems like it should be much simpler since we built the API to sync directly with the Google Calendar. Maybe we need to reset the API credentials and start clean?

I greatly appreciate your help.
Thanks.

  • Patrick Freitas

    Hi Sam

    Sorry to hear that you are having this problem.

    I made some test on my website and I could not see any issue on my plugin and Google Calendar.
    You can follow any issue on API console, select the project and you can follow the requests and errors:

    However you can try to sync the appointments logging on WordPress dashboard > Appointments > Settings > Google Calendar > Export and Update to gCal

    If the problem persist I would suggest start over the Google API settings and use another gmail for a test

    Let me know the results
    Have a Great Day,
    Patrick Freitas

  • Sam

    Hi Patrick, your aforementioned tips did not fix the issue and there were no errors being reported on the Google API page, so I decided to reset the API credentials, go through the API setup steps again, and re-register the Google account with Appointments+. After all of that, the plugin is now not able to recognize the Google account I registered.

    I now see a message that says, "There was an error loading your calendars." where there used to be a drop-down to select which email to sync with.

    Please, tell me what I'm doing wrong here.
    Thanks!

  • Patrick Freitas

    Hi Sam

    Yeap, you create the API and Credentials for the account that you will be using on Google Calendar, you will need to allow the plugin use the gCal for this account, also make sure when you allow click to allow the plugin, it has to be done in the same Google Account that you created the API project and credentials. However would't you mind please provide me a stating site or allow me to create a Google Account and run some test, once I wasn't able to replicate on my site I would need have a closer look on your site.

    If you wish you can send me the Gmail Credentials and I can configure on the website.

    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:
    Subject: "Attn: Patrick Freitas"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - Gmail account
    - Temporary Password.

    Let me know when you send me the information or to allow me create a new Gmail account to run some test on the website.

    Have a Great Day
    Best Regards,
    Patrick Freitas

  • Sam

    Ahh, got it. We turned that off and the events are automatically added as "Active" now, however, we need the events to be automatically added to the Google Calendar (we still have to manually change the status from, "Active" to "Reserved by GCal " to import the events to GCal right now).

    I'm sorry if I'm missing where to change that. I have looked top to bottom in the settings and could not find that as an option.

    Thanks again for your help!

  • Patrick Freitas

    Hi Sam

    I'm really sorry about the delay here, somehow we missed this ticket here. I had a closer look on this again, the confirmed status must add this on the google calendar.

    Wouldn't you mind please send me some information and I can run some new tests on your end.

    Note: Don't leave your login details in this ticket.

    Instead, you can send us your details using our contact

    form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: "Attn: Patrick Freitas"

    - Gmail Credentials for the Google Calendar:

    - Site login URL:

    - WordPress admin username:
    - WordPress admin password:

    - Link back to this thread for reference

    - Any other relevant urls/info:

    Please, reply the ticket once you have sent the informations.
    Best Regards
    Patrick Freitas

  • Patrick Freitas

    Hi Sam

    How are you today?

    I had a closer look at the problem, It seems that the Appointment+ can't reach the Google API while the customer is making the appointment.

    When I try to schedule the appointment I get stuck on the loading function and can see an error in the browser console:

    Also, I checked the box to get the appointment on my gCal and wasn't able to skip this part.

    However, I went to the WordPress dashboard > Appointments + > Appointments and could see that the appointments was succeful scheduled.

    It can be caused by a plugin conflict.

    So, would you mind please run a conflict test?

    Remember, is important that you run this test in a staging site, if you can’t do it you must create a full backup.

    Please deactivate all plug-ins just keep the reported one, and check if the problem is gone. If so, then enable all plugins one by one and find which one is creating the issue.

    If you still having this issue, could you do a theme test, much the same as the plugin test, but now you’re testing themes!
    Activate one of the default WordPress themes, like Twenty Sixteen or Twenty Seventeen.

    Here you will find more information: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Let me know the results that you get,
    Best Regards,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.